-
Notifications
You must be signed in to change notification settings - Fork 4
Mac OS X
robnagler edited this page Apr 7, 2023
·
9 revisions
You can turn up verbose debugging:
nfsd verbose up; nfsd verbose up; nfsd verbose up; nfsd verbose
And look in the logs:
log show --predicate 'process == "nfsd"' --debug --info
How to create a bootable USB:
diskutil list
diskutil unmountDisk /dev/disk6
sudo dd if=/Users/nagler/d/Fedora-Server-DVD-x86_64-23.iso of=/dev/rdisk6 bs=1m
diskutil eject /dev/disk6
For Ubuntu:
hdiutil convert -format UDRW -o ~/path/to/target.img ~/path/to/ubuntu.iso
This happened with my Cinema Display. This fixed it:
sudo killall VDCAssistant
Do not enable audio in your VirtualBox VMs. It will be on by default so you have to turn it off in the vagrant's box directory:
VBoxManage modifyvm "$(cat .vagrant/machines/default/virtualbox/id)" --audio none
See how to do this in the Vagrantfile.
If you see this error:
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
You should run:
defaults write org.macosforge.xquartz.X11 enable_iglx -bool true
(On Windows, you might have to add +iglx
, but this isn't tested or known
to be a problem.)