Skip to content

DellForce10MXL

Rob Nagler edited this page Feb 17, 2019 · 4 revisions

Dell Force10 MXL

Show

show interface managementethernet 0/0
sh int m 0/0

show interfaces advertise

show interface status
show interface description

show interface counters.


show int switch te 0/17

show vlan

interface range

Glossary

  • route process module (RPM)
  • switch fabric module (SFM)

Aliases

  • en enable
  • con configure
  • int interface
  • m managementethernet
  • sh show

diag

show tech-support

Issues

  • Can't remove a username(?)
  • LOM1 & LOM2 are on fabric A1 and A2 respectively so need two MXLs
  • Management port can't be on a tagged VLAN?

Connecting to MXL

ssh root@fnl-cmc1
connect switch-1
To exit type CTRL+\
# may take a while if booting, hit <return>

mxl0>en

mxl0#con
mxl0(conf)#

management route 0.0.0.0/0 192.168.2.1
interface ManagementEthernet 0/0
  ip address 192.168.2.111/24
  no shutdown
ip domain-lookup
! ssh has some issue that the console doesn't so disable
no ip ssh server enable
login statistics enable

nor all 802.1p markings on incoming switched traffic on an interface (from INTERFACE mode) or on all interfaces (from CONFIGURATION mode). A CONFIGURATION mode entry supersedes an INTERFACE mode entry.

http://www.dell.com/support/manuals/us/en/19/poweredge-m-io-aggregator/mioa_cli_9.9.0.0_pub/service-class-dynamic-dot1p no service-class dynamic dot1p

10-base-t:

  • In expansion slot 0, the ports are numbered 41 to 44.
  • In expansion slot 1, the ports are numbered 49 to 52.

mxl-0(conf)#interface TenGigabitEthernet 0/41 mxl-0(conf-if-te-0/41)#no ip address mxl-0(conf-if-te-0/41)#portmode hybrid mxl-0(conf-if-te-0/41)#switchport mxl-0(conf-if-te-0/41)#no shutdown mxl-0(conf-if-te-0/41)#exit

interface TenGigabitEthernet 0/41 no ip address portmode hybrid switchport no shutdown exit

clock timezone UTC 0 ntp server 0.centos.pool.ntp.org ntp server 1.centos.pool.ntp.org ntp server 2.centos.pool.ntp.org ntp server 3.centos.pool.ntp.org

mxl-0>show ntp associations show ntp associations remote vrf-Id ref clock st when poll reach delay offset disp

*162.248.241.94 0 129.6.15.30 2 3 16 37 54.52 48.847 876.10 69.61.82.106 0 130.207.244.240 2 9 16 17 48.26 48.948 1888.50 +96.126.105.86 0 132.246.11.231 2 3 16 37 58.69 48.955 877.90

  • master (synced), # master (unsynced), + selected, - candidate mxl-0>show ntp status show ntp status Clock is unsynchronized, stratum 16, no reference clock frequency is 0.000 ppm, stability is 0.000 ppm, precision is 4294967279 reference time is DD8E52CB.189E6000 (21:34:3.096 UTC Sun Oct 15 2017) clock offset is 48.900964 msec, root delay is 0.05228 sec root dispersion is 1.84444 sec, peer dispersion is 25.421 msec peer mode is client

mxl-0(conf)#reload-type mxl-0(conf-reload-type)#boot-type normal-reload mxl-0(conf-reload-type)#no config-scr-download enable mxl-0(conf-reload-type)#exit

Remove a VLAN or interface

no interface vlan 11

int vlan 1 no tagged te 0/1-32

spanning tree

In a standard STP environment, issue the show spanning-tree 0 interface gigabitinterface [unit/port] command to determine the STP characteristics of a port.

show spanning-tree 0 interface gigabitinterface 0/1
show spanning-tree rstp interface gigabitinterface [unit/port]

setup stack and 40gbe

boot system stack-unit 0 primary system: A:
boot system stack-unit 0 secondary system: B:
redundancy auto-synchronize full
hostname mxl0
default vlan-id 11
no iscsi enable

stack-unit 0 provision MXL-10/40GbE
stack-unit 0 stack-group 0
stack-unit 0 stack-group 1
stack-unit 0 priority 14
no stack-unit 0 port 33 portmode quad
no stack-unit 0 port 37 portmode quad

interface TenGigabitEthernet 0/41


interface TenGigabitEthernet 0/1
description fnl0
no ip address
portmode hybrid
switchport
spanning-tree rstp edge-port
! spanning-tree rstp edge-port
no shutdown

interface fortyGigE 0/33
description port-channel_member_10
no ip address
no shutdown

interface fortyGigE 0/33
description port-channel_member_10
no ip address
no shutdown


interface Vlan 1
 no ip address
 tagged TenGigabitEthernet 0/1-32
 tagged Port-channel 1
interface Vlan 2
 description WAN_VLAN
 no ip address
 tagged TenGigabitEthernet 0/1-32
 tagged Port-channel 1

! All frames received on a switch port from a host that does not tag its outbound traffic will be placed by the switch in VLAN 11
interface Vlan 11
description vlan 11
untagged TenGigabitEthernet 0/1-32
untagged Port-channel 10


ip domain-name lhric.local
ip domain-lookup
ip name-server 10.3.4.207
ip name-server 10.3.4.204
ntp server 166.109.254.2
ntp server 166.109.254.4
ntp server 166.109.254.6

banner login ^C
clock timezone UTC +0
no dcb enable
ip ssh server version 2

reload-type
boot-type normal-reload

end

ssh hanging

https://www.force10networks.com/CSPortal20/TechTips/0045_HardwareTroubleshootingGuideforS50.aspx

One known condition that can lead to a console hang is excessive frame flooding due to a topology loop in the network or due to a large number of broadcasts or unknown unicast frames, which a switch will flood to all working interfaces in the same VLAN. Such excessive frame flooding can lead to high CPU utilization as the switch becomes overwhelmed with processing the unwanted frames. To prevent unwanted flooding, try the following:

VLAN Mac OS X

http://www.ogris.de/howtos/macosx-tagged-vlans.html

  1. From the Apple menu (upper left corner of your desktop) choose System Preferences...
  2. Open Network
  3. In the toolbar below all of your network interfaces, click the gear wheel to access a dropdown menu
  4. From that dropdown menu, select Manage Virtual Interfaces...
  5. Click on + to access another dropdown menu
  6. From that dropdown menu, select New VLAN...
  7. Enter an appropriate name for your new VLAN, e.g. DMZ
  8. Enter the desired tag, e.g. 23
  9. Choose the correct physical interface, normally Ethernet
  10. Click Create
  11. Click Done
  12. Configure your new VLAN interface as you would configure a physical interface, e.g. assign it an IP address, network mask, etc.
  13. Click Apply

VLAN tagging linux

https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html/networking_guide/sec-Configure_802_1Q_VLAN_Tagging_Using_the_Command_Line#sec-Setting_Up_802.1Q_VLAN_Tagging_Using_ifcfg_Files

########

14251 files, 307760 used, 1520292 free (2668 frags, 189703 blocks, 0.1% fragmentation)

show system stack-ports
show system brief

enable
configure
no stack-unit 0 port 41 portmode quad
no stack-unit 0 port 42 portmode quad

write memory
reload


In 40GbE mode of operation, the ports are numbered 33 and 37.

Dell> enable
Dell# configure
Dell(conf)# stack-unit 0 stack-group 0 Dell(conf)# stack-unit 0 stack-group 1

To configure the stack so that the roles are assigned according to pre-determined priorities, enter the stack-unit priority command as described in the following Note.
stack-unit unit-number priority number command in CONFIGURATION mode on each stacked switch, where:
stack-unit unit-number identifies the switch in the stack.
priority number specifies the management priority. Range: 1-14. Default: 0.
To remove a port from stacking mode, use the no form of the stack-unit stack- group command; for example, no stack-unit 0 stack-group 0


power-cycle stack-unit unit-number
boot system stack-unitunit-numberprimary system a:

# hostname

hostname name

# Spanning tree enable

To enable RSTP globally for all Layer 2 interfaces, use the following commands.
Dell(conf-if-te-1/1)#show config
!
interface TenGigabitEthernet 1/1
no ip address
switchport
no shutdown
Dell(conf-if-te-1/1)#
1.
2.
Enter PROTOCOL SPANNING TREE RSTP mode. CONFIGURATION mode
protocol spanning-tree rstp
Enable RSTP.
PROTOCOL SPANNING TREE RSTP mode
no disable

Adding and Removing Interfaces
To add and remove interfaces, use the following commands.
To add an interface to the Rapid Spanning Tree topology, con gure it for Layer 2 and it is automatically added. If you previously disabled RSTP on the interface using the command no spanning-tree 0 command, re-enable it using the spanning-tree 0 command.

Con guring an EdgePort
The EdgePort feature enables interfaces to begin forwarding tra c approximately 30 seconds sooner.
In this mode an interface forwards frames by default until it receives a BPDU that indicates that it should behave otherwise; it does not go through the Learning and Listening states. The bpduguard shutdown-on-violation option causes the interface hardware to be shut down when it receives a BPDU. When only bpduguard is implemented, although the interface is placed in an Error Disabled state when receiving the BPDU, the physical interface remains up and spanning-tree drops packets in the hardware after a BPDU violation. BPDUs are dropped in the software after receiving the BPDU violation. This feature is the same as PortFast mode in Spanning Tree.
CAUTION: Con gure EdgePort only on links connecting to an end station. If you enable EdgePort on an interface connected to a network, it can cause loops.

# Enable ntp

ntp server 166.109.254.2
ntp server 166.109.254.4
ntp server 166.109.254.6
ntp server ip-address

# tftp

yum install -y tftp-server tftp
http://www.bo-yang.net/2015/08/31/centos7-install-tftp-server

# copying commands

cd flash:

copy running-config startup-config
copy running-config ftp:// username:password@{hostip | hostname}/filepath/ filename
copy running-config tftp://{hostip | hostname}/ filepath/filename
copy running-config scp://{hostip | hostname}/ filepath/filename

dir flash

show file flash://filename

show running-config
show file-systems

show command-history

Example of Enabling Audit and Security Logs
Dell(conf)#logging extended
Dell#show logging auditlog
Dell#show logging
<0-1> Select syslog version (default = 0)
Dell(conf)#logging version 1
 Specify the server to which you want to send system messages. You can con gure up to eight syslog servers. CONFIGURATION mode
 logging {ip-address | ipv6–address |hostname} {{udp {port}} | {tcp {port}}}
 Add line on a 4.1 BSD UNIX system. local7.debugging /var/log/log7.log
logging facility [facility-type]
– – – –
auth (for authorization messages) cron (for system scheduler m


# Need to disable data center bridging

no dcb enable

# startup
show startup-config:

show hardware stack-unit 0–11 drops [unit 0 [port 0–63]]
show hardware stack-unit 0 drops
show hardware stack-unit 0 drops unit 0 port 1
show hardware stack-unit 2 cpu data-plane statistics

# Interfaces

show running
Current Configuration ...
!
interface GigabitEthernet 9/6
no ip address
shutdown !
interface GigabitEthernet 9/7
  no ip address
  shutdown !
  interface GigabitEthernet 9/8
    no ip address
    shutdown !
    interface GigabitEthernet 9/9
      no ip address
        shutdown



Enter the keyword interface then the type of interface and slot/port information. CONFIGURATION mode
interface interface-type
• For the Management interface on the RPM, enter the keyword ManagementEthernet then the slot/port information.
• For a 10-Gigabit Ethernet interface, enter the keyword TenGigabitEthernet then the slot/port information.
• For a 40-Gigabit Ethernet interface, enter the keyword fortyGigE then the slot/port information.
2. Enable the interface. INTERFACE mode
no shutdown


Dell(conf-if)#show config
!
interface GigabitEthernet 1/2
no ip address
switchport
no shutdown
Dell(conf-if)#ip address 10.10.1.1 /24
% Error: Port is in Layer 2 mode Gi 1/2.
Dell(conf-if)#


show config
show interface

show ip interface

Enabling a Physical Interface

After determining the type of physical interfaces available, to enable and con gure the interfaces, enter INTERFACE mode by using the interface interface slot/port command.

  1. Enter the keyword interface then the type of interface and slot/port information. CONFIGURATION mode interface interface-type • For the Management interface on the RPM, enter the keyword ManagementEthernet then the slot/port information. • For a 10-Gigabit Ethernet interface, enter the keyword TenGigabitEthernet then the slot/port information. • For a 40-Gigabit Ethernet interface, enter the keyword fortyGigE then the slot/port information.
  2. Enable the interface. INTERFACE mode no shutdown

The switch interfaces support Layer 2 and Layer 3 tra c over the 100/1000/10000, 10-Gigabit, and 40-Gigabit Ethernet interfaces. These interfaces can also become part of virtual interfaces such as virtual local area networks (VLANs) or port channels.

Port Channels

Combining physical interfaces (slot/port) to a single IP. You can then use link aggregation and redundancy features.

TODO(robnagler) If we want two drops, we could use this potentially.

Port ranges

ll(conf)# interface range tengigabitethernet 5/1 - 23 Dell(conf-if-range-te-5/1-23)# no shutdown Dell(conf-if-range-te-5/1-23)#

Inventory

show inventory media

Auto negotiation

Example of the negotiation auto Command Dell(conf)# int tengig 0/0 Dell(conf-if)#neg auto

Enabling Directed Broadcast

By default, the system drops directed broadcast packets destined for an interface. This default setting provides some protection against denial of service (DoS) attacks. To enable the system to receive directed broadcasts, use the following command. • Enable directed broadcast. INTERFACE mode ip directed-broadcast To view the con guration, use the show config command in INTERFACE mode.

vlan

https://networkdirection.net/Tagged,+Untagged,+and+Native+VLANs

Native VLANs

The switch assigns any untagged frame that arrives on a tagged port to the native VLAN. If a frame on the native VLAN leaves a trunk (tagged) port, the switch strips the VLAN tag out. In short, the native VLAN is a way of carrying untagged traffic across one or more switches.

Tagged VLANs

A port is a 'tagged port' when the interface is expecting frames containing VLAN tags. An example of this is when two switches are connected, and pass tagged traffic. Cisco switches use the term 'trunk' to refer to a tagged port.

Untagged VLANs

A switchport may be a 'tagged' or 'untagged' port. An untagged port, or access port on a Cisco switch, connects to hosts (such as a server). The host is unaware of any VLAN configuration.

The connected host sends its traffic without any VLAN tag on the frames. When the frame reaches the switch port, the switch will add the VLAN tag. The switch port is configured with a VLAN ID that it will put into the tag. Most switch ports will use this mode by default, with VLAN ID 1.

When a frame leaves an untagged port, the switch strips the VLAN tag from the frame. The traffic is then forwarded as normal.

vlan tagging

http://www.dell.com/support/article/us/en/19/how12148/how-to-configure-switchport-modes-on-dell-networking-n-series-switches?lang=en#Access

Access port is also known as a server port. Switchport

Command Parameters Dell# configure Enter configuration mode. Dell(config)# interface gi 1/0/1 Enter a specific interface. This could be a single physical interface, a range of ports or a port channel interface. Dell(config-if-Gi1/0/1)# switchport mode access Set switchport mode to access. Dell N Series switches are in default switchport mode access out of the box. Dell(config-if-Gi1/0/1)# switchport access vlan 100 Set the interface as a member of the specified VLAN. By default, access mode ports are members of VLAN 1. Dell(config-if-Gi1/0/1)# end Leave interface configuration mode and go back to Privilege EXEC mode Dell# show interfaces switchport gi 1/0/1 Display information on the port to verify the switchport mode configuration.

???? This Interface VLAN 100 description HR_Department_LAN untagged TenGigabitEthernet 0/20

To tag frames leaving an interface in Layer 2 mode, assign that interface to a port-based VLAN to tag it with that VLAN ID. To tag interfaces, use the following commands.

  1. Access INTERFACE VLAN mode of the VLAN to which you want to assign the interface. CONFIGURATION mode interface vlan vlan-id
  2. Enable an interface to include the IEEE 802.1Q tag header. INTERFACE mode tagged interface

Dell#show vlan Codes: * - Default VLAN, G - GVRP VLANs NUM Status Q Ports

  • 1 Inactive 2 Active 3 Active T Po1(So 0/0-1) T Tengig 3/0 T Po1(So 0/0-1) T Tengig 3/1 Dell#config Dell(conf)#int vlan 4 Dell(conf-if-vlan)#tagged po 1 Dell(conf-if-vlan)#show conf ! interface Vlan 4 no ip address tagged Port-channel 1 Dell(conf-if-vlan)#end Dell#show vlan Codes: * - Default VLAN, G - GVRP VLANs NUM Status Q Ports
  • 1 Inactive 2 Active T Po1(So 0/0-1) T Tengig 3/0 822 Virtual LANs (VLANs) 3 Active T Po1(So 0/0-1) T Tengig 3/1 4 Active T Po1(So 0/0-1) Dell# interface Vlan 2 description WAN_VLAN no ip address tagged TenGigabitEthernet 0/1-32 tagged Port-channel 1 Page 6 Dell Networking MXL L2 Switch Configuration Example with Explanations [Defines VLAN 2 as a tagged VLAN that will traverse ports Te0/1-32 and port-channel 1. As a reminder, a “tagged VLAN” simply means that the Ethernet frame header includes the 32-bit dot1Q tag, which includes the VLAN ID number, CoS markings and the 0x8100 hexadecimal label that identifies the frame as an Ethernet frame.] no shutdown ! ! interface Vlan 3 description WAN_Monitoring no ip address tagged TenGigabitEthernet 0/1-32 tagged Port-channel 1 [Defines VLAN 3 as a tagged VLAN that will traverse ports Te0/1-32 and port-channel 1. As a reminder, a “tagged VLAN” simply means that the Ethernet frame header includes the 32-bit dot1Q tag, which includes the VLAN ID number, CoS markings and the 0x8100 hexadecimal label that identifies the frame as an Ethernet frame.] no shutdown ! interface Vlan 11 description vlan 11 untagged TenGigabitEthernet 0/1-32 untagged Port-channel 10 [Defines VLAN 11 as an UNtagged VLAN that will traverse ports Te0/1-32 and port-channel 1. This means that the dot1Q tag or shim does not exist in the Ethernet frame header. All frames received on a switch port from a host that does not tag its outbound traffic will be placed by the switch in VLAN 11.]

Management

management route 0.0.0.0/0 192.168.2.1 [Default route for management VLAN including the next hop/default gateway address] ! ip domain-name lhric.local ip domain-lookup [Creates a switch domain name and enables DNS lookups on the switch itself] ip name-server 10.3.4.207 ip name-server 10.3.4.204

ip ssh server version 2

Configure Storm Control

Storm control is supported in INTERFACE mode and CONFIGURATION mode. Con guring Storm Control from INTERFACE Mode To con gure storm control, use the following command. You can only con gure storm control for ingress tra c in INTERFACE mode. If you con gure storm control from both INTERFACE and CONFIGURATION mode, the INTERFACE mode con gurations override the CONFIGURATION mode con gurations. • Con gure storm control. INTERFACE mode storm control

FTOS

https://niktips.wordpress.com/2016/07/03/dell-force10-part-1-initial-configuration/

spanning tree: It’s a good practice to enable STP as a safeguard mechanism from such configuration errors. https://niktips.wordpress.com/2012/07/16/spanning-tree-protocol-overview/

Flow control: To avoid dropped packets on 10Gb switch ports at times of potential heavy utilization it is also a best practice to as a minimum enable bi-directional Flow Control on the storage array ports.

Dell's SupportAssist helps to automatically open Dell service tickets if there is a switch fault.

How to upgrade: https://niktips.wordpress.com/2015/03/19/force10-mxl-firmware-upgrade/

Jump frames: dont' bother https://niktips.wordpress.com/2012/03/27/jumbo-frames-justified/

Stacking http://humairahmed.com/blog/?p=5857 My setup on the MXL blade in slot A2 is the same ast that of the MXL in slot A1. On the MXL in slot A1, I set its priority to 12 and set its ‘fortyGigE 0/33′ port to a stacking port and reload. On the MXL in slot A2, I set its priority to 11 and set its ‘fortyGigE 0/33′ port to a stacking port and reload. The switch set to a higher priority becomes the management switch for the stack and the other switch becomes standby. T

I will always prefer VLT over stacking if it meets customer requirements. In many designs I’ve recommended and helped create for customers, it’s been a while since I created a design where I had to incorporate stacking. However, there is nothing wrong with using stacking and some customers prefer it as they find it more familiar, or they already have a standard architecture that they continually replicate and want to stick to.

Getting started guide

p9 To change a port from 4x10GbEto40GbEmodeofoperation,entertheno stack-unit port portmode quad command. Dell(conf)# no stack-unit unit-number port port-number portmode quad Valid values for slot 0: 41 or 45; for slot 1: 49 or 53 (refer to Port Numbering).

Save the configuration and reload the switch. Dell# write memory Dell# reload

• show run | grep Ethernet ignore-case returns instances containing both “Ethernet” and “ethernet.”

Dell(conf)#do show stack-unit all stack-ports all pfc details | except 0

The find keyword displays the output of the show command beginning from the rst occurrence of speci ed text. show stack-unit all stack-ports all pfc details | find 0

The no-more command displays the output all at once rather than one screen at a time. This is similar to the terminal length command except that the no-more option a ects the output of the speci ed command only.

You can lter a single command output multiple times. The save option must be the last option entered. For example:Dell# command | grep regular-expression | except regular-expression | grep other- regular-expression | find regular-expression | save. p The save command copies the output to a le for future reference. n

Clone this wiki locally