forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
sys-apps/xdg-desktop-portal-gnome: Version bump to 45_alpha
Signed-off-by: Guillermo Joandet <[email protected]> Closes: gentoo#31961 Signed-off-by: Matt Turner <[email protected]>
- Loading branch information
Showing
3 changed files
with
47 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST xdg-desktop-portal-gnome-44.1.tar.xz 127504 BLAKE2B ceae17bc5aea4c3c6a8420af56439698cbb57fbb35f7ba671a8469778aa87843314db6f021c92a8c69859d5943cf4d568069b94050fa89e27f08a0c0bd398366 SHA512 58e165b06a7b8dd8dd87cd2874db87e1e6e608e9752334f6c1ae341acd28857dca2d02ef1659b174dd4041897e898455ee99cde1cdf4b28f9e3a88d4dba73989 | ||
DIST xdg-desktop-portal-gnome-45.alpha.tar.xz 127556 BLAKE2B f655b2c2cf2d1c64c4ab8018bc7999ae570ec5d1c007b9ac088b3932ec36b9101fff35e455478a14c0759d48499dbba0054544a3fec2d0d99331aa3c65765da5 SHA512 6003604cc5a6c3cf78c4ac4a312d530918a7b9c651bd28ea1375b21ce3d9e4b2349678107de716b71cb10aef19eb5fb9a57922c8cf2bcf305afb99d5e74c775b |
45 changes: 45 additions & 0 deletions
45
sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-45_alpha.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,45 @@ | ||
# Copyright 1999-2023 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
inherit gnome.org meson systemd xdg | ||
|
||
DESCRIPTION="Backend implementation for xdg-desktop-portal using GNOME" | ||
HOMEPAGE="https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome" | ||
|
||
LICENSE="LGPL-2.1" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86" | ||
IUSE="wayland X" | ||
|
||
# Newer-than-strictly-required xdg-desktop-portal dep for hang/slowness fixes | ||
# https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome/-/issues/74 | ||
DEPEND=" | ||
dev-libs/glib:2 | ||
gnome-base/gnome-desktop:4= | ||
gui-libs/libadwaita:1 | ||
media-libs/fontconfig | ||
sys-apps/dbus | ||
>=sys-apps/xdg-desktop-portal-1.16.0-r1 | ||
>=sys-apps/xdg-desktop-portal-gtk-1.14.0 | ||
gui-libs/gtk:4[wayland?,X?] | ||
X? ( x11-libs/libX11 ) | ||
wayland? ( dev-libs/wayland ) | ||
" | ||
RDEPEND="${DEPEND}" | ||
BDEPEND=" | ||
dev-util/gdbus-codegen | ||
sys-devel/gettext | ||
virtual/pkgconfig | ||
wayland? ( dev-util/wayland-scanner ) | ||
" | ||
|
||
src_configure() { | ||
local emesonargs=( | ||
-Dsystemduserunitdir="$(systemd_get_userunitdir)" | ||
) | ||
|
||
meson_src_configure | ||
} |