forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-libs/libva: fix link with LLD 17
Upstream-PR: intel/libva#732 Signed-off-by: Violet Purcell <[email protected]>
- Loading branch information
Showing
2 changed files
with
50 additions
and
0 deletions.
There are no files selected for viewing
46 changes: 46 additions & 0 deletions
46
media-libs/libva/files/libva-2.20.0-no-undefined-version.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,46 @@ | ||
From https://github.com/intel/libva/commit/17e07d17ba723a6b5822390afacdd3ccd976ecd2 Mon Sep 17 00:00:00 2001 | ||
From: Violet Purcell <[email protected]> | ||
Date: Sun, 1 Oct 2023 16:34:19 -0400 | ||
Subject: [PATCH] va: Fix -Wl,--version-script check with LLD 17 | ||
|
||
LLD 17 uses --no-undefined-version by default, so the check currently | ||
fails due to vaCreateSurface being undefined. This commit replaces that | ||
check with a generic check in the top level meson.build, using the | ||
conftest.syms file. | ||
|
||
Signed-off-by: Violet Purcell <[email protected]> | ||
--- /dev/null | ||
+++ b/conftest.syms | ||
@@ -0,0 +1,6 @@ | ||
+VERSION_1 { | ||
+ global: | ||
+ main; | ||
+ local: | ||
+ *; | ||
+}; | ||
--- a/meson.build | ||
+++ b/meson.build | ||
@@ -87,6 +87,12 @@ dl_dep = cc.find_library('dl', required : false) | ||
WITH_DRM = not get_option('disable_drm') and (host_machine.system() != 'windows') | ||
libdrm_dep = dependency('libdrm', version : '>= 2.4.60', required : (host_machine.system() != 'windows')) | ||
|
||
+ld_supports_version_script = cc.links( | ||
+ 'int main() { return 0; }', | ||
+ name : '-Wl,--version-script', | ||
+ args : ['-shared', '-Wl,--version-script,' + '@0@/@1@'.format(meson.current_source_dir(), 'conftest.syms')] | ||
+) | ||
+ | ||
WITH_X11 = false | ||
if get_option('with_x11') != 'no' | ||
x11_dep = dependency('x11', required : get_option('with_x11') == 'yes') | ||
--- a/va/meson.build | ||
+++ b/va/meson.build | ||
@@ -60,7 +60,7 @@ libva_sym_arg = '-Wl,-version-script,' + '@0@/@1@'.format(meson.current_source_d | ||
|
||
libva_link_args = [] | ||
libva_link_depends = [] | ||
-if cc.links('', name: '-Wl,--version-script', args: ['-shared', libva_sym_arg]) | ||
+if ld_supports_version_script | ||
libva_link_args = libva_sym_arg | ||
libva_link_depends = libva_sym | ||
endif |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters