Skip to content

Commit

Permalink
Merge pull request #3 from tsukuba-hpcs/add-gfarm
Browse files Browse the repository at this point in the history
  • Loading branch information
onokatio authored Jun 7, 2024
2 parents 29bc311 + d1edb50 commit 9c27c17
Showing 1 changed file with 34 additions and 0 deletions.
34 changes: 34 additions & 0 deletions packages/gfarm/package.py
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
from spack.package import *


class Gfarm(AutotoolsPackage):
'''distributed file system for large-scale cluster computing and wide-area data sharing. provides fine-grained replica location control.'''

homepage = 'https://github.com/oss-tsukuba/gfarm'
url = 'https://github.com/oss-tsukuba/gfarm/archive/refs/tags/2.8.0.tar.gz'
git = 'https://github.com/oss-tsukuba/gfarm.git'

version('master', branch='master')
version('2.8.0', tag='2.8.0', preferred=True)
version('2.7.25', tag='2.7.25')

variant('infiniband', default=False, description='enable InfiniBand')

depends_on('postgresql')
depends_on('openssl')
depends_on('rdma-core', when="+infiniband")
depends_on('py-docopt')
depends_on('py-schema')

depends_on('autoconf', type=('build'))
depends_on('automake', type=('build'))
depends_on('libtool', type=('build'))
depends_on('pkgconfig', type=('build'))

def configure_args(self):
args = []

if '+infiniband' in self.spec:
args.extend(['--with-infiniband'])

return args

0 comments on commit 9c27c17

Please sign in to comment.