-
Notifications
You must be signed in to change notification settings - Fork 1
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Merge pull request #3 from tsukuba-hpcs/add-gfarm
- Loading branch information
Showing
1 changed file
with
34 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,34 @@ | ||
from spack.package import * | ||
|
||
|
||
class Gfarm(AutotoolsPackage): | ||
'''distributed file system for large-scale cluster computing and wide-area data sharing. provides fine-grained replica location control.''' | ||
|
||
homepage = 'https://github.com/oss-tsukuba/gfarm' | ||
url = 'https://github.com/oss-tsukuba/gfarm/archive/refs/tags/2.8.0.tar.gz' | ||
git = 'https://github.com/oss-tsukuba/gfarm.git' | ||
|
||
version('master', branch='master') | ||
version('2.8.0', tag='2.8.0', preferred=True) | ||
version('2.7.25', tag='2.7.25') | ||
|
||
variant('infiniband', default=False, description='enable InfiniBand') | ||
|
||
depends_on('postgresql') | ||
depends_on('openssl') | ||
depends_on('rdma-core', when="+infiniband") | ||
depends_on('py-docopt') | ||
depends_on('py-schema') | ||
|
||
depends_on('autoconf', type=('build')) | ||
depends_on('automake', type=('build')) | ||
depends_on('libtool', type=('build')) | ||
depends_on('pkgconfig', type=('build')) | ||
|
||
def configure_args(self): | ||
args = [] | ||
|
||
if '+infiniband' in self.spec: | ||
args.extend(['--with-infiniband']) | ||
|
||
return args |