Skip to content

Commit

Permalink
chore(sync): 39 -> 40
Browse files Browse the repository at this point in the history
  • Loading branch information
madonuko committed Feb 13, 2024
1 parent fd1ab0d commit 91a4934
Show file tree
Hide file tree
Showing 9 changed files with 55 additions and 24 deletions.
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@
%global __provides_exclude_from %{_datadir}/%{name}/.*\\.so

Name: discord-canary-openasar
Version: 0.0.276
Version: 0.0.277
Release: 1%{?dist}
Summary: A snappier Discord rewrite with features like further customization and theming
License: MIT AND https://discord.com/terms
Expand Down
2 changes: 1 addition & 1 deletion anda/apps/discord-canary/discord-canary.spec
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@
%global __provides_exclude_from %{_datadir}/%{name}/.*\\.so

Name: discord-canary
Version: 0.0.276
Version: 0.0.277
Release: 1%{?dist}
Summary: Free Voice and Text Chat for Gamers
URL: discord.com
Expand Down
2 changes: 1 addition & 1 deletion anda/apps/discord-openasar/discord-openasar.spec
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@
%global __provides_exclude_from %{_datadir}/%{name}/.*\\.so

Name: discord-openasar
Version: 0.0.42
Version: 0.0.43
Release: 1%{?dist}
Summary: A snappier Discord rewrite with features like further customization and theming
License: MIT AND https://discord.com/terms
Expand Down
2 changes: 1 addition & 1 deletion anda/apps/discord/discord.spec
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@
%global __provides_exclude_from %{_datadir}/%{name}/.*\\.so

Name: discord
Version: 0.0.42
Version: 0.0.43
Release: 1%{?dist}
Summary: Free Voice and Text Chat for Gamers
URL: https://discord.com
Expand Down
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# from Fedora upstream
%global extension pop-shell
%global uuid %{extension}@system76.com
%global commit cf3c932b55d5c247906efe9d81f988ee092d9f51
%global commit 9a30c5bd49c373896410852d6477596ac4c43bd3
%global shortcommit %{lua:print(macros.commit:sub(1,7))}
%global ver 1.2.0

Expand Down
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
Name: ayatana-indicator-datetime
Summary: A GTK implementation of the StatusNotifierItem Specification
Version: 23.10.1
Version: 24.2.0
Release: 1%{?dist}
License: GPL-3.0
URL: https://github.com/AyatanaIndicators/ayatana-indicator-datetime
Expand Down
63 changes: 47 additions & 16 deletions anda/langs/nim/nim/nim.spec
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

Name: nim
Version: 2.0.2
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Imperative, multi-paradigm, compiled programming language
License: MIT and BSD
URL: https://nim-lang.org
Expand Down Expand Up @@ -56,30 +56,54 @@ export FCFLAGS="${FCFLAGS} -Ofast"
export PATH="$(pwd):$(pwd)/bin:${PATH}"

mold -run nim c -d:danger koch.nim
mold -run koch boot -d:useLinenoise -t:-fPIE -l:-pie
mold -run koch boot -d:useLinenoise -t:-fPIE -l:-pie -d:release -d:nativeStacktrace -d:useGnuReadline

mold -run koch docs &
(cd lib; mold -run nim c --app:lib -d:danger -d:createNimRtl -t:-fPIE -l:-pie nimrtl.nim) &
(cd lib && nim c --app:lib -d:createNimRtl -d:release nimrtl.nim) &
mold -run koch tools -t:-fPIE -l:-pie &
mold -run nim c -t:-fPIE -l:-pie -d:danger nimsuggest/nimsuggest.nim &
mold -run nim c -t:-fPIE -l:-pie -d:release nimsuggest/nimsuggest.nim &
wait

sed -i '/<link.*fonts.googleapis.com/d' doc/html/*.html


%install
export PATH="$(pwd):$(pwd)/bin:${PATH}"
sh install.sh %{buildroot}usr/bin

mkdir -p %{buildroot}/%{_bindir}
install -Dp -m755 bin/nim{,ble,grep,suggest,pretty} %{buildroot}/%{_bindir}
install -Dp -m644 tools/nim.bash-completion %{buildroot}%{bashcompdir}/nim
mkdir -p %buildroot{%_bindir,%_docdir/%name/html,%_prefix/lib/nim}
install -Dp -m755 bin/nim{,ble,grep,suggest,pretty} %buildroot/%_bindir
install -Dp -m644 dist/nimble/nimble.bash-completion %{buildroot}%{bashcompdir}/nimble
install -Dp -m644 -t%{buildroot}%{_mandir}/man1 %SOURCE1 %SOURCE2 %SOURCE3 %SOURCE4

mkdir -p %{buildroot}%{_docdir}/%{name}/html %buildroot%_prefix/lib/nim
cp -a doc/html/*.html %{buildroot}%{_docdir}/%{name}/html/
# completions
for comp in tools/*.bash-completion; do
install -Dm644 $comp %bashcompdir/$(basename "${comp/.bash-completion}")
done
for comp in tools/*.zsh-completion; do
install -Dm644 $comp %zshcompdir/_$(basename "${comp/.zsh-completion}")
done

cp -a doc/html/*.html %buildroot%_docdir/%name/html/
cp tools/dochack/dochack.js %{buildroot}%{_docdir}/%{name}/
cp -r lib %buildroot%_prefix/lib/nim/
cp -a lib %buildroot%_prefix/lib/nim
cp -a compiler %buildroot%_prefix/lib/nim
install -Dm644 nim.nimble %buildroot%_prefix/lib/nim/compiler
ls **
ls %buildroot%_prefix/lib/nim/*
install -m755 lib/libnimrtl.so %buildroot%_prefix/lib/libnimrtl.so

install -Dm644 config/* -t %buildroot/etc/nim
install -Dm755 bin/* -t %buildroot%_bindir

install -d %buildroot%_includedir
cp -a %buildroot%_prefix/lib/nim/lib/*.h %buildroot%_includedir

ln -s %_datadir/nim/doc %buildroot%_prefix/lib/nim/doc

ln -s %_prefix/lib/nim %buildroot%_prefix/lib/nim/lib

rm -rf %buildroot/nim || true
rm %buildroot%_bindir/*.bat || true

%check
# export PATH=$PATH:$(realpath ./bin)
Expand All @@ -91,19 +115,26 @@ cp -r lib %buildroot%_prefix/lib/nim/
%files
%license copying.txt dist/nimble/license.txt
%doc doc/readme.txt
/etc/nim/
%_bindir/atlas
%_bindir/nim_dbg
%_bindir/nim-gdb
%_bindir/testament
%_prefix/lib/nim/
%_prefix/lib/libnimrtl.so
%{_bindir}/nim{,ble}
%{_mandir}/man1/nim{,ble}.1*
%_prefix/lib/nim/
%_includedir/cycle.h
%_includedir/nimbase.h

%files tools
%license copying.txt
%_prefix/lib/nim/
%{_bindir}/nim{grep,suggest,pretty}
%{_mandir}/man1/nim{grep,suggest}.1*

%%files doc
%files doc
%doc %{_docdir}/nim


%changelog
* Mon Jan 9 2023 windowsboy111 <[email protected]> - 0.8.4
- Initial Package.
%autochangelog
2 changes: 1 addition & 1 deletion anda/langs/rust/bat-extras/bat-extras.spec
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
%define debug_package %{nil}

Name: bat-extras
Version: 2023.09.19
Version: 2024.02.12
Release: 1%{?dist}
Summary: Bash scripts that integrate bat with various command line tools

Expand Down
2 changes: 1 addition & 1 deletion anda/system/xpadneo/xpadneo.spec
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@
%endif

Name: xpadneo
Version: 0.9.5
Version: 0.9.6
Release: 1%{?dist}
Summary: Advanced Linux Driver for Xbox One Wireless Gamepad
Group: System Environment/Kernel
Expand Down

0 comments on commit 91a4934

Please sign in to comment.