Merge pull request #202 from stader-labs/fix_zero_cycle_in_claim_sp #331
Annotations
10 errors
Golangci-lint:
shared/utils/arr-utils/arr.go#L1
var-naming: don't use an underscore in package name (revive)
|
Golangci-lint:
shared/utils/arr-utils/arr.go#L9
return statements should not be cuddled if block has more than two lines (wsl)
|
Golangci-lint:
shared/utils/stdr/config.go#L61
octalLiteral: use new octal literal style, 0o664 (gocritic)
|
Golangci-lint:
shared/utils/stdr/validator-state.go#L59
hugeParam: validatorInfo is heavy (128 bytes); consider passing it by pointer (gocritic)
|
Golangci-lint:
shared/utils/stdr/validator-state.go#L63
hugeParam: beaconValidatorStatus is heavy (168 bytes); consider passing it by pointer (gocritic)
|
Golangci-lint:
shared/utils/stdr/validator-state.go#L49
rangeValCopy: each iteration copies 128 bytes (consider pointers or indexing) (gocritic)
|
Golangci-lint:
shared/utils/stdr/validator-state.go#L41
unused-parameter: parameter 'operatorId' seems to be unused, consider removing or renaming it as _ (revive)
|
Golangci-lint:
shared/utils/stdr/validator-state.go#L34
var-naming: struct field OperatorId should be OperatorID (revive)
|
Golangci-lint:
shared/utils/stdr/fee-recipient.go#L17
unused-parameter: parameter 'vf' seems to be unused, consider removing or renaming it as _ (revive)
|
Golangci-lint:
shared/utils/stdr/fee-recipient.go#L24
var-naming: var operatorId should be operatorID (revive)
|
Loading