Skip to content

Commit

Permalink
Merge pull request #24 from rdkcentral/develop
Browse files Browse the repository at this point in the history
Develop to main
  • Loading branch information
deepthi-ps authored Sep 12, 2024
2 parents b78b95c + f42ecc5 commit 99141bb
Show file tree
Hide file tree
Showing 20 changed files with 73 additions and 14 deletions.
8 changes: 8 additions & 0 deletions conf/layer.conf
Original file line number Diff line number Diff line change
Expand Up @@ -24,3 +24,11 @@ BBFILES += "${LAYERDIR}/meta-rdk-oss-reference/recipes-multimedia/gstreamer/gstr
${LAYERDIR}/meta-rdk-oss-reference/recipes-kernel/make-mod-scripts/*.bbappend \
${LAYERDIR}/recipes-graphics/mesa/mesa_%.bbappend \
"

# OSS layer is customising wayland and removing wayland-egl.so and PC file causing build errors.
BBFILES += " \
${LAYERDIR}/recipes-graphics/wayland/wayland-default-egl_1.18.0.bb \
${LAYERDIR}/recipes-graphics/mesa/mesa_%.bbappend \
${LAYERDIR}/recipes-workaround/westeros/westeros.bbappend \
${LAYERDIR}/recipes-workaround/gstreamer/gstreamer1.0-plugins-base_%.bbappend \
"
26 changes: 26 additions & 0 deletions recipes-graphics/wayland/files/CMakeLists.txt
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
cmake_minimum_required(VERSION 3.15)

project(wayland-egl VERSION 1.18.0 DESCRIPTION "Frontend wayland-egl library")

include(GNUInstallDirs)

add_library(${PROJECT_NAME} SHARED wayland-egl.c)

set_target_properties(${PROJECT_NAME} PROPERTIES
VERSION 1.0.0 SOVERSION 1)

install(TARGETS ${PROJECT_NAME} LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})

set(prefix "/usr")
set(exec_prefix "\${prefix}")
set(libdir "\${exec_prefix}/lib")
set(includedir "\${prefix}/include")

configure_file(
${CMAKE_CURRENT_SOURCE_DIR}/wayland-egl.pc.in
${CMAKE_CURRENT_BINARY_DIR}/wayland-egl.pc
@ONLY)

# Install the pkg-config file
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/wayland-egl.pc
DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
32 changes: 32 additions & 0 deletions recipes-graphics/wayland/wayland-default-egl_1.18.0.bb
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
# This recipe's intended to provide only the wayland-egl.so and related pkgconfig
# due to the non-standard wayland package delivery from OSS layer.
# Refer: ./common/meta-rdk-oss-reference/recipes-graphics/wayland/wayland_%.bbappend

HOMEPAGE = "http://wayland.freedesktop.org"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://../COPYING;md5=b31d8f53b6aaf2b4985d7dd7810a70d1 \
file://../src/wayland-server.c;endline=24;md5=b8e046164a766bb1ede8ba38e9dcd7ce"

DEPENDS = "wayland"
RDEPENDS_${PN} = "wayland"

SRC_URI = "https://wayland.freedesktop.org/releases/wayland-${PV}.tar.xz \
file://CMakeLists.txt \
"

SRC_URI[md5sum] = "23317697b6e3ff2e1ac8c5ba3ed57b65"
SRC_URI[sha256sum] = "4675a79f091020817a98fd0484e7208c8762242266967f55a67776936c2e294d"

UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html"

S = "${WORKDIR}/wayland-${PV}/egl"

PV ?= "1.18.0"
PR ?= "r0"

inherit cmake pkgconfig

do_configure_prepend() {
cp ${WORKDIR}/CMakeLists.txt ${S}
}

4 changes: 4 additions & 0 deletions recipes-graphics/westeros/essos.bbappend
Original file line number Diff line number Diff line change
@@ -1 +1,5 @@
CXXFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'enable_ermgr', ' -DUSE_ESSRMGR_UDS_IMPL', '', d)}"

# wayland-egl provider for RPi is now changed from wayland to wayland-default-egl.
DEPENDS += "wayland-default-egl"
RDEPENDS_${PN} += "wayland-default-egl"
1 change: 0 additions & 1 deletion recipes-workaround/cairo/cairo_%.bbappend

This file was deleted.

This file was deleted.

1 change: 0 additions & 1 deletion recipes-workaround/gstreamer/gstreamer1.0-libav_%.bbappend

This file was deleted.

This file was deleted.

Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DEPENDS += "wayland-default-egl"
RDEPENDS_${PN} += "wayland-default-egl"

This file was deleted.

1 change: 0 additions & 1 deletion recipes-workaround/libepoxy/libepoxy_%.bbappend

This file was deleted.

1 change: 0 additions & 1 deletion recipes-workaround/librsvg/librsvg_%.bbappend

This file was deleted.

1 change: 0 additions & 1 deletion recipes-workaround/pango/pango_%.bbappend

This file was deleted.

1 change: 0 additions & 1 deletion recipes-workaround/userland/userland_git.bbappend

This file was deleted.

1 change: 0 additions & 1 deletion recipes-workaround/westeros/essos.bbappend

This file was deleted.

1 change: 0 additions & 1 deletion recipes-workaround/westeros/westeros-simplebuffer.bbappend

This file was deleted.

1 change: 0 additions & 1 deletion recipes-workaround/westeros/westeros-simpleshell.bbappend

This file was deleted.

1 change: 0 additions & 1 deletion recipes-workaround/westeros/westeros-sink.bbappend

This file was deleted.

1 change: 0 additions & 1 deletion recipes-workaround/westeros/westeros-soc-drm.bbappend

This file was deleted.

2 changes: 2 additions & 0 deletions recipes-workaround/westeros/westeros.bbappend
Original file line number Diff line number Diff line change
@@ -1 +1,3 @@
# wayland-egl provider for RPi is now changed from wayland to wayland-default-egl.
DEPENDS += "wayland-default-egl"
RDEPENDS_${PN} += "wayland-default-egl"

0 comments on commit 99141bb

Please sign in to comment.