-
Notifications
You must be signed in to change notification settings - Fork 2
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Merge pull request #24 from rdkcentral/develop
Develop to main
- Loading branch information
Showing
20 changed files
with
73 additions
and
14 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,26 @@ | ||
cmake_minimum_required(VERSION 3.15) | ||
|
||
project(wayland-egl VERSION 1.18.0 DESCRIPTION "Frontend wayland-egl library") | ||
|
||
include(GNUInstallDirs) | ||
|
||
add_library(${PROJECT_NAME} SHARED wayland-egl.c) | ||
|
||
set_target_properties(${PROJECT_NAME} PROPERTIES | ||
VERSION 1.0.0 SOVERSION 1) | ||
|
||
install(TARGETS ${PROJECT_NAME} LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}) | ||
|
||
set(prefix "/usr") | ||
set(exec_prefix "\${prefix}") | ||
set(libdir "\${exec_prefix}/lib") | ||
set(includedir "\${prefix}/include") | ||
|
||
configure_file( | ||
${CMAKE_CURRENT_SOURCE_DIR}/wayland-egl.pc.in | ||
${CMAKE_CURRENT_BINARY_DIR}/wayland-egl.pc | ||
@ONLY) | ||
|
||
# Install the pkg-config file | ||
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/wayland-egl.pc | ||
DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,32 @@ | ||
# This recipe's intended to provide only the wayland-egl.so and related pkgconfig | ||
# due to the non-standard wayland package delivery from OSS layer. | ||
# Refer: ./common/meta-rdk-oss-reference/recipes-graphics/wayland/wayland_%.bbappend | ||
|
||
HOMEPAGE = "http://wayland.freedesktop.org" | ||
LICENSE = "MIT" | ||
LIC_FILES_CHKSUM = "file://../COPYING;md5=b31d8f53b6aaf2b4985d7dd7810a70d1 \ | ||
file://../src/wayland-server.c;endline=24;md5=b8e046164a766bb1ede8ba38e9dcd7ce" | ||
|
||
DEPENDS = "wayland" | ||
RDEPENDS_${PN} = "wayland" | ||
|
||
SRC_URI = "https://wayland.freedesktop.org/releases/wayland-${PV}.tar.xz \ | ||
file://CMakeLists.txt \ | ||
" | ||
|
||
SRC_URI[md5sum] = "23317697b6e3ff2e1ac8c5ba3ed57b65" | ||
SRC_URI[sha256sum] = "4675a79f091020817a98fd0484e7208c8762242266967f55a67776936c2e294d" | ||
|
||
UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html" | ||
|
||
S = "${WORKDIR}/wayland-${PV}/egl" | ||
|
||
PV ?= "1.18.0" | ||
PR ?= "r0" | ||
|
||
inherit cmake pkgconfig | ||
|
||
do_configure_prepend() { | ||
cp ${WORKDIR}/CMakeLists.txt ${S} | ||
} | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,5 @@ | ||
CXXFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'enable_ermgr', ' -DUSE_ESSRMGR_UDS_IMPL', '', d)}" | ||
|
||
# wayland-egl provider for RPi is now changed from wayland to wayland-default-egl. | ||
DEPENDS += "wayland-default-egl" | ||
RDEPENDS_${PN} += "wayland-default-egl" |
This file was deleted.
Oops, something went wrong.
1 change: 0 additions & 1 deletion
1
recipes-workaround/devicesettings/devicesettings-hal-raspberrypi4_%.bbappend
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
1 change: 0 additions & 1 deletion
1
recipes-workaround/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
This file was deleted.
Oops, something went wrong.
1 change: 1 addition & 0 deletions
1
recipes-workaround/gstreamer/gstreamer1.0-plugins-base_%.bbappend
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DEPENDS += "wayland-default-egl" | ||
RDEPENDS_${PN} += "wayland-default-egl" |
1 change: 0 additions & 1 deletion
1
recipes-workaround/gstreamer/gstreamer1.0-plugins-good_%.bbappend
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,3 @@ | ||
# wayland-egl provider for RPi is now changed from wayland to wayland-default-egl. | ||
DEPENDS += "wayland-default-egl" | ||
RDEPENDS_${PN} += "wayland-default-egl" |