Skip to content

Commit

Permalink
libpcap: update to 1.10.5
Browse files Browse the repository at this point in the history
  • Loading branch information
AuthorReflex authored and hauke committed Sep 22, 2024
1 parent 37cedc7 commit c7671a2
Show file tree
Hide file tree
Showing 4 changed files with 26 additions and 26 deletions.
4 changes: 2 additions & 2 deletions package/libs/libpcap/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=libpcap
PKG_VERSION:=1.10.4
PKG_VERSION:=1.10.5
PKG_RELEASE:=1

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.tcpdump.org/release/
PKG_HASH:=ed19a0383fad72e3ad435fd239d7cd80d64916b87269550159d20e47160ebe5f
PKG_HASH:=37ced90a19a302a7f32e458224a00c365c117905c2cd35ac544b6880a81488f0

PKG_MAINTAINER:=Felix Fietkau <[email protected]>
PKG_LICENSE:=BSD-3-Clause
Expand Down
14 changes: 7 additions & 7 deletions package/libs/libpcap/patches/100-no-openssl.patch
Original file line number Diff line number Diff line change
@@ -1,10 +1,10 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1325,7 +1325,6 @@ endif()
#
# OpenSSL/libressl.
#
-find_package(OpenSSL)
if(OPENSSL_FOUND)
@@ -1441,7 +1441,6 @@ if(ENABLE_REMOTE)
#
# We have OpenSSL.
# OpenSSL/libressl.
#
- find_package(OpenSSL)
if(OPENSSL_FOUND)
#
# We have OpenSSL.
2 changes: 1 addition & 1 deletion package/libs/libpcap/patches/102-skip-manpages.patch
Original file line number Diff line number Diff line change
Expand Up @@ -9,7 +9,7 @@ Subject: [PATCH] skip manpages

--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3325,57 +3325,6 @@ if(NOT MSVC)
@@ -3548,57 +3548,6 @@ if(NOT MSVC)
if(MINGW)
find_program(LINK_EXECUTABLE ln)
endif(MINGW)
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -36,7 +36,7 @@ Signed-off-by: Linus Lüssing <[email protected]>

--- a/Makefile.in
+++ b/Makefile.in
@@ -133,6 +133,8 @@ PUBHDR = \
@@ -130,6 +130,8 @@ PUBHDR = \
HDR = $(PUBHDR) \
arcnet.h \
atmuni31.h \
Expand Down Expand Up @@ -220,7 +220,7 @@ Signed-off-by: Linus Lüssing <[email protected]>
#endif
--- a/gencode.c
+++ b/gencode.c
@@ -60,6 +60,8 @@
@@ -58,6 +58,8 @@
#include "sunatmpos.h"
#include "pflog.h"
#include "ppp.h"
Expand All @@ -229,7 +229,7 @@ Signed-off-by: Linus Lüssing <[email protected]>
#include "pcap/sll.h"
#include "pcap/ipnet.h"
#include "arcnet.h"
@@ -9436,6 +9438,168 @@ gen_geneve(compiler_state_t *cstate, bpf
@@ -9704,6 +9706,168 @@ gen_geneve(compiler_state_t *cstate, bpf
return b1;
}

Expand Down Expand Up @@ -412,15 +412,15 @@ Signed-off-by: Linus Lüssing <[email protected]>
struct block *gen_atmtype_abbrev(compiler_state_t *, int);
--- a/grammar.y.in
+++ b/grammar.y.in
@@ -375,6 +375,7 @@ DIAG_OFF_BISON_BYACC
@@ -383,6 +383,7 @@ DIAG_OFF_BISON_BYACC
%type <i> mtp2type
%type <blk> mtp3field
%type <blk> mtp3fieldvalue mtp3value mtp3listvalue
+%type <rblk> pbatadv


%token DST SRC HOST GATEWAY
@@ -393,7 +394,7 @@ DIAG_OFF_BISON_BYACC
@@ -401,7 +402,7 @@ DIAG_OFF_BISON_BYACC
%token LEN
%token IPV6 ICMPV6 AH ESP
%token VLAN MPLS
Expand All @@ -429,7 +429,7 @@ Signed-off-by: Linus Lüssing <[email protected]>
%token ISO ESIS CLNP ISIS L1 L2 IIH LSP SNP CSNP PSNP
%token STP
%token IPX
@@ -620,11 +621,40 @@ other: pqual TK_BROADCAST { CHECK_PTR_
@@ -698,11 +699,40 @@ other: pqual TK_BROADCAST { CHECK_PTR_
| PPPOES { CHECK_PTR_VAL(($$ = gen_pppoes(cstate, 0, 0))); }
| GENEVE pnum { CHECK_PTR_VAL(($$ = gen_geneve(cstate, $2, 1))); }
| GENEVE { CHECK_PTR_VAL(($$ = gen_geneve(cstate, 0, 0))); }
Expand Down Expand Up @@ -472,7 +472,7 @@ Signed-off-by: Linus Lüssing <[email protected]>
| PF_RNR NUM { CHECK_PTR_VAL(($$ = gen_pf_rnr(cstate, $2))); }
--- a/nametoaddr.c
+++ b/nametoaddr.c
@@ -136,8 +136,12 @@
@@ -134,8 +134,12 @@

#include "diag-control.h"

Expand All @@ -484,16 +484,16 @@ Signed-off-by: Linus Lüssing <[email protected]>
+
#include "nametoaddr.h"

#ifdef HAVE_OS_PROTO_H
@@ -604,6 +608,7 @@ PCAP_API_DEF struct eproto eproto_db[] =
#include "thread-local.h"
@@ -597,6 +601,7 @@ PCAP_API_DEF struct eproto eproto_db[] =
{ "moprc", ETHERTYPE_MOPRC },
{ "rarp", ETHERTYPE_REVARP },
{ "sca", ETHERTYPE_SCA },
+ { "batadv", ETHERTYPE_BATMAN },
{ (char *)0, 0 }
};

@@ -638,6 +643,60 @@ pcap_nametollc(const char *s)
@@ -631,6 +636,60 @@ pcap_nametollc(const char *s)

while (p->s != 0) {
if (strcmp(p->s, s) == 0)
Expand Down Expand Up @@ -582,7 +582,7 @@ Signed-off-by: Linus Lüssing <[email protected]>
Abbreviations for:
.in +.5i
.nf
@@ -792,6 +793,36 @@ For example:
@@ -795,6 +796,36 @@ For example:
filters IPv4 protocol encapsulated in Geneve with VNI 0xb. This will
match both IPv4 directly encapsulated in Geneve as well as IPv4 contained
inside an Ethernet frame.
Expand Down Expand Up @@ -621,18 +621,18 @@ Signed-off-by: Linus Lüssing <[email protected]>
\fIProtocol\fP can be a number or one of the names
--- a/pcap/namedb.h
+++ b/pcap/namedb.h
@@ -70,6 +70,8 @@ PCAP_API int pcap_nametoportrange(const
PCAP_API int pcap_nametoproto(const char *);
PCAP_API int pcap_nametoeproto(const char *);
@@ -94,6 +94,8 @@ PCAP_API int pcap_nametoeproto(const cha

PCAP_AVAILABLE_0_9
PCAP_API int pcap_nametollc(const char *);
+PCAP_API int pcap_nametobatadvtype_v14(const char *);
+PCAP_API int pcap_nametobatadvtype_v15(const char *);

/*
* If a protocol is unknown, PROTO_UNDEF is returned.
* Also, pcap_nametoport() returns the protocol along with the port number.
--- a/scanner.l
+++ b/scanner.l
@@ -347,6 +347,7 @@ mpls return MPLS;
@@ -365,6 +365,7 @@ mpls return MPLS;
pppoed return PPPOED;
pppoes return PPPOES;
geneve return GENEVE;
Expand Down

0 comments on commit c7671a2

Please sign in to comment.