bug: propagate TLS errors as failures #307
build.yml
on: pull_request
short-tests
8s
lint
4s
gosec
21s
coverage-threshold
9s
integration
9s
Annotations
8 errors and 10 warnings
integration
missing go.sum entry for module providing package golang.org/x/sys/cpu (imported by golang.org/x/crypto/chacha20poly1305); to add:
|
integration
missing go.sum entry for module providing package golang.org/x/sys/unix (imported by github.com/ory/dockertest/v3/docker/pkg/archive); to add:
|
integration
missing go.sum entry for module providing package gopkg.in/yaml.v2 (imported by github.com/docker/cli/cli/compose/loader); to add:
|
integration
Process completed with exit code 1.
|
coverage-threshold
missing go.sum entry for module providing package golang.org/x/sys/cpu (imported by golang.org/x/crypto/chacha20poly1305); to add:
|
coverage-threshold
Process completed with exit code 2.
|
short-tests
missing go.sum entry for module providing package golang.org/x/sys/cpu (imported by golang.org/x/crypto/chacha20poly1305); to add:
|
short-tests
Process completed with exit code 1.
|
lint:
internal/runtimex/runtimex_test.go#L13
parameter 't' seems to be unused, consider removing or renaming it as _
|
lint:
internal/mocks/addr.go#L1
should have a package comment
|
lint:
internal/runtimex/runtimex_test.go#L31
parameter 't' seems to be unused, consider removing or renaming it as _
|
lint:
internal/runtimex/runtimex_test.go#L22
parameter 't' seems to be unused, consider removing or renaming it as _
|
lint:
internal/runtimex/runtimex_test.go#L40
parameter 't' seems to be unused, consider removing or renaming it as _
|
lint:
internal/session/manager.go#L166
if block ends with a return statement, so drop this else and outdent its block
|
lint:
internal/model/session.go#L8
don't use ALL_CAPS in Go names; use CamelCase
|
lint:
internal/model/packet.go#L24
don't use ALL_CAPS in Go names; use CamelCase
|
lint:
internal/model/packet.go#L26
don't use ALL_CAPS in Go names; use CamelCase
|
lint:
internal/model/packet.go#L25
don't use ALL_CAPS in Go names; use CamelCase
|