Skip to content

Commit

Permalink
gimp: rebuild with GCC 14
Browse files Browse the repository at this point in the history
Avoid warning that is elevated to an error in GCC 14.
  • Loading branch information
mmuetzel committed Nov 15, 2024
1 parent f1c41a9 commit f0a89cc
Show file tree
Hide file tree
Showing 2 changed files with 18 additions and 1 deletion.
14 changes: 14 additions & 0 deletions mingw-w64-gimp/0008-avoid-incompatible-pointer-cast.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
diff -urN gimp-2.10.38/plug-ins/file-tiff/file-tiff-load.c.orig gimp-2.10.38/plug-ins/file-tiff/file-tiff-load.c
--- gimp-2.10.38/plug-ins/file-tiff/file-tiff-load.c.orig 2024-05-03 02:33:35.000000000 +0200
+++ gimp-2.10.38/plug-ins/file-tiff/file-tiff-load.c 2024-11-15 17:33:41.801228400 +0100
@@ -1301,8 +1301,8 @@

/* any resolution info in the file? */
{
- gfloat xres = 72.0;
- gfloat yres = 72.0;
+ gdouble xres = 72.0;
+ gdouble yres = 72.0;
gushort read_unit;
GimpUnit unit = GIMP_UNIT_PIXEL; /* invalid unit */

5 changes: 4 additions & 1 deletion mingw-w64-gimp/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@ _realname=gimp
pkgbase=mingw-w64-${_realname}
pkgname=("${MINGW_PACKAGE_PREFIX}-${_realname}")
pkgver=2.10.38
pkgrel=1
pkgrel=2
pkgdesc="GNU Image Manipulation Program (mingw-w64)"
arch=('any')
mingw_arch=('mingw32' 'mingw64' 'ucrt64' 'clang64')
Expand Down Expand Up @@ -55,6 +55,7 @@ source=(https://download.gimp.org/pub/gimp/v${pkgver%.*}/${_realname}-${pkgver}.
0004-replace-pygtk-codegen.patch
0005-fix-link-python-plugins.patch
0007-clang-rc-files-fix.patch
0008-avoid-incompatible-pointer-cast.patch
https://gitlab.gnome.org/GNOME/gimp/-/commit/13284c8953b43e349dc94a6c5bcc9dbf4e98533f.patch)
sha256sums=('50a845eec11c8831fe8661707950f5b8446e35f30edfb9acf98f85c1133f856e'
'f7f9badc547f1a0317b95e012530db8df63b7c7038c9d9ff8d0b510c86f43439'
Expand All @@ -63,6 +64,7 @@ sha256sums=('50a845eec11c8831fe8661707950f5b8446e35f30edfb9acf98f85c1133f856e'
'98b6212e669eb3a93877514ee6d3284cb3a44ae6d57b6ecb29de3a076db3dbd2'
'01651bb582b2120aae67752f6a28c0750ea690d46259d855e28f8b18da567bf5'
'f4f8258b352530b0f9dd1ebd4f4730125caa4d047ca17bf9e5180b52be19c117'
'328369701b2d63389b84893215fdda24828e6ab8e86f3af70e7f2bc91d7d3d91'
'3d346b0d7cb9ab534501f5e1a5d543a54dc16bb16b884a2fc42382c6a5b82cbf')

apply_patch_with_msg() {
Expand All @@ -82,6 +84,7 @@ prepare() {
0004-replace-pygtk-codegen.patch \
0005-fix-link-python-plugins.patch \
0007-clang-rc-files-fix.patch \
0008-avoid-incompatible-pointer-cast.patch \
13284c8953b43e349dc94a6c5bcc9dbf4e98533f.patch

sed -e "s|-Wl,-rpath '-Wl,\$\$ORIGIN/../lib'||g" -i app/Makefile.am
Expand Down

0 comments on commit f0a89cc

Please sign in to comment.