Skip to content

Commit

Permalink
texinfo: Replace compiler error workaround with upstream patch
Browse files Browse the repository at this point in the history
  • Loading branch information
Biswa96 committed Sep 11, 2024
1 parent 3ffc0c3 commit c8191cb
Show file tree
Hide file tree
Showing 2 changed files with 43 additions and 8 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
From 442b9a641d10e4de462e59300b7e1711448d5530 Mon Sep 17 00:00:00 2001
From: Gavin Smith <[email protected]>
Date: Tue, 10 Sep 2024 16:29:21 +0100
Subject: [PATCH] * info/terminal.c (terminal_prep_terminal_hook): Return void not int.

---
diff --git a/info/terminal.c b/info/terminal.c
index 5340434..69d1f0e 100644
--- a/info/terminal.c
+++ b/info/terminal.c
@@ -56,7 +56,7 @@ extern int tputs ();

void (*terminal_initialize_terminal_hook) (char *terminal_name) = NULL;
void (*terminal_get_screen_size_hook) (void) = NULL;
-int (*terminal_prep_terminal_hook) (void) = NULL;
+void (*terminal_prep_terminal_hook) (void) = NULL;
void (*terminal_unprep_terminal_hook) (void) = NULL;
void (*terminal_new_terminal_hook) (char *terminal_name) = NULL;
void (*terminal_goto_xy_hook) (int x, int y) = NULL;
diff --git a/info/terminal.h b/info/terminal.h
index 3439250..28a6d07 100644
--- a/info/terminal.h
+++ b/info/terminal.h
@@ -59,7 +59,7 @@ extern void (*terminal_get_screen_size_hook) (void);
extern int terminal_prep_terminal (void);
extern void terminal_unprep_terminal (void);

-extern int (*terminal_prep_terminal_hook) (void);
+extern void (*terminal_prep_terminal_hook) (void);
extern void (*terminal_unprep_terminal_hook) (void);

/* Re-initialize the terminal to TERMINAL_NAME. */
--
2.46.0

16 changes: 8 additions & 8 deletions mingw-w64-texinfo/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@ _realname=texinfo
pkgbase=mingw-w64-${_realname}
pkgname=("${MINGW_PACKAGE_PREFIX}-${_realname}")
pkgver=7.1.1
pkgrel=1
pkgrel=2
pkgdesc="GNU documentation system for on-line information and printed output (mingw-w64)"
arch=('any')
mingw_arch=('mingw64' 'ucrt64' 'clang64' 'clangarm64' 'mingw32')
Expand All @@ -25,22 +25,22 @@ makedepends=(
"${MINGW_PACKAGE_PREFIX}-gettext-tools"
)
source=("https://ftp.gnu.org/pub/gnu/${_realname}/${_realname}-${pkgver}.tar.xz"{,.sig}
"0001-info-terminal.c-terminal_prep_terminal_hook-Return-v.patch"
"texinfo-install.hook.in"
"texinfo-remove.hook.in")
sha256sums=('31ae37e46283529432b61bee1ce01ed0090d599e606fc6a29dca1f77c76a6c82'
'SKIP'
'3b622842e37b24a0307ff196e094c6b4b026667a995f6bfe55da284cf309c105'
'd367fe9dfa09385408cd2e2240f95738258d727449cb3b29e685925210c2a1d9'
'ef6e404ee6a45f18957e413d2d83a7699a486bebfde28eb8d515a5f14736d948')
validpgpkeys=('EAF669B31E31E1DECBD11513DDBC579DAB37FBA9') # Gavin Smith (Texinfo maintainer) <[email protected]>

build() {
# work around gcc 14 errors
if [[ "${CC}" == "gcc" ]]; then
CFLAGS+=" -Wno-error=incompatible-pointer-types"
else
CFLAGS+=" -Wno-error=incompatible-function-pointer-types"
fi
prepare() {
cd "${_realname}-${pkgver}"
patch -p1 -i "${srcdir}/0001-info-terminal.c-terminal_prep_terminal_hook-Return-v.patch"
}

build() {
mkdir -p "build-${MSYSTEM}" && cd "build-${MSYSTEM}"

../"${_realname}-${pkgver}"/configure \
Expand Down

0 comments on commit c8191cb

Please sign in to comment.