forked from msys2/MINGW-packages
-
Notifications
You must be signed in to change notification settings - Fork 1
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
glpk: Do not use embedded zlib nor embedded suitesparse
Adopt patches from Debian: https://salsa.debian.org/science-team/glpk/-/tree/6aef0457486b0bb014b755ac5c8408c8c697afd4/debian/patches
- Loading branch information
Showing
3 changed files
with
139 additions
and
6 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,52 @@ | ||
Description: Do not use embedded copy of zlib | ||
Author: Sébastien Villemot <[email protected]> | ||
Forwarded: not-needed | ||
Last-Update: 2013-06-25 | ||
--- | ||
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/ | ||
--- a/src/Makefile.am | ||
+++ b/src/Makefile.am | ||
@@ -18,8 +18,7 @@ libglpk_la_CPPFLAGS = \ | ||
-I$(srcdir)/mpl \ | ||
-I$(srcdir)/npp \ | ||
-I$(srcdir)/proxy \ | ||
--I$(srcdir)/simplex \ | ||
--I$(srcdir)/zlib | ||
+-I$(srcdir)/simplex | ||
|
||
libglpk_la_LDFLAGS = \ | ||
-version-info 43:1:3 \ | ||
@@ -202,21 +201,6 @@ simplex/spxprim.c \ | ||
simplex/spxprob.c \ | ||
simplex/spychuzc.c \ | ||
simplex/spychuzr.c \ | ||
-simplex/spydual.c \ | ||
-zlib/adler32.c \ | ||
-zlib/compress.c \ | ||
-zlib/crc32.c \ | ||
-zlib/deflate.c \ | ||
-zlib/gzclose.c \ | ||
-zlib/gzlib.c \ | ||
-zlib/gzread.c \ | ||
-zlib/gzwrite.c \ | ||
-zlib/inffast.c \ | ||
-zlib/inflate.c \ | ||
-zlib/inftrees.c \ | ||
-zlib/trees.c \ | ||
-zlib/uncompr.c \ | ||
-zlib/zio.c \ | ||
-zlib/zutil.c | ||
+simplex/spydual.c | ||
|
||
## eof ## | ||
--- a/configure.ac | ||
+++ b/configure.ac | ||
@@ -190,6 +190,8 @@ case "${host}" in | ||
esac | ||
AC_SUBST([NOUNDEFINED]) | ||
|
||
+AC_CHECK_LIB([z], [gzopen]) | ||
+ | ||
AC_CONFIG_FILES( | ||
[src/Makefile examples/Makefile Makefile]) | ||
AC_OUTPUT |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,61 @@ | ||
Description: Do not use embedded copy of AMD and COLAMD libraries from suitesparse | ||
Author: Sébastien Villemot <[email protected]> | ||
Forwarded: not-needed | ||
Last-Update: 2013-06-25 | ||
--- | ||
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/ | ||
--- a/configure.ac | ||
+++ b/configure.ac | ||
@@ -192,6 +192,12 @@ AC_SUBST([NOUNDEFINED]) | ||
|
||
AC_CHECK_LIB([z], [gzopen]) | ||
|
||
+AC_CHECK_LIB([amd], [amd_1]) | ||
+AC_CHECK_LIB([colamd], [colamd]) | ||
+ | ||
+CPPFLAGS="$CPPFLAGS $(pkg-config --cflags AMD)" | ||
+AC_CHECK_HEADER([amd.h]) | ||
+ | ||
AC_CONFIG_FILES( | ||
[src/Makefile examples/Makefile Makefile]) | ||
AC_OUTPUT | ||
--- a/src/Makefile.am | ||
+++ b/src/Makefile.am | ||
@@ -6,10 +6,8 @@ lib_LTLIBRARIES = libglpk.la | ||
|
||
libglpk_la_CPPFLAGS = \ | ||
-I$(srcdir) \ | ||
--I$(srcdir)/amd \ | ||
-I$(srcdir)/api \ | ||
-I$(srcdir)/bflib \ | ||
--I$(srcdir)/colamd \ | ||
-I$(srcdir)/draft \ | ||
-I$(srcdir)/env \ | ||
-I$(srcdir)/intopt \ | ||
@@ -26,18 +24,6 @@ libglpk_la_LDFLAGS = \ | ||
${NOUNDEFINED} | ||
|
||
libglpk_la_SOURCES = \ | ||
-amd/amd_1.c \ | ||
-amd/amd_2.c \ | ||
-amd/amd_aat.c \ | ||
-amd/amd_control.c \ | ||
-amd/amd_defaults.c \ | ||
-amd/amd_dump.c \ | ||
-amd/amd_info.c \ | ||
-amd/amd_order.c \ | ||
-amd/amd_post_tree.c \ | ||
-amd/amd_postorder.c \ | ||
-amd/amd_preprocess.c \ | ||
-amd/amd_valid.c \ | ||
api/advbas.c \ | ||
api/asnhall.c \ | ||
api/asnlp.c \ | ||
@@ -103,7 +89,6 @@ bflib/scf.c \ | ||
bflib/scfint.c \ | ||
bflib/sgf.c \ | ||
bflib/sva.c \ | ||
-colamd/colamd.c \ | ||
draft/bfd.c \ | ||
draft/bfx.c \ | ||
draft/glpapi06.c \ |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters