forked from msys2/MINGW-packages
-
Notifications
You must be signed in to change notification settings - Fork 1
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
Showing
3 changed files
with
105 additions
and
35 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,42 @@ | ||
diff -urN Trilinos-trilinos-release-16-0-0/packages/adelus/src/CMakeLists.txt.orig Trilinos-trilinos-release-16-0-0/packages/adelus/src/CMakeLists.txt | ||
--- Trilinos-trilinos-release-16-0-0/packages/adelus/src/CMakeLists.txt.orig 2024-07-22 21:31:42.000000000 +0200 | ||
+++ Trilinos-trilinos-release-16-0-0/packages/adelus/src/CMakeLists.txt 2024-09-12 18:23:54.236799900 +0200 | ||
@@ -119,6 +119,9 @@ | ||
HEADERS ${HEADERS} | ||
SOURCES ${SOURCES} | ||
) | ||
+ IF(TPL_ENABLE_MPI) | ||
+ target_link_libraries(zadelus PRIVATE MPI::MPI_CXX) | ||
+ ENDIF() | ||
|
||
ELSEIF(Adelus_ENABLE_SCPLX) | ||
MESSAGE(" Building the S Complex library") | ||
@@ -139,6 +142,9 @@ | ||
HEADERS ${HEADERS} | ||
SOURCES ${SOURCES} | ||
) | ||
+ IF(TPL_ENABLE_MPI) | ||
+ target_link_libraries(cadelus PRIVATE MPI::MPI_CXX) | ||
+ ENDIF() | ||
|
||
ELSEIF(Adelus_ENABLE_SREAL) | ||
MESSAGE(" Building the single precision library") | ||
@@ -159,6 +165,9 @@ | ||
HEADERS ${HEADERS} | ||
SOURCES ${SOURCES} | ||
) | ||
+ IF(TPL_ENABLE_MPI) | ||
+ target_link_libraries(sadelus PRIVATE MPI::MPI_CXX) | ||
+ ENDIF() | ||
|
||
ELSEIF(Adelus_ENABLE_DREAL) | ||
MESSAGE(" Building the double precision library") | ||
@@ -179,5 +188,8 @@ | ||
HEADERS ${HEADERS} | ||
SOURCES ${SOURCES} | ||
) | ||
+ IF(TPL_ENABLE_MPI) | ||
+ target_link_libraries(dadelus PRIVATE MPI::MPI_CXX) | ||
+ ENDIF() | ||
|
||
ENDIF() |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,15 @@ | ||
diff -urN Trilinos-trilinos-release-16-0-0/packages/stokhos/src/CMakeLists.txt.orig Trilinos-trilinos-release-16-0-0/packages/stokhos/src/CMakeLists.txt | ||
--- Trilinos-trilinos-release-16-0-0/packages/stokhos/src/CMakeLists.txt.orig 2024-07-22 21:31:42.000000000 +0200 | ||
+++ Trilinos-trilinos-release-16-0-0/packages/stokhos/src/CMakeLists.txt 2024-09-12 19:43:02.405609700 +0200 | ||
@@ -198,6 +198,11 @@ | ||
${Stokhos_ENABLE_OpenMP_Default} | ||
) | ||
|
||
+IF (NOT (Stokhos_ENABLE_NOX AND NOX_ENABLE_ABSTRACT_IMPLEMENTATION_EPETRA AND | ||
+ NOX_ENABLE_EpetraExt)) | ||
+ SET(HAVE_STOKHOS_NOX OFF) | ||
+ENDIF() | ||
+ | ||
TRIBITS_CONFIGURE_FILE(${PACKAGE_NAME}_config.h) | ||
|
||
# |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters