Skip to content

[email protected]

Pre-release
Pre-release
Compare
Choose a tag to compare
@logaretm logaretm released this 07 Oct 04:02

This release contains a bunch of minor but breaking changes 💥

Props Renamed

Some props and functions names got changed to better communicate their purpose and avoid any obscure terminology

  • lazy prop on useQuery and Query has been renamed to fetchOnMount to better communicate the purpose
  • Changed the pausing terminology for useQuery and Query to better reflect their use, resume is now watchVariables and pause is now unwatchVariables, isPaused is now isWatchingVariables. A little verbose but clear cut
  • renamed pause prop name to be paused on both Query and Subscription components
  • renamed suspend prop on Query component to suspended for consistency with other props

Subscription Changes

  • subscriptions have been re-implemented as a simple plugin handleSubscriptions rather than their own weird thing, which allows subscriptions to participate in the plugins pipeline (previously they didn't)