forked from openwrt/packages
-
Notifications
You must be signed in to change notification settings - Fork 1
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
* removed needless subshell calls * add memory measurements: - size of the final blocklist in MB - free memory in MB (MemAvailable from /proc/meminfo) - script max. used RAM (VmHWM from /proc/$$/status) * optimized restart logic * cosmetics Signed-off-by: Dirk Brenken <[email protected]>
- Loading branch information
Showing
5 changed files
with
94 additions
and
85 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -6,8 +6,8 @@ | |
include $(TOPDIR)/rules.mk | ||
|
||
PKG_NAME:=adblock | ||
PKG_VERSION:=4.2.4 | ||
PKG_RELEASE:=2 | ||
PKG_VERSION:=4.2.5 | ||
PKG_RELEASE:=1 | ||
PKG_LICENSE:=GPL-3.0-or-later | ||
PKG_MAINTAINER:=Dirk Brenken <[email protected]> | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -51,6 +51,7 @@ stop_service() { | |
} | ||
|
||
restart() { | ||
rc_procd "${adb_script}" stop | ||
rc_procd start_service restart | ||
} | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,6 +1,6 @@ | ||
#!/bin/sh | ||
# send mail script for adblock notifications | ||
# Copyright (c) 2015-2024 Dirk Brenken ([email protected]) | ||
# Copyright (c) 2015-2025 Dirk Brenken ([email protected]) | ||
# This is free software, licensed under the GNU General Public License v3. | ||
|
||
# Please note: you have to manually install and configure the package 'msmtp' before using this script | ||
|
Oops, something went wrong.