forked from ebutera/meta-sunxi
-
Notifications
You must be signed in to change notification settings - Fork 184
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
u-boot_%.bbappend: Fix U-Boot for sun9i
Use a proper fix instead of reverting U-Boot commit ffb0294. After reporting this issue to the U-Boot mailing list, a patch that works on Allwinner A80 machines like Merrii A80 Optimus board was proposed by Andre Przywara: https://lists.denx.de/pipermail/u-boot/2024-December/575050.html Signed-off-by: Leon Anavi <[email protected]>
- Loading branch information
1 parent
f2f4c6a
commit ab9690a
Showing
3 changed files
with
42 additions
and
110 deletions.
There are no files selected for viewing
108 changes: 0 additions & 108 deletions
108
recipes-bsp/u-boot/files/0001-Revert-sunxi-board-simplify-early-PMIC-setup-conditi.patch
This file was deleted.
Oops, something went wrong.
41 changes: 41 additions & 0 deletions
41
recipes-bsp/u-boot/files/0001-sunxi-board-Fix-early-PMIC-setup-conditions.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,41 @@ | ||
From f4dde09fa41eb538b743ee2104c1e2e10cc7e13f Mon Sep 17 00:00:00 2001 | ||
From: Leon Anavi <[email protected]> | ||
Date: Sat, 14 Dec 2024 10:59:09 +0000 | ||
Subject: [PATCH] sunxi: board: Fix early PMIC setup conditions | ||
|
||
Patch provided by Andre Przywara through the U-Boot mailing list: | ||
https://lists.denx.de/pipermail/u-boot/2024-December/575050.html | ||
|
||
Upstream-Status: Pending | ||
|
||
Suggested-by: Andre Przywara <[email protected]> | ||
Signed-off-by: Leon Anavi <[email protected]> | ||
--- | ||
board/sunxi/board.c | 4 +++- | ||
1 file changed, 3 insertions(+), 1 deletion(-) | ||
|
||
diff --git a/board/sunxi/board.c b/board/sunxi/board.c | ||
index 961cdcde74..d6759fe853 100644 | ||
--- a/board/sunxi/board.c | ||
+++ b/board/sunxi/board.c | ||
@@ -577,7 +577,6 @@ void sunxi_board_init(void) | ||
|
||
#ifdef CONFIG_AXP_DCDC1_VOLT | ||
power_failed |= axp_set_dcdc1(CONFIG_AXP_DCDC1_VOLT); | ||
- power_failed |= axp_set_dcdc5(CONFIG_AXP_DCDC5_VOLT); | ||
#endif | ||
#ifdef CONFIG_AXP_DCDC2_VOLT | ||
power_failed |= axp_set_dcdc2(CONFIG_AXP_DCDC2_VOLT); | ||
@@ -586,6 +585,9 @@ void sunxi_board_init(void) | ||
#ifdef CONFIG_AXP_DCDC4_VOLT | ||
power_failed |= axp_set_dcdc4(CONFIG_AXP_DCDC4_VOLT); | ||
#endif | ||
+#ifdef CONFIG_AXP_DCDC5_VOLT | ||
+ power_failed |= axp_set_dcdc5(CONFIG_AXP_DCDC5_VOLT); | ||
+#endif | ||
|
||
#ifdef CONFIG_AXP_ALDO1_VOLT | ||
power_failed |= axp_set_aldo1(CONFIG_AXP_ALDO1_VOLT); | ||
-- | ||
2.47.1 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters