Skip to content

Commit

Permalink
u-boot_%.bbappend: Fix U-Boot for sun9i
Browse files Browse the repository at this point in the history
Use a proper fix instead of reverting U-Boot commit ffb0294.
After reporting this issue to the U-Boot mailing list, a patch
that works on Allwinner A80 machines like Merrii A80 Optimus board
was proposed by Andre Przywara:
https://lists.denx.de/pipermail/u-boot/2024-December/575050.html

Signed-off-by: Leon Anavi <[email protected]>
  • Loading branch information
leon-anavi committed Dec 14, 2024
1 parent f2f4c6a commit ab9690a
Show file tree
Hide file tree
Showing 3 changed files with 42 additions and 110 deletions.

This file was deleted.

Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
From f4dde09fa41eb538b743ee2104c1e2e10cc7e13f Mon Sep 17 00:00:00 2001
From: Leon Anavi <[email protected]>
Date: Sat, 14 Dec 2024 10:59:09 +0000
Subject: [PATCH] sunxi: board: Fix early PMIC setup conditions

Patch provided by Andre Przywara through the U-Boot mailing list:
https://lists.denx.de/pipermail/u-boot/2024-December/575050.html

Upstream-Status: Pending

Suggested-by: Andre Przywara <[email protected]>
Signed-off-by: Leon Anavi <[email protected]>
---
board/sunxi/board.c | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/board/sunxi/board.c b/board/sunxi/board.c
index 961cdcde74..d6759fe853 100644
--- a/board/sunxi/board.c
+++ b/board/sunxi/board.c
@@ -577,7 +577,6 @@ void sunxi_board_init(void)

#ifdef CONFIG_AXP_DCDC1_VOLT
power_failed |= axp_set_dcdc1(CONFIG_AXP_DCDC1_VOLT);
- power_failed |= axp_set_dcdc5(CONFIG_AXP_DCDC5_VOLT);
#endif
#ifdef CONFIG_AXP_DCDC2_VOLT
power_failed |= axp_set_dcdc2(CONFIG_AXP_DCDC2_VOLT);
@@ -586,6 +585,9 @@ void sunxi_board_init(void)
#ifdef CONFIG_AXP_DCDC4_VOLT
power_failed |= axp_set_dcdc4(CONFIG_AXP_DCDC4_VOLT);
#endif
+#ifdef CONFIG_AXP_DCDC5_VOLT
+ power_failed |= axp_set_dcdc5(CONFIG_AXP_DCDC5_VOLT);
+#endif

#ifdef CONFIG_AXP_ALDO1_VOLT
power_failed |= axp_set_aldo1(CONFIG_AXP_ALDO1_VOLT);
--
2.47.1

3 changes: 1 addition & 2 deletions recipes-bsp/u-boot/u-boot_%.bbappend
Original file line number Diff line number Diff line change
Expand Up @@ -18,9 +18,8 @@ SRC_URI:append:sunxi = " \
file://0004-OrangePi-3-LTS-support.patch \
file://boot.cmd \
"

SRC_URI:append:sun9i = " \
file://0001-Revert-sunxi-board-simplify-early-PMIC-setup-conditi.patch \
file://0001-sunxi-board-Fix-early-PMIC-setup-conditions.patch \
"

SRC_URI:append:mangopi-mq-t-t113 = " \
Expand Down

0 comments on commit ab9690a

Please sign in to comment.