forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 1
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
llvm-core/llvm-toolchain-symlinks: main is now 21*
Signed-off-by: Michał Górny <[email protected]>
- Loading branch information
Showing
1 changed file
with
48 additions
and
0 deletions.
There are no files selected for viewing
48 changes: 48 additions & 0 deletions
48
llvm-core/llvm-toolchain-symlinks/llvm-toolchain-symlinks-21.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,48 @@ | ||
# Copyright 2022-2025 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
inherit multilib | ||
|
||
DESCRIPTION="Symlinks to use LLVM on binutils-free system" | ||
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:LLVM" | ||
S=${WORKDIR} | ||
|
||
LICENSE="public-domain" | ||
SLOT="${PV}" | ||
IUSE="multilib-symlinks +native-symlinks" | ||
|
||
RDEPEND=" | ||
llvm-core/llvm:${SLOT} | ||
" | ||
|
||
src_install() { | ||
use native-symlinks || return | ||
|
||
local tools=( | ||
addr2line ar dlltool nm objcopy objdump ranlib readelf size | ||
strings strip windres | ||
# https://bugs.gentoo.org/936068 | ||
cxxfilt:c++filt | ||
) | ||
local chosts=( "${CHOST}" ) | ||
if use multilib-symlinks; then | ||
local abi | ||
for abi in $(get_all_abis); do | ||
chosts+=( "$(get_abi_CHOST "${abi}")" ) | ||
done | ||
fi | ||
|
||
local chost t | ||
local dest=/usr/lib/llvm/${SLOT}/bin | ||
dodir "${dest}" | ||
for t in "${tools[@]}"; do | ||
dosym "llvm-${t%:*}" "${dest}/${t#*:}" | ||
done | ||
for chost in "${chosts[@]}"; do | ||
for t in "${tools[@]}"; do | ||
dosym "llvm-${t%:*}" "${dest}/${chost}-${t#*:}" | ||
done | ||
done | ||
} |