Skip to content
/ gentoo Public
forked from gentoo/gentoo

Commit

Permalink
llvm-core/lld-toolchain-symlinks: main is now 21*
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Feb 1, 2025
1 parent efbd046 commit 3641747
Showing 1 changed file with 37 additions and 0 deletions.
37 changes: 37 additions & 0 deletions llvm-core/lld-toolchain-symlinks/lld-toolchain-symlinks-21.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Copyright 2022-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit multilib

DESCRIPTION="Symlinks to use LLD on binutils-free system"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:LLVM"
S=${WORKDIR}

LICENSE="public-domain"
SLOT="${PV}"
IUSE="multilib-symlinks +native-symlinks"

RDEPEND="
llvm-core/lld:${SLOT}
"

src_install() {
use native-symlinks || return

local chosts=( "${CHOST}" )
if use multilib-symlinks; then
local abi
for abi in $(get_all_abis); do
chosts+=( "$(get_abi_CHOST "${abi}")" )
done
fi

local dest=/usr/lib/llvm/${SLOT}/bin
dodir "${dest}"
dosym ld.lld "${dest}/ld"
for chost in "${chosts[@]}"; do
dosym ld.lld "${dest}/${chost}-ld"
done
}

0 comments on commit 3641747

Please sign in to comment.