Skip to content

Commit

Permalink
Update py-flask-login to 0.2.9.
Browse files Browse the repository at this point in the history
Version 0.2.9-dev
-----------------

Released on December 28th, 2013

- Fixes anonymous user assignment.
- Fixes localization in Python 3.


Version 0.2.8
-------------

Released on December 21st 2013

- Support login via authorization header. This allows login via Basic Auth, for
  example. Useful in an API presentation context.
- Ability to override user ID method name. This is useful if the ID getter is
  named differently than the default.
- Session data is now only read when the user is requested. This can be
  beneficial for cookie and caching control when differenting between
  requests that use user information for rendering and ones where all users
  (including anonymous) get the same result (e.g. static pages)
- BREAKING: User *must* always be accessed through the ``current_user``
  local. This breaks any previous direct access to ``_request_ctx.top.user``.
  This is because user is not loaded until current_user is accessed.
- Fixes unnecessary access to the session when the user is anonymous
  and session protection is active.
  see maxcountryman/flask-login#120
- Fixes issue where order dependency of applying the login manager
  before dependent applications was required.
  see pallets-eco/flask-principal#22
- Fixes Python 3 ``UserMixin`` hashing.
- Fixes incorrect documentation.
  • Loading branch information
kleink committed Jan 1, 2014
1 parent e8e5909 commit 62d9631
Show file tree
Hide file tree
Showing 2 changed files with 6 additions and 6 deletions.
4 changes: 2 additions & 2 deletions www/py-flask-login/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.7 2013/08/23 15:33:58 kleink Exp $
# $NetBSD: Makefile,v 1.8 2014/01/01 17:56:43 kleink Exp $

DISTNAME= Flask-Login-0.2.7
DISTNAME= Flask-Login-0.2.9
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:tl}
CATEGORIES= www python
MASTER_SITES= http://pypi.python.org/packages/source/F/Flask-Login/
Expand Down
8 changes: 4 additions & 4 deletions www/py-flask-login/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.5 2013/08/23 15:33:58 kleink Exp $
$NetBSD: distinfo,v 1.6 2014/01/01 17:56:43 kleink Exp $

SHA1 (Flask-Login-0.2.7.tar.gz) = 676eb6be40a7aca15ebbdf234236e457905bdbef
RMD160 (Flask-Login-0.2.7.tar.gz) = a67bbde1968c9af74ba395cfc821355c5fa229b1
Size (Flask-Login-0.2.7.tar.gz) = 10199 bytes
SHA1 (Flask-Login-0.2.9.tar.gz) = 79c8d78aa17f56d403ea8059399f18f7218e8211
RMD160 (Flask-Login-0.2.9.tar.gz) = 7382c36c0a97e057922947d368143749e6f16558
Size (Flask-Login-0.2.9.tar.gz) = 10922 bytes

0 comments on commit 62d9631

Please sign in to comment.