Skip to content

Commit

Permalink
updpatch: atuin 18.3.0-1
Browse files Browse the repository at this point in the history
This commit increases the SQLite operation timeout to 2s to make the
test pass. Details see upstream: atuinsh/atuin#2337.
  • Loading branch information
jaxvanyang committed Aug 2, 2024
1 parent 01cb4a3 commit d846843
Showing 1 changed file with 13 additions and 5 deletions.
18 changes: 13 additions & 5 deletions atuin/riscv64.patch
Original file line number Diff line number Diff line change
@@ -1,11 +1,19 @@
--- PKGBUILD
+++ PKGBUILD
@@ -32,7 +32,7 @@ build() {
@@ -21,6 +21,8 @@ prepare() {
cd "$pkgname-$pkgver"
cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')"
mkdir completions/
+ # increase SQLite connection timeout
+ sed -i 's/Sqlite::new("sqlite::memory:", 0.1)/Sqlite::new("sqlite::memory:", 2.0)/' crates/atuin-client/src/database.rs
}

build() {
@@ -36,6 +38,7 @@ build() {
}

check() {
+ export ATUIN_TEST_SQLITE_STORE_TIMEOUT=2.0
cd "$pkgname-$pkgver"
- cargo test --frozen --all-features --workspace --lib
+ ATUIN_TEST_SQLITE_STORE_TIMEOUT=1.0 cargo test --frozen --all-features --workspace --lib
cargo test --frozen --all-features --workspace --lib
}

package() {

0 comments on commit d846843

Please sign in to comment.