forked from libremesh/lime-packages
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
Showing
8 changed files
with
94 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,30 @@ | ||
include $(TOPDIR)/rules.mk | ||
|
||
GIT_COMMIT_DATE:=$(shell git log -n 1 --pretty=%ad --date=short . ) | ||
GIT_COMMIT_TSTAMP:=$(shell git log -n 1 --pretty=%at . ) | ||
|
||
PKG_NAME:=devnet | ||
PKG_VERSION=$(GIT_COMMIT_DATE)-$(GIT_COMMIT_TSTAMP) | ||
|
||
include $(INCLUDE_DIR)/package.mk | ||
|
||
define Package/$(PKG_NAME) | ||
TITLE:=DevNet | ||
CATEGORY:=LibreMesh | ||
PKGARCH:=all | ||
endef | ||
|
||
define Package/$(PKG_NAME)/description | ||
Napoli development testnet | ||
endef | ||
|
||
|
||
define Build/Compile | ||
endef | ||
|
||
define Package/$(PKG_NAME)/install | ||
$(INSTALL_DIR) $(1)/ | ||
$(CP) ./files/* $(1)/ | ||
endef | ||
|
||
$(eval $(call BuildPackage,$(PKG_NAME))) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,6 @@ | ||
config lime system | ||
option hostname 'falsorouter-kone' | ||
|
||
config generic_uci_config location_coord | ||
list uci_set 'location.settings.node_latitude=-31.83469' | ||
list uci_set 'location.settings.node_longitude=-64.41885' |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,6 @@ | ||
config lime system | ||
option hostname 'kone-carcassa' | ||
|
||
config generic_uci_config location_coord | ||
list uci_set 'location.settings.node_latitude=-31.82346' | ||
list uci_set 'location.settings.node_longitude=-64.38726' |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,6 @@ | ||
config lime system | ||
option hostname 'konA-base11s' | ||
|
||
config generic_uci_config location_coord | ||
list uci_set 'location.settings.node_latitude='-31.81850' | ||
list uci_set 'location.settings.node_longitude='-64.41593' |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,6 @@ | ||
config lime system | ||
option hostname 'konB-11s' | ||
|
||
config generic_uci_config location_coord | ||
list uci_set 'location.settings.node_latitude='-31.81194' | ||
list uci_set 'location.settings.node_longitude='-64.40151' |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQDqx1QGbn1OYyrnIyrLzVJNqvjEgTzKI3fB7VkzeatVJJS1uvlBFSZEqKxIHbTJxenIEoF4B6CfOCtTPB03OInhFtV5tbo1024oKDgR6DKWPjMuQVVrSTLPeN30TfDx09/VhapAjslWgm5umSrEGu3rtgT3OSu4udlKyiATGh2UPlf1GwuVtQOONKMeRXfMW694j8vr+QEv5VqIm2FxsQqtdZt3SHbWCnsg45WftfQRvjmfEACBh8qINL2KrEKKscmPPYxj+LIuZLWBklgf4se1NyEnFzYCz8cNtpmjoeNuIFC2XCpQVxXr1P6kmCzJ+/U+tnMW0jv59fhYneSGrTAn root@localhost |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,4 @@ | ||
#!/bin/sh | ||
uci set eupgrade.main.custom_api_url='http://10.13.0.2:8081/' | ||
uci commit eupgrade | ||
exit 0 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,35 @@ | ||
local repository = "http://10.13.0.2:8081/" | ||
local lime_mesh_upgrade = require 'lime-mesh-upgrade' | ||
local eupgrade = require 'eupgrade' | ||
|
||
|
||
local network = require("lime.network") | ||
print(tostring(network.primary_address())) | ||
print(tostring(eupgrade.get_upgrade_api_url())) | ||
|
||
|
||
local utils = require "lime.utils" | ||
-- Uncoment for qemu | ||
--os.execute('echo librerouter-v1 > /tmp/sysinfo/board_name') | ||
|
||
print(eupgrade._get_board_name()) | ||
eupgrade.set_custom_api_url(repository) | ||
print(tostring(eupgrade.get_upgrade_api_url())) | ||
utils.printJson(eupgrade.is_new_version_available()) | ||
|
||
--lime_mesh_upgrade.become_main_node() | ||
--utils.printJson(lime_mesh_upgrade.get_main_node_status()) | ||
-- | ||
--os.execute("sleep " .. tonumber(1)) | ||
-- | ||
--utils.printJson(lime_mesh_upgrade.get_main_node_status()) | ||
-- | ||
--while not (lime_mesh_upgrade.get_main_node_status().code == eupgrade.STATUS_DOWNLOADED) do | ||
-- | ||
-- os.execute("sleep " .. tonumber(1)) | ||
-- | ||
-- utils.printJson(lime_mesh_upgrade.get_main_node_status()) | ||
-- | ||
--end | ||
-- | ||
--utils.printJson(lime_mesh_upgrade.start_firmware_upgrade_transaction()) |