Skip to content

Commit

Permalink
Merge branch 'master' of github.com:javierbrk/lime-packages into babe…
Browse files Browse the repository at this point in the history
…lnodes
  • Loading branch information
javierbrk committed Oct 6, 2023
2 parents 7a05210 + 9f8754b commit a5f59c2
Show file tree
Hide file tree
Showing 5 changed files with 47 additions and 7 deletions.
19 changes: 19 additions & 0 deletions CHANGELOG.md
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,26 @@ All notable changes to this project will be documented in this file.

## 2023.1 - Unreleased

## 2023.1-rc1 - Release candidate 2

### Full changelog since 2023.1-rc1
- Fix safe-upgrade bootstrap broken since OpenWrt 19.07 (merge #1050)
- Add force option to safe-upgrade bootstrap cmd (merge #1051)
- Default distance setting: increase 10x (merge #1047)
- add wifi interface name in shared state wifi information module (merge #1048)
- add freq information (merge #1045)
- Enable Node Information Exchange (merge #1043)
- readme: expanded instructions on ImageBuilder (merge #1028)
- removed extra info from shared state (merge #1041)
- wifi-unstuck-wa: allow parametrizable values for interval and timeout (merge #1039, fix #1034)
- Shared state ubus (merge #1040)
- New Shared-State wifi Links information module (merge #1038)

## 2023.1-rc1 - Release candidate 1

### Full changelog
- Add shared state async node (merge #1030)
- lime.network.scandevices: fix finding intefaces on dsa devices (merge #1033)
- Unit testing update (merge #1027)
- various readme improvements (merge #1015)
- remove old iw/iw-full compatibility check (merge #1024)
Expand Down
Original file line number Diff line number Diff line change
@@ -0,0 +1,10 @@
#!/bin/sh

unique_append()
{
grep -qF "$1" "$2" || echo "$1" >> "$2"
}

unique_append \
'*/5 * * * * ((sleep $(($RANDOM % 120)); shared-state-multiwriter sync reference_state_nodes_info &> /dev/null)&)'\
/etc/crontabs/root
Original file line number Diff line number Diff line change
@@ -0,0 +1,10 @@
#!/bin/sh

unique_append()
{
grep -qF "$1" "$2" || echo "$1" >> "$2"
}

unique_append \
'*/5 * * * * ((sleep $(($RANDOM % 120)); shared-state-multiwriter sync reference_state_wifi_links_info &> /dev/null)&)'\
/etc/crontabs/root
2 changes: 2 additions & 0 deletions packages/lime-system/files/usr/lib/lua/lime/utils.lua
Original file line number Diff line number Diff line change
Expand Up @@ -574,6 +574,8 @@ function utils.is_valid_mac(string)
end
end

--! TODO: Better having a C strcmp/memcmp like behavior so the output can be
--! used for sorting beyond determining equality
function utils.deepcompare(t1,t2)
if t1 == t2 then return true end
local ty1 = type(t1)
Expand Down
13 changes: 6 additions & 7 deletions packages/shared-state-network_nodes/Makefile
Original file line number Diff line number Diff line change
@@ -1,23 +1,22 @@
#
# Copyright (C) 2020 German Ferrero <germanferrero@altermundi.net>
# Copyright (C) 2020-2023 Asociacion Civil Altermundi <info@altermundi.net>
#
# This is free software, licensed under the GNU General Public License v3.
# This is free software, licensed under the GNU Affero General Public License v3.
#

include ../../libremesh.mk

define Package/$(PKG_NAME)
SECTION:=utils
CATEGORY:=Utilities
TITLE:=$(PKG_NAME) provides shared state database of all times network nodes
MAINTAINER:=Germán Ferrero <[email protected]>
CATEGORY:=LibreMesh
TITLE:=$(PKG_NAME) provides data-type for network nodes marked as reliable by user
MAINTAINER:=Asociacion Civil Altermundi <[email protected]>
DEPENDS:=+shared-state +shared-state-nodes_and_links +lime-system +luci-lib-jsonc \
+libubus-lua +random-numgen
PKGARCH:=all
endef

define Package/$(PKG_NAME)/description
This $(PKG_NAME) provides shared state database of all times network nodes.
Provides data-type for network nodes marked as reliable by user via lime-app
endef

$(eval $(call BuildPackage,$(PKG_NAME)))

0 comments on commit a5f59c2

Please sign in to comment.