-
Notifications
You must be signed in to change notification settings - Fork 12
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Merge pull request #41 from fedora-modularity/devel
Merge request to master
- Loading branch information
Showing
40 changed files
with
1,910 additions
and
1,575 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,20 @@ | ||
# Include warnings about missing documentation? | ||
doc-warnings: False | ||
|
||
# Include warnings about tests? | ||
test-warnings: True | ||
|
||
# tests stricktness | ||
strictness: medium | ||
|
||
pylint: | ||
options: | ||
max-line-length: 120 | ||
|
||
# autodetect dependencies? | ||
autodetect: True | ||
|
||
# paths to be ignored | ||
ignore-paths: | ||
- docs | ||
- setup.py |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1 @@ | ||
0.5.18-1 ./ | ||
0.5.19-1 ./ |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,5 +1,5 @@ | ||
Exceptions and Debug | ||
==================== | ||
Common | ||
======= | ||
|
||
.. automodule:: moduleframework.common | ||
:members: | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,7 @@ | ||
Exceptions | ||
=========== | ||
|
||
.. automodule:: moduleframework.exceptions | ||
:members: | ||
:undoc-members: | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -22,6 +22,7 @@ | |
# Authors: Jan Scotka <[email protected]> | ||
# | ||
|
||
from moduleframework import common | ||
from moduleframework import module_framework | ||
from avocado import skipIf | ||
from avocado import skipUnless | ||
|
@@ -40,12 +41,12 @@ def testGccSkippedInsideTest(self): | |
self.start() | ||
self.run("gcc -v") | ||
|
||
@skipIf(module_framework.get_correct_profile() == "default") | ||
@skipIf(common.get_profile() == "default") | ||
def testDecoratorNotSkippedForDefault(self): | ||
self.start() | ||
self.run("echo for default profile") | ||
|
||
@skipUnless(module_framework.get_correct_profile() == "gcc") | ||
@skipUnless(common.get_profile() == "gcc") | ||
def testDecoratorSkip(self): | ||
self.start() | ||
self.run("gcc -v") |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -23,7 +23,7 @@ Requires: python2-dockerfile-parse | |
Requires: python2-pdc-client | ||
Requires: python2-modulemd | ||
Provides: modularity-testing-framework = %{version}-%{release} | ||
Obsoletes: modularity-testing-framework < 0.5.18-1 | ||
Obsoletes: modularity-testing-framework < 0.5.18-2 | ||
|
||
%description | ||
%{summary}. | ||
|
@@ -51,6 +51,23 @@ chmod a+x %{buildroot}%{python_sitelib}/%{framework_name}/{module_framework,mtf_ | |
%{_datadir}/moduleframework/ | ||
|
||
%changelog | ||
* Mon Aug 07 2017 Nils Philippsen <[email protected]> 0.5.19-1 | ||
- obsolete modularity-testing-framework-0.5.18-1, too | ||
|
||
* Fri Aug 04 2017 Petr "Stone" Hracek <[email protected]> 0.5.19-1 | ||
- Add Landscap.io into project (#27) ([email protected]) | ||
- Update scheduling.rst ([email protected]) | ||
- Several fixes caused by missing testing. ([email protected]) | ||
- Draft of refactoring avocado-tests. ([email protected]) | ||
- replaced get_correct_backed in all internal tests by get_backend | ||
([email protected]) | ||
- fixed typo caused by function moving to other module ([email protected]) | ||
- function names cleanup, removed "correct" "latest" words fixing command | ||
sanitizer ([email protected]) | ||
- changed return variable to not be same as input param ([email protected]) | ||
- improved multihost test handling and created functions for normalizing | ||
commands before run (escaping) ([email protected]) | ||
|
||
* Tue Aug 01 2017 Petr Hracek <[email protected]> - 0.5.18-2 | ||
- Renaming package to the new name meta-test-family | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,22 @@ | ||
#!/usr/bin/python | ||
# -*- coding: utf-8 -*- | ||
# | ||
# This Modularity Testing Framework helps you to write tests for modules | ||
# Copyright (C) 2017 Red Hat, Inc. | ||
# | ||
# This program is free software; you can redistribute it and/or modify | ||
# it under the terms of the GNU General Public License as published by | ||
# he Free Software Foundation; either version 2 of the License, or | ||
# (at your option) any later version. | ||
# | ||
# This program is distributed in the hope that it will be useful, | ||
# but WITHOUT ANY WARRANTY; without even the implied warranty of | ||
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the | ||
# GNU General Public License for more details. | ||
# | ||
# You should have received a copy of the GNU General Public License along | ||
# with this program; if not, write to the Free Software Foundation, Inc., | ||
# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA. | ||
# | ||
# Authors: Petr Hracek <[email protected]> | ||
# |
Oops, something went wrong.