forked from openwrt/openwrt
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
build: scripts/config - update to kconfig-v6.6.16
The main goal here is to keep this close to upstream. Changes include: - allow symbols implied by y to become m - make 'imply' obey the direct dependency - allow only 'config', 'comment', and 'if' inside 'choice' - qconf: make search fully work again on split mode - qconf: navigate menus on hyperlinks - remove '---help---' support - qconf: allow to edit "int", "hex", "string" menus in-place - qconf: drop Qt4 support - nconf: fix core dump when searching in empty menu - nconf: stop endless search loops - Create links to main menu items in search - fix segmentation fault in menuconfig search - nconf: Add search jump feature - port qconf to work with Qt6 in addition to Qt5 - fix possible buffer overflow - fix memory leak from range properties Signed-off-by: Eneas U de Queiroz <[email protected]>
- Loading branch information
1 parent
f4d1990
commit 4b47965
Showing
28 changed files
with
1,390 additions
and
994 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,16 +1,12 @@ | ||
# SPDX-License-Identifier: GPL-2.0-only | ||
/conf | ||
/[gmnq]conf | ||
/[gmnq]conf-cfg | ||
/[gmnq]conf-bin | ||
/[gmnq]conf-cflags | ||
/[gmnq]conf-libs | ||
/qconf-moc.cc | ||
|
||
# From linux kconfig parent directories | ||
.* | ||
|
||
# OpenWrt-generated files | ||
# | ||
# Added by openwrt | ||
# | ||
mconf_check | ||
|
||
# Temporary files from older versions. They should be removed after the | ||
# end of support for OpenWrt 19.07. | ||
zconf.???.c | ||
zconf.hash.c |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,279 @@ | ||
# SPDX-License-Identifier: GPL-2.0 | ||
#### | ||
# kbuild: Generic definitions | ||
|
||
# Convenient variables | ||
comma := , | ||
quote := " | ||
squote := ' | ||
empty := | ||
space := $(empty) $(empty) | ||
space_escape := _-_SPACE_-_ | ||
pound := \# | ||
define newline | ||
|
||
|
||
endef | ||
|
||
### | ||
# Comparison macros. | ||
# Usage: $(call test-lt, $(CONFIG_LLD_VERSION), 150000) | ||
# | ||
# Use $(intcmp ...) if supported. (Make >= 4.4) | ||
# Otherwise, fall back to the 'test' shell command. | ||
ifeq ($(intcmp 1,0,,,y),y) | ||
test-ge = $(intcmp $(strip $1)0, $(strip $2)0,,y,y) | ||
test-gt = $(intcmp $(strip $1)0, $(strip $2)0,,,y) | ||
else | ||
test-ge = $(shell test $(strip $1)0 -ge $(strip $2)0 && echo y) | ||
test-gt = $(shell test $(strip $1)0 -gt $(strip $2)0 && echo y) | ||
endif | ||
test-le = $(call test-ge, $2, $1) | ||
test-lt = $(call test-gt, $2, $1) | ||
|
||
### | ||
# Name of target with a '.' as filename prefix. foo/bar.o => foo/.bar.o | ||
dot-target = $(dir $@).$(notdir $@) | ||
|
||
### | ||
# Name of target with a '.tmp_' as filename prefix. foo/bar.o => foo/.tmp_bar.o | ||
tmp-target = $(dir $@).tmp_$(notdir $@) | ||
|
||
### | ||
# The temporary file to save gcc -MMD generated dependencies must not | ||
# contain a comma | ||
depfile = $(subst $(comma),_,$(dot-target).d) | ||
|
||
### | ||
# filename of target with directory and extension stripped | ||
basetarget = $(basename $(notdir $@)) | ||
|
||
### | ||
# real prerequisites without phony targets | ||
real-prereqs = $(filter-out $(PHONY), $^) | ||
|
||
### | ||
# Escape single quote for use in echo statements | ||
escsq = $(subst $(squote),'\$(squote)',$1) | ||
|
||
### | ||
# Quote a string to pass it to C files. foo => '"foo"' | ||
stringify = $(squote)$(quote)$1$(quote)$(squote) | ||
|
||
### | ||
# The path to Kbuild or Makefile. Kbuild has precedence over Makefile. | ||
kbuild-dir = $(if $(filter /%,$(src)),$(src),$(srctree)/$(src)) | ||
kbuild-file = $(or $(wildcard $(kbuild-dir)/Kbuild),$(kbuild-dir)/Makefile) | ||
|
||
### | ||
# Read a file, replacing newlines with spaces | ||
# | ||
# Make 4.2 or later can read a file by using its builtin function. | ||
ifneq ($(filter-out 3.% 4.0 4.1, $(MAKE_VERSION)),) | ||
read-file = $(subst $(newline),$(space),$(file < $1)) | ||
else | ||
read-file = $(shell cat $1 2>/dev/null) | ||
endif | ||
|
||
### | ||
# Easy method for doing a status message | ||
kecho := : | ||
quiet_kecho := echo | ||
silent_kecho := : | ||
kecho := $($(quiet)kecho) | ||
|
||
### | ||
# filechk is used to check if the content of a generated file is updated. | ||
# Sample usage: | ||
# | ||
# filechk_sample = echo $(KERNELRELEASE) | ||
# version.h: FORCE | ||
# $(call filechk,sample) | ||
# | ||
# The rule defined shall write to stdout the content of the new file. | ||
# The existing file will be compared with the new one. | ||
# - If no file exist it is created | ||
# - If the content differ the new file is used | ||
# - If they are equal no change, and no timestamp update | ||
define filechk | ||
$(check-FORCE) | ||
$(Q)set -e; \ | ||
mkdir -p $(dir $@); \ | ||
trap "rm -f $(tmp-target)" EXIT; \ | ||
{ $(filechk_$(1)); } > $(tmp-target); \ | ||
if [ ! -r $@ ] || ! cmp -s $@ $(tmp-target); then \ | ||
$(kecho) ' UPD $@'; \ | ||
mv -f $(tmp-target) $@; \ | ||
fi | ||
endef | ||
|
||
### | ||
# Shorthand for $(Q)$(MAKE) -f scripts/Makefile.build obj= | ||
# Usage: | ||
# $(Q)$(MAKE) $(build)=dir | ||
build := -f $(srctree)/scripts/Makefile.build obj | ||
|
||
### | ||
# Shorthand for $(Q)$(MAKE) -f scripts/Makefile.dtbinst obj= | ||
# Usage: | ||
# $(Q)$(MAKE) $(dtbinst)=dir | ||
dtbinst := -f $(srctree)/scripts/Makefile.dtbinst obj | ||
|
||
### | ||
# Shorthand for $(Q)$(MAKE) -f scripts/Makefile.clean obj= | ||
# Usage: | ||
# $(Q)$(MAKE) $(clean)=dir | ||
clean := -f $(srctree)/scripts/Makefile.clean obj | ||
|
||
# pring log | ||
# | ||
# If quiet is "silent_", print nothing and sink stdout | ||
# If quiet is "quiet_", print short log | ||
# If quiet is empty, print short log and whole command | ||
silent_log_print = exec >/dev/null; | ||
quiet_log_print = $(if $(quiet_cmd_$1), echo ' $(call escsq,$(quiet_cmd_$1)$(why))';) | ||
log_print = echo '$(pound) $(call escsq,$(or $(quiet_cmd_$1),cmd_$1 $@)$(why))'; \ | ||
echo ' $(call escsq,$(cmd_$1))'; | ||
|
||
# Delete the target on interruption | ||
# | ||
# GNU Make automatically deletes the target if it has already been changed by | ||
# the interrupted recipe. So, you can safely stop the build by Ctrl-C (Make | ||
# will delete incomplete targets), and resume it later. | ||
# | ||
# However, this does not work when the stderr is piped to another program, like | ||
# $ make >&2 | tee log | ||
# Make dies with SIGPIPE before cleaning the targets. | ||
# | ||
# To address it, we clean the target in signal traps. | ||
# | ||
# Make deletes the target when it catches SIGHUP, SIGINT, SIGQUIT, SIGTERM. | ||
# So, we cover them, and also SIGPIPE just in case. | ||
# | ||
# Of course, this is unneeded for phony targets. | ||
delete-on-interrupt = \ | ||
$(if $(filter-out $(PHONY), $@), \ | ||
$(foreach sig, HUP INT QUIT TERM PIPE, \ | ||
trap 'rm -f $@; trap - $(sig); kill -s $(sig) $$$$' $(sig);)) | ||
|
||
# print and execute commands | ||
cmd = @$(if $(cmd_$(1)),set -e; $($(quiet)log_print) $(delete-on-interrupt) $(cmd_$(1)),:) | ||
|
||
### | ||
# if_changed - execute command if any prerequisite is newer than | ||
# target, or command line has changed | ||
# if_changed_dep - as if_changed, but uses fixdep to reveal dependencies | ||
# including used config symbols | ||
# if_changed_rule - as if_changed but execute rule instead | ||
# See Documentation/kbuild/makefiles.rst for more info | ||
|
||
ifneq ($(KBUILD_NOCMDDEP),1) | ||
# Check if both commands are the same including their order. Result is empty | ||
# string if equal. User may override this check using make KBUILD_NOCMDDEP=1 | ||
# If the target does not exist, the *.cmd file should not be included so | ||
# $(savedcmd_$@) gets empty. Then, target will be built even if $(newer-prereqs) | ||
# happens to become empty. | ||
cmd-check = $(filter-out $(subst $(space),$(space_escape),$(strip $(savedcmd_$@))), \ | ||
$(subst $(space),$(space_escape),$(strip $(cmd_$1)))) | ||
else | ||
# We still need to detect missing targets. | ||
cmd-check = $(if $(strip $(savedcmd_$@)),,1) | ||
endif | ||
|
||
# Replace >$< with >$$< to preserve $ when reloading the .cmd file | ||
# (needed for make) | ||
# Replace >#< with >$(pound)< to avoid starting a comment in the .cmd file | ||
# (needed for make) | ||
# Replace >'< with >'\''< to be able to enclose the whole string in '...' | ||
# (needed for the shell) | ||
make-cmd = $(call escsq,$(subst $(pound),$$(pound),$(subst $$,$$$$,$(cmd_$(1))))) | ||
|
||
# Find any prerequisites that are newer than target or that do not exist. | ||
# PHONY targets skipped in both cases. | ||
# If there is no prerequisite other than phony targets, $(newer-prereqs) becomes | ||
# empty even if the target does not exist. cmd-check saves this corner case. | ||
newer-prereqs = $(filter-out $(PHONY),$?) | ||
|
||
# It is a typical mistake to forget the FORCE prerequisite. Check it here so | ||
# no more breakage will slip in. | ||
check-FORCE = $(if $(filter FORCE, $^),,$(warning FORCE prerequisite is missing)) | ||
|
||
if-changed-cond = $(newer-prereqs)$(cmd-check)$(check-FORCE) | ||
|
||
# Execute command if command has changed or prerequisite(s) are updated. | ||
if_changed = $(if $(if-changed-cond),$(cmd_and_savecmd),@:) | ||
|
||
cmd_and_savecmd = \ | ||
$(cmd); \ | ||
printf '%s\n' 'savedcmd_$@ := $(make-cmd)' > $(dot-target).cmd | ||
|
||
# Execute the command and also postprocess generated .d dependencies file. | ||
if_changed_dep = $(if $(if-changed-cond),$(cmd_and_fixdep),@:) | ||
|
||
cmd_and_fixdep = \ | ||
$(cmd); \ | ||
scripts/basic/fixdep $(depfile) $@ '$(make-cmd)' > $(dot-target).cmd;\ | ||
rm -f $(depfile) | ||
|
||
# Usage: $(call if_changed_rule,foo) | ||
# Will check if $(cmd_foo) or any of the prerequisites changed, | ||
# and if so will execute $(rule_foo). | ||
if_changed_rule = $(if $(if-changed-cond),$(rule_$(1)),@:) | ||
|
||
### | ||
# why - tell why a target got built | ||
# enabled by make V=2 | ||
# Output (listed in the order they are checked): | ||
# (1) - due to target is PHONY | ||
# (2) - due to target missing | ||
# (3) - due to: file1.h file2.h | ||
# (4) - due to command line change | ||
# (5) - due to missing .cmd file | ||
# (6) - due to target not in $(targets) | ||
# (1) PHONY targets are always build | ||
# (2) No target, so we better build it | ||
# (3) Prerequisite is newer than target | ||
# (4) The command line stored in the file named dir/.target.cmd | ||
# differed from actual command line. This happens when compiler | ||
# options changes | ||
# (5) No dir/.target.cmd file (used to store command line) | ||
# (6) No dir/.target.cmd file and target not listed in $(targets) | ||
# This is a good hint that there is a bug in the kbuild file | ||
ifneq ($(findstring 2, $(KBUILD_VERBOSE)),) | ||
_why = \ | ||
$(if $(filter $@, $(PHONY)),- due to target is PHONY, \ | ||
$(if $(wildcard $@), \ | ||
$(if $(newer-prereqs),- due to: $(newer-prereqs), \ | ||
$(if $(cmd-check), \ | ||
$(if $(savedcmd_$@),- due to command line change, \ | ||
$(if $(filter $@, $(targets)), \ | ||
- due to missing .cmd file, \ | ||
- due to $(notdir $@) not in $$(targets) \ | ||
) \ | ||
) \ | ||
) \ | ||
), \ | ||
- due to target missing \ | ||
) \ | ||
) | ||
|
||
why = $(space)$(strip $(_why)) | ||
endif | ||
|
||
############################################################################### | ||
|
||
# delete partially updated (i.e. corrupted) files on error | ||
.DELETE_ON_ERROR: | ||
|
||
# do not delete intermediate files automatically | ||
# | ||
# .NOTINTERMEDIATE is more correct, but only available on newer Make versions. | ||
# Make 4.4 introduced .NOTINTERMEDIATE, and it appears in .FEATURES, but the | ||
# global .NOTINTERMEDIATE does not work. We can use it on Make > 4.4. | ||
# Use .SECONDARY for older Make versions, but "newer-prereq" cannot detect | ||
# deleted files. | ||
ifneq ($(and $(filter notintermediate, $(.FEATURES)),$(filter-out 4.4,$(MAKE_VERSION))),) | ||
.NOTINTERMEDIATE: | ||
else | ||
.SECONDARY: | ||
endif |
Oops, something went wrong.