forked from openwrt/openwrt
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
mac80211: only build ath10k with smallbuffers
When both variants of ath10k drivers are selected, any driver that is selected along is being built twice, one for each ath10k variant. Avoid these redundant builds by introducing an optional second parameter to config_package that lists the variants for which the package is to be built. If the symbol is to be set for all of the variants, $(ALL_VARIANTS) can be used. This is the case for the mac80211 and cfg80211 modules. If the parameter is empty, then the module will be selected and thus built when the first variant is compiled. Signed-off-by: Eneas U de Queiroz <[email protected]>
- Loading branch information
1 parent
4390ea4
commit 375dd23
Showing
2 changed files
with
12 additions
and
6 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -47,7 +47,13 @@ define KernelPackage/mac80211/Default | |
MAINTAINER:=Felix Fietkau <[email protected]> | ||
endef | ||
|
||
config_package=$(if $(CONFIG_PACKAGE_kmod-$(1)),m) | ||
# config_pacakge: | ||
# 1 = OpenWrt KernelPackage name | ||
# 2 = Optional list of variants for which the module may be selected: | ||
# If empty, the module is only selected with the first variant | ||
# Use $(ALL_VARIANTS) to allow module selection in all variants | ||
config_package=$(if $(and $(CONFIG_PACKAGE_kmod-$(1)),$(call mac80211_variant_check,$(2))),m) | ||
mac80211_variant_check=$(if $(ALL_VARIANTS),$(filter $(BUILD_VARIANT),$(if $(1),$(1),$(firstword $(ALL_VARIANTS)))),y) | ||
|
||
config-y:= \ | ||
WLAN \ | ||
|
@@ -72,10 +78,10 @@ config-y:= \ | |
WLAN_VENDOR_TI \ | ||
WLAN_VENDOR_ZYDAS \ | ||
|
||
config-$(call config_package,cfg80211) += CFG80211 | ||
config-$(call config_package,cfg80211,$(ALL_VARIANTS)) += CFG80211 | ||
config-$(CONFIG_PACKAGE_CFG80211_TESTMODE) += NL80211_TESTMODE | ||
|
||
config-$(call config_package,mac80211) += MAC80211 | ||
config-$(call config_package,mac80211,$(ALL_VARIANTS)) += MAC80211 | ||
config-$(CONFIG_PACKAGE_MAC80211_MESH) += MAC80211_MESH | ||
|
||
include ath.mk | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters