Skip to content

Commit

Permalink
aws-iot-securetunneling-localproxy: upgrade git -> new
Browse files Browse the repository at this point in the history
  • Loading branch information
aws-iot-embedded-linux-ci committed Nov 22, 2024
1 parent a127e44 commit e5a0872
Show file tree
Hide file tree
Showing 6 changed files with 19 additions and 45 deletions.
Original file line number Diff line number Diff line change
Expand Up @@ -17,16 +17,14 @@ DEPENDS += "\
BRANCH ?= "main"

# nooelint: oelint.file.patchsignedoff
SRC_URI = "\
git://[email protected]/aws-samples/aws-iot-securetunneling-localproxy.git;branch=${BRANCH};protocol=https \
file://boost-support-any.patch \
file://gcc13.patch \
file://gcc13_2.patch \
file://remove-cxx-standard.patch \
file://boost-include-format.patch \
file://run-ptest \
"
SRCREV = "9eace7470fbbee00473074f6dc763afdc9e11a4c"
SRC_URI = "git://[email protected]/aws-samples/aws-iot-securetunneling-localproxy.git;branch=${BRANCH};protocol=https \
file://boost-support-any.patch \
file://gcc13_2.patch \
file://remove-cxx-standard.patch \
file://boost-include-format.patch \
file://run-ptest \
"
SRCREV = "b9d706f92b64dc003514fa31ae804564fb0af429"

UPSTREAM_CHECK_COMMITS = "1"

Expand Down
Original file line number Diff line number Diff line change
@@ -1,16 +1,15 @@
From 0ac519e1cf096c70aa5deceff51c7f533a95eaf7 Mon Sep 17 00:00:00 2001
From 6ea963cfb223cafcf83092054e1590f5e95e9eb5 Mon Sep 17 00:00:00 2001
From: Thomas Roos <[email protected]>
Date: Mon, 11 Mar 2024 10:35:55 +0000
Subject: [PATCH] aws-iot-securetunneling-localproxy: boost 1.84 format include

Upstream-Status: Submitted [author]

---
src/config/ConfigFile.cpp | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/src/config/ConfigFile.cpp b/src/config/ConfigFile.cpp
index 105ca10..ce9f17b 100644
index 2a3205c..6e25a2f 100644
--- a/src/config/ConfigFile.cpp
+++ b/src/config/ConfigFile.cpp
@@ -19,6 +19,7 @@
Expand All @@ -21,7 +20,7 @@ index 105ca10..ce9f17b 100644
#include <boost/property_tree/ini_parser.hpp>
#include <boost/algorithm/string.hpp>
#include <boost/lexical_cast.hpp>
@@ -212,4 +213,4 @@ namespace aws { namespace iot { namespace securedtunneling { namespace config_fi
@@ -219,4 +220,4 @@ namespace aws { namespace iot { namespace securedtunneling { namespace config_fi
boost::filesystem::path full_path(boost::filesystem::current_path());
return (boost::format("%1%/config") % full_path.string()).str();
}
Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
From 55a765ca7c0fdc46a0cfac8f7cbf10a89d42ded3 Mon Sep 17 00:00:00 2001
From ad3ae0ebf4954fd2389870857f27d3d60f822bfd Mon Sep 17 00:00:00 2001
From: Thomas Roos <[email protected]>
Date: Fri, 10 Mar 2023 12:46:05 +0000
Subject: [PATCH] aws-iot-securetunneling-localproxy: support any boost version
Expand All @@ -9,10 +9,10 @@ Upstream-Status: Denied [Any version that compile should be good, team does only
1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/CMakeLists.txt b/CMakeLists.txt
index d54b8eb..34c897a 100644
index aa4e90b..02ac23c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -76,8 +76,7 @@ endif(BUILD_TESTS)
@@ -92,8 +92,7 @@ endif(BUILD_TESTS)
set(Boost_USE_STATIC_LIBS ON)
set(Boost_USE_DEBUG_RUNTIME OFF)
#set_property(GLOBAL PROPERTY Boost_USE_MULTITHREADED ON)
Expand Down
22 changes: 0 additions & 22 deletions recipes-iot/aws-iot-securetunneling-localproxy/files/gcc13.patch

This file was deleted.

Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
From 36fa8d748cf149a5db554cf18b4485b601d9dcc0 Mon Sep 17 00:00:00 2001
From ed1d14ea59b5dffc8107c9bddfa1d10939fa7f73 Mon Sep 17 00:00:00 2001
From: Thomas Roos <[email protected]>
Date: Mon, 8 Jan 2024 15:07:56 +0000
Subject: [PATCH] aws-iot-securetunneling-localproxy: fix GCC 13 build
Expand Down
Original file line number Diff line number Diff line change
@@ -1,16 +1,15 @@
From be61db954f8819dd7252b86f8aa5716da0d4d0b2 Mon Sep 17 00:00:00 2001
From e239941555cf9656e3b41a0bb130b5e258c970dd Mon Sep 17 00:00:00 2001
From: Thomas Roos <[email protected]>
Date: Tue, 9 Jan 2024 14:34:32 +0000
Subject: [PATCH] aws-iot-securetunneling-localproxy: remove setting of

Upstream-Status: Submitted [author]

---
CMakeLists.txt | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 34c897a..972e5a8 100644
index 02ac23c..fe71762 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,3 @@
Expand All @@ -19,7 +18,7 @@ index 34c897a..972e5a8 100644
set(AWS_TUNNEL_LOCAL_PROXY_TARGET_NAME localproxy)
set(AWS_TUNNEL_LOCAL_PROXY_LIB_NAME lproxy)
project(${AWS_TUNNEL_LOCAL_PROXY_TARGET_NAME} CXX)
@@ -21,9 +19,7 @@ endif ()
@@ -31,9 +29,7 @@ endif ()
########################################
# Section : Common Build setttings #
########################################
Expand All @@ -28,5 +27,5 @@ index 34c897a..972e5a8 100644
-set(CMAKE_CXX_STANDARD_REQUIRED ON) #...is required...
+# Disable extensions.
set(CMAKE_CXX_EXTENSIONS OFF) #...without compiler extensions like gnu++11

set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin)

0 comments on commit e5a0872

Please sign in to comment.