-
Notifications
You must be signed in to change notification settings - Fork 86
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
1 parent
ac991f0
commit bad69db
Showing
1 changed file
with
21 additions
and
40 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,49 +1,30 @@ | ||
From 3c3bc04d3aa71ff22abb0694c7d8dbb6840626fd Mon Sep 17 00:00:00 2001 | ||
From: Thomas Roos <[email protected]> | ||
Date: Fri, 12 Jan 2024 13:24:54 +0000 | ||
Subject: [PATCH] add new recipe aws-cli-v2 | ||
|
||
--- | ||
pyproject.toml | 26 +++++++++++++------------- | ||
requirements/bootstrap.txt | 2 +- | ||
2 files changed, 14 insertions(+), 14 deletions(-) | ||
|
||
diff --git a/pyproject.toml b/pyproject.toml | ||
index a29425b6a..23bf69200 100644 | ||
--- a/pyproject.toml | ||
+++ b/pyproject.toml | ||
@@ -1,6 +1,6 @@ | ||
[build-system] | ||
requires = [ | ||
-"flit_core>=3.7.1,<3.8.1", | ||
+"flit_core>=3.7.1", | ||
] | ||
build-backend = "pep517" | ||
backend-path = ["backends"] | ||
@@ -28,21 +28,21 @@ classifiers = [ | ||
Index: git/pyproject.toml | ||
=================================================================== | ||
--- git.orig/pyproject.toml | ||
+++ git/pyproject.toml | ||
@@ -28,21 +28,16 @@ classifiers = [ | ||
"Programming Language :: Python :: 3.11", | ||
] | ||
dependencies = [ | ||
- "colorama>=0.2.5,<0.4.7", | ||
- "docutils>=0.10,<0.20", | ||
- "cryptography>=3.3.2,<40.0.2", | ||
- "ruamel.yaml>=0.15.0,<=0.17.21", | ||
+ "colorama>=0.2.5", | ||
+ "docutils>=0.10", | ||
+ "cryptography>=3.3.2", | ||
+ "ruamel.yaml>=0.15.0", | ||
# ruamel.yaml only requires ruamel.yaml.clib for Python versions | ||
# less than or equal to Python 3.10. In order to ensure we have | ||
# a consistent dependency closure across all Python versions, | ||
# we explicitly include ruamel.yaml.clib as a dependency. | ||
- # ruamel.yaml only requires ruamel.yaml.clib for Python versions | ||
- # less than or equal to Python 3.10. In order to ensure we have | ||
- # a consistent dependency closure across all Python versions, | ||
- # we explicitly include ruamel.yaml.clib as a dependency. | ||
- "ruamel.yaml.clib>=0.2.0,<=0.2.7", | ||
- "prompt-toolkit>=3.0.24,<3.0.39", | ||
- "distro>=1.5.0,<1.9.0", | ||
- "awscrt>=0.19.18,<=0.19.19", | ||
- "python-dateutil>=2.1,<3.0.0", | ||
- "jmespath>=0.7.1,<1.1.0", | ||
- "urllib3>=1.25.4,<1.27", | ||
+ "ruamel.yaml.clib>=0.2.0", | ||
+ "colorama>=0.2.5", | ||
+ "docutils>=0.10", | ||
+ "cryptography>=3.3.2", | ||
+ "ruamel.yaml>=0.15.0", | ||
+ "prompt-toolkit>=3.0.24", | ||
+ "distro>=1.5.0", | ||
+ "awscrt>=0.19.18", | ||
|
@@ -52,19 +33,19 @@ index a29425b6a..23bf69200 100644 | |
+ "urllib3>=1.25.4", | ||
] | ||
dynamic = ["version"] | ||
@@ -98,4 +98,4 @@ filterwarnings = [ | ||
|
||
@@ -98,4 +93,4 @@ filterwarnings = [ | ||
] | ||
|
||
[tool.black] | ||
-line-length = 80 | ||
\ No newline at end of file | ||
+line-length = 80 | ||
diff --git a/requirements/bootstrap.txt b/requirements/bootstrap.txt | ||
index f50b4ee36..2a210a9b6 100644 | ||
--- a/requirements/bootstrap.txt | ||
+++ b/requirements/bootstrap.txt | ||
Index: git/requirements/bootstrap.txt | ||
=================================================================== | ||
--- git.orig/requirements/bootstrap.txt | ||
+++ git/requirements/bootstrap.txt | ||
@@ -1,2 +1,2 @@ | ||
pip>=22.0.0,<24.0.0 | ||
-flit_core>=3.7.1,<3.8.1 | ||
-flit_core>=3.7.1,<3.9.1 | ||
+flit_core>=3.7.1 |