-
Notifications
You must be signed in to change notification settings - Fork 86
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
amazon-cloudwatch-publisher: add ptest, fix oelint-adv warn + err
- Loading branch information
1 parent
41bc45b
commit 6828250
Showing
3 changed files
with
49 additions
and
32 deletions.
There are no files selected for viewing
57 changes: 30 additions & 27 deletions
57
recipes-cloud/amazon-cloudwatch-publisher/amazon-cloudwatch-publisher_1.2.4.bb
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,15 @@ | ||
#!/bin/sh | ||
set -euxo pipefail | ||
|
||
cd /opt/aws/amazon-cloudwatch-publisher | ||
|
||
./amazon-cloudwatch-publisher & | ||
sleep 30 | ||
grep "Instance ID is" /opt/aws/amazon-cloudwatch-publisher/logs/amazon-cloudwatch-publisher.log | ||
|
||
RETVAL=$? | ||
if [ $RETVAL -eq 0 ] ; then | ||
echo "PASS: amazon-cloudwatch-publisher: startup test" | ||
else | ||
echo "FAIL: amazon-cloudwatch-publisher: startup test" | ||
fi |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,15 +1,14 @@ | ||
SUMMARY = "Timeloop" | ||
DESCRIPTION = "" | ||
HOMEPAGE = "" | ||
DESCRIPTION = "An elegant periodic task executor " | ||
HOMEPAGE = "https://github.com/sankalpjonn/timeloop" | ||
LICENSE = "MIT" | ||
LIC_FILES_CHKSUM = "file://LICENSE;md5=030635eb18c38d9fd120c13a324721b7" | ||
|
||
inherit setuptools3 | ||
|
||
SRC_URI = "git://github.com/sankalpjonn/timeloop.git;protocol=https;branch=master" | ||
SRCREV = "36ec5cbb133a6dcfb5316f59b5e11765c14e62c2" | ||
|
||
S = "${WORKDIR}/git" | ||
|
||
RDEPENDS:${PN} += "python3-core" | ||
inherit setuptools3 | ||
|
||
RDEPENDS:${PN} += "python3-core" |