Skip to content

Commit

Permalink
Update Cargo metadata
Browse files Browse the repository at this point in the history
  • Loading branch information
mrLSD committed Jun 4, 2024
1 parent 4bcc4f9 commit d85496f
Show file tree
Hide file tree
Showing 6 changed files with 37 additions and 36 deletions.
6 changes: 3 additions & 3 deletions .github/workflows/rust.yml
Original file line number Diff line number Diff line change
Expand Up @@ -55,15 +55,15 @@ jobs:

- name: Run Ethereum state tests
run: |
cargo run --release --features=enable-slow-tests -p evm-jsontests -- \
cargo run -r -p evm-jsontests -F enable-slow-tests -- \
state -f -s cancun \
ethtests/GeneralStateTests/
- name: Run Ethereum vm tests
run: |
cargo run --release --features=enable-slow-tests -p evm-jsontests -- \
cargo run -r -p evm-jsontests -F enable-slow-tests -- \
vm -f \
ethtests/LegacyTests/Constantinople/VMTests/vmArithmeticTest \
ethtests/LegacyTests/Constantinople/VMTests/vmArithmeticTest \
ethtests/LegacyTests/Constantinople/VMTests/vmBitwiseLogicOperation \
ethtests/LegacyTests/Constantinople/VMTests/vmBlockInfoTest \
ethtests/LegacyTests/Constantinople/VMTests/vmEnvironmentalInfo \
Expand Down
13 changes: 7 additions & 6 deletions Cargo.toml
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
[package]
name = "evm"
version = "0.41.0"
version = "0.42.0"
license = "Apache-2.0"
authors = ["Wei Tang <[email protected]>", "Parity Technologies <[email protected]>"]
description = "SputnikVM - a Portable Blockchain Virtual Machine"
repository = "https://github.com/sorpaas/rust-evm"
keywords = ["no_std", "ethereum"]
edition = "2018"
edition = "2021"

[dependencies]
auto_impl = "1.0"
Expand All @@ -19,12 +19,12 @@ sha3 = { version = "0.10", default-features = false }
# Optional dependencies
environmental = { version = "1.1.2", default-features = false, optional = true }
scale-codec = { package = "parity-scale-codec", version = "3.2", default-features = false, features = ["derive"], optional = true }
scale-info = { version = "2.3", default-features = false, features = ["derive"], optional = true }
scale-info = { version = "2.11", default-features = false, features = ["derive"], optional = true }
serde = { version = "1.0", default-features = false, features = ["derive"], optional = true }

evm-core = { version = "0.41", path = "core", default-features = false }
evm-gasometer = { version = "0.41", path = "gasometer", default-features = false }
evm-runtime = { version = "0.41", path = "runtime", default-features = false }
evm-core = { version = "0.42", path = "core", default-features = false }
evm-gasometer = { version = "0.42", path = "gasometer", default-features = false }
evm-runtime = { version = "0.42", path = "runtime", default-features = false }

[dev-dependencies]
criterion = "0.5"
Expand Down Expand Up @@ -76,6 +76,7 @@ force-debug = [
]
create-fixed = []
print-debug = ["evm-gasometer/print-debug"]
# enable-slow-tests = ["evm-jsontests/enable-slow-tests"]

[workspace]
members = [
Expand Down
24 changes: 12 additions & 12 deletions core/Cargo.toml
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
[package]
name = "evm-core"
version = "0.41.0"
version = "0.42.0"
license = "Apache-2.0"
authors = ["Wei Tang <[email protected]>", "Parity Technologies <[email protected]>"]
description = "Portable Ethereum Virtual Machine implementation written in pure Rust."
repository = "https://github.com/sorpaas/rust-evm"
keywords = ["no_std", "ethereum"]
edition = "2018"
edition = "2021"

[dependencies]
log = { version = "0.4", optional = true }
Expand All @@ -21,21 +21,21 @@ hex = "0.4"
[features]
default = ["std"]
std = [
"primitive-types/std",
"serde/std",
"scale-codec/std",
"scale-info/std",
"primitive-types/std",
"serde/std",
"scale-codec/std",
"scale-info/std",
]
with-codec = [
"scale-codec",
"scale-info",
"primitive-types/impl-codec",
"scale-codec",
"scale-info",
"primitive-types/impl-codec",
]
with-serde = [
"serde",
"primitive-types/impl-serde",
"serde",
"primitive-types/impl-serde",
]
force-debug = [
"log",
"log",
]
tracing = []
4 changes: 2 additions & 2 deletions fuzzer/Cargo.toml
Original file line number Diff line number Diff line change
Expand Up @@ -2,14 +2,14 @@
name = "evm-fuzzer"
version = "0.2.0-dev"
authors = ["Vincent Ulitzsch <[email protected]>"]
edition = "2018"
edition = "2021"
description = "Fuzzer for EVM."
license = "Apache-2.0"

[dependencies]
honggfuzz = "0.5"

evm-core = { version = "0.41", path = "../core" }
evm-core = { version = "0.42", path = "../core" }

[[bin]]
name = "evm_fuzz"
Expand Down
8 changes: 4 additions & 4 deletions gasometer/Cargo.toml
Original file line number Diff line number Diff line change
@@ -1,20 +1,20 @@
[package]
name = "evm-gasometer"
version = "0.41.0"
version = "0.42.0"
license = "Apache-2.0"
authors = ["Wei Tang <[email protected]>", "Parity Technologies <[email protected]>"]
description = "Portable Ethereum Virtual Machine implementation written in pure Rust."
repository = "https://github.com/sorpaas/rust-evm"
keywords = ["no_std", "ethereum"]
edition = "2018"
edition = "2021"

[dependencies]
environmental = { version = "1.1.2", default-features = false, optional = true }
log = { version = "0.4", optional = true }
primitive-types = { version = "0.12", default-features = false }

evm-core = { version = "0.41", path = "../core", default-features = false }
evm-runtime = { version = "0.41", path = "../runtime", default-features = false }
evm-core = { version = "0.42", path = "../core", default-features = false }
evm-runtime = { version = "0.42", path = "../runtime", default-features = false }

[features]
default = ["std"]
Expand Down
18 changes: 9 additions & 9 deletions runtime/Cargo.toml
Original file line number Diff line number Diff line change
@@ -1,29 +1,29 @@
[package]
name = "evm-runtime"
version = "0.41.0"
version = "0.42.0"
license = "Apache-2.0"
authors = ["Wei Tang <[email protected]>", "Parity Technologies <[email protected]>"]
description = "SputnikVM - a Portable Blockchain Virtual Machine"
repository = "https://github.com/sorpaas/rust-evm"
keywords = ["no_std", "ethereum"]
edition = "2018"
edition = "2021"

[dependencies]
auto_impl = "1.0"
environmental = { version = "1.1.2", default-features = false, optional = true }
environmental = { version = "1.1", default-features = false, optional = true }
primitive-types = { version = "0.12", default-features = false }
sha3 = { version = "0.10", default-features = false }

evm-core = { version = "0.41", path = "../core", default-features = false }
evm-core = { version = "0.42", path = "../core", default-features = false }

[features]
default = ["std"]
std = [
"environmental/std",
"primitive-types/std",
"sha3/std",
"evm-core/std",
"environmental/std",
"primitive-types/std",
"sha3/std",
"evm-core/std",
]
tracing = [
"environmental",
"environmental",
]

0 comments on commit d85496f

Please sign in to comment.