Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Feat(eos_designs): Added support for use different router IDs per VRF defined in network services #4775

Open
wants to merge 14 commits into
base: devel
Choose a base branch
from
Open
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
l3leaf:
defaults:
loopback_ipv4_pool: 10.42.0.0/24
vtep_loopback_ipv4_pool: 10.43.0.0/24
mlag_interfaces: [ Ethernet5, Ethernet6 ]
mlag_peer_ipv4_pool: 10.255.252.0/24
mlag_peer_l3_ipv4_pool: 10.255.251.0/24

node_groups:
- group: vrf-router-id
nodes:
- name: vrf-bgp-vtep-router-id
bgp_as: 42
id: 42

type: l3leaf

tenants:
# Tenant A Specific Information - VRFs / VLANs
- name: Tenant_X
mac_vrf_vni_base: 11000
vrfs:
- name: Tenant_X_OP_Zone
vrf_id: 20
svis:
- id: 310
name: Tenant_X_OP_Zone_1
tags: [opzone]
enabled: true
bgp:
router_id: diagnostic_loopback

expected_error_message: >-
Invalid configuration on VRF 'Tenant_X_OP_Zone' in Tenant 'Tenant_X'.
'vtep_diagnostic.loopback' along with either 'vtep_diagnostic.loopback_ip_pools' or 'vtep_diagnostic.loopback_ip_range' must be defined
when 'router_id' is set to 'vtep_diagnostic' on the VRF.
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
l3leaf:
defaults:
loopback_ipv4_pool: 10.42.0.0/24
vtep_loopback_ipv4_pool: 10.43.0.0/24
mlag_interfaces: [ Ethernet5, Ethernet6 ]
mlag_peer_ipv4_pool: 10.255.252.0/24
mlag_peer_l3_ipv4_pool: 10.255.251.0/24

node_groups:
- group: vrf-router-id
nodes:
- name: vrf-ospf-vtep-router-id
bgp_as: 42
id: 42

type: l3leaf

tenants:
# Tenant A Specific Information - VRFs / VLANs
- name: Tenant_X
mac_vrf_vni_base: 11000
vrfs:
- name: Tenant_X_OP_Zone
vrf_id: 20
svis:
- id: 310
name: Tenant_X_OP_Zone_1
tags: [opzone]
enabled: true
ospf:
enabled: true
router_id: diagnostic_loopback

expected_error_message: >-
Invalid configuration on VRF 'Tenant_X_OP_Zone' in Tenant 'Tenant_X'.
'vtep_diagnostic.loopback' along with either 'vtep_diagnostic.loopback_ip_pools' or 'vtep_diagnostic.loopback_ip_range' must be defined
when 'router_id' is set to 'vtep_diagnostic' on the VRF.
Copy link
Contributor

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

This error message also needs to be updated with the new wording.

Copy link
Contributor Author

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

updated

Original file line number Diff line number Diff line change
Expand Up @@ -148,6 +148,12 @@ all:
hosts:
duplicate-vlans-mlag-a:
duplicate-vlans-mlag-b:
VRF_BGP_VTEP_ROUTER_ID:
hosts:
vrf-bgp-vtep-router-id:
VRF_OSPF_VTEP_ROUTER_ID:
hosts:
vrf-ospf-vtep-router-id:

EOS_DESIGNS_FAILURES_EXCLUDED:
# These hosts are included in the vars and facts, but will not be included in the structured config run,
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -477,7 +477,6 @@ router bgp 65105
router-id 192.168.255.15
!
router ospf 14 vrf Tenant_A_WAN_Zone
router-id 192.168.255.15
passive-interface default
no passive-interface Vlan150
redistribute bgp
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -375,7 +375,6 @@ router bgp 65101
rd 1.1.1.1:12
route-target import evpn 1234:12
route-target export evpn 1234:12
router-id 192.168.42.42
redistribute connected
!
vrf Tenant_A_OP_Zone
Expand All @@ -394,7 +393,7 @@ router bgp 65101
redistribute connected
!
router ospf 9 vrf Tenant_A_OP_Zone
router-id 192.168.42.42
router-id 10.10.10.10
passive-interface default
no passive-interface Vlan113
redistribute bgp
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -822,14 +822,13 @@ router bgp 65102
rd 65001:12
route-target import evpn 100000:12
route-target export evpn 100000:12
router-id 192.168.255.10
redistribute connected
!
vrf Tenant_A_DB_Zone
rd 65001:13
route-target import evpn 100000:13
route-target export evpn 100000:13
router-id 192.168.255.10
router-id 11.11.11.11
redistribute connected
!
vrf Tenant_A_OP_Zone
Expand Down Expand Up @@ -877,7 +876,7 @@ router bgp 65102
redistribute static
!
router ospf 16 vrf Tenant_A_OSPF
router-id 192.168.255.10
router-id 10.255.11.10
passive-interface default
no passive-interface Ethernet22
no passive-interface Ethernet23
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -786,14 +786,13 @@ router bgp 65102
rd 65001:12
route-target import evpn 100000:12
route-target export evpn 100000:12
router-id 192.168.255.11
redistribute connected
!
vrf Tenant_A_DB_Zone
rd 65001:13
route-target import evpn 100000:13
route-target export evpn 100000:13
router-id 192.168.255.11
router-id 11.11.11.11
redistribute connected
!
vrf Tenant_A_OP_Zone
Expand Down Expand Up @@ -841,7 +840,7 @@ router bgp 65102
redistribute static
!
router ospf 16 vrf Tenant_A_OSPF
router-id 192.168.255.11
router-id 10.255.11.11
passive-interface default
no passive-interface Ethernet24
redistribute bgp
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -1098,7 +1098,6 @@ router bgp 65103
rd 65103:12
route-target import evpn 12:12
route-target export evpn 12:12
router-id 192.168.255.12
update wait-install
neighbor 10.255.251.7 peer group MLAG-PEERS
neighbor 10.255.251.7 description DC1-SVC3B
Expand All @@ -1108,7 +1107,7 @@ router bgp 65103
rd 65103:13
route-target import evpn 13:13
route-target export evpn 13:13
router-id 192.168.255.12
router-id 11.11.11.11
update wait-install
neighbor 10.255.251.7 peer group MLAG-PEERS
neighbor 10.255.251.7 description DC1-SVC3B
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -1062,7 +1062,6 @@ router bgp 65103
rd 65103:12
route-target import evpn 12:12
route-target export evpn 12:12
router-id 192.168.255.13
update wait-install
neighbor 10.255.251.6 peer group MLAG-PEERS
neighbor 10.255.251.6 description DC1-SVC3A
Expand All @@ -1072,7 +1071,7 @@ router bgp 65103
rd 65103:13
route-target import evpn 13:13
route-target export evpn 13:13
router-id 192.168.255.13
router-id 11.11.11.11
update wait-install
neighbor 10.255.251.6 peer group MLAG-PEERS
neighbor 10.255.251.6 description DC1-SVC3A
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -656,7 +656,6 @@ router bgp 65110
rd 192.168.255.21:12
route-target import evpn 12:12
route-target export evpn 12:12
router-id 192.168.255.21
update wait-install
neighbor 10.255.251.25 peer group MLAG-PEERS
neighbor 10.255.251.25 description DC1_UNDEPLOYED_LEAF1B
Expand All @@ -666,7 +665,7 @@ router bgp 65110
rd 192.168.255.21:13
route-target import evpn 13:13
route-target export evpn 13:13
router-id 192.168.255.21
router-id 11.11.11.11
update wait-install
neighbor 10.255.251.25 peer group MLAG-PEERS
neighbor 10.255.251.25 description DC1_UNDEPLOYED_LEAF1B
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -656,7 +656,6 @@ router bgp 65111
rd 192.168.255.22:12
route-target import evpn 12:12
route-target export evpn 12:12
router-id 192.168.255.22
update wait-install
neighbor 10.255.251.24 peer group MLAG-PEERS
neighbor 10.255.251.24 description DC1_UNDEPLOYED_LEAF1A
Expand All @@ -666,7 +665,7 @@ router bgp 65111
rd 192.168.255.22:13
route-target import evpn 13:13
route-target export evpn 13:13
router-id 192.168.255.22
router-id 11.11.11.11
update wait-install
neighbor 10.255.251.24 peer group MLAG-PEERS
neighbor 10.255.251.24 description DC1_UNDEPLOYED_LEAF1A
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -423,7 +423,7 @@ router bgp 65151
rd 192.168.255.33:20
route-target import evpn 20:20
route-target export evpn 20:20
router-id 192.168.255.33
router-id 10.255.1.33
redistribute connected
!
end
Original file line number Diff line number Diff line change
Expand Up @@ -423,7 +423,7 @@ router bgp 65152
rd 192.168.255.34:20
route-target import evpn 20:20
route-target export evpn 20:20
router-id 192.168.255.34
router-id 10.255.1.34
redistribute connected
!
end
Original file line number Diff line number Diff line change
Expand Up @@ -228,7 +228,7 @@ router bgp 65153
rd 192.168.255.35:20
route-target import evpn 20:20
route-target export evpn 20:20
router-id 192.168.255.35
router-id 10.255.1.35
redistribute connected
!
end
Original file line number Diff line number Diff line change
Expand Up @@ -659,14 +659,13 @@ router bgp 101
rd 192.168.255.109:12
route-target import evpn 12:12
route-target export evpn 12:12
router-id 192.168.255.109
redistribute connected
!
vrf Tenant_A_DB_Zone
rd 192.168.255.109:13
route-target import evpn 13:13
route-target export evpn 13:13
router-id 192.168.255.109
router-id 11.11.11.11
redistribute connected
!
vrf Tenant_A_ERP_Zone
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -595,7 +595,6 @@ router_ospf:
- id: 14
vrf: Tenant_A_WAN_Zone
passive_interface_default: true
router_id: 192.168.255.15
no_passive_interfaces:
- Vlan150
max_lsa: 15000
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -339,7 +339,6 @@ router_bgp:
- address_family: evpn
route_targets:
- '1234:12'
router_id: 192.168.42.42
redistribute:
connected:
enabled: true
Expand Down Expand Up @@ -395,7 +394,7 @@ router_ospf:
- id: 9
vrf: Tenant_A_OP_Zone
passive_interface_default: true
router_id: 192.168.42.42
router_id: 10.10.10.10
no_passive_interfaces:
- Vlan113
redistribute:
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -748,7 +748,6 @@ router_bgp:
- address_family: evpn
route_targets:
- '100000:12'
router_id: 192.168.255.10
redistribute:
connected:
enabled: true
Expand All @@ -763,7 +762,7 @@ router_bgp:
- address_family: evpn
route_targets:
- '100000:13'
router_id: 192.168.255.10
router_id: 11.11.11.11
redistribute:
connected:
enabled: true
Expand Down Expand Up @@ -881,7 +880,7 @@ router_ospf:
- id: 16
vrf: Tenant_A_OSPF
passive_interface_default: true
router_id: 192.168.255.10
router_id: 10.255.11.10
no_passive_interfaces:
- Ethernet22
- Ethernet23
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -688,7 +688,6 @@ router_bgp:
- address_family: evpn
route_targets:
- '100000:12'
router_id: 192.168.255.11
redistribute:
connected:
enabled: true
Expand All @@ -703,7 +702,7 @@ router_bgp:
- address_family: evpn
route_targets:
- '100000:13'
router_id: 192.168.255.11
router_id: 11.11.11.11
redistribute:
connected:
enabled: true
Expand Down Expand Up @@ -821,7 +820,7 @@ router_ospf:
- id: 16
vrf: Tenant_A_OSPF
passive_interface_default: true
router_id: 192.168.255.11
router_id: 10.255.11.11
no_passive_interfaces:
- Ethernet24
redistribute:
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -1101,7 +1101,6 @@ router_bgp:
- address_family: evpn
route_targets:
- '12:12'
router_id: 192.168.255.12
updates:
wait_install: true
neighbors:
Expand All @@ -1122,7 +1121,7 @@ router_bgp:
- address_family: evpn
route_targets:
- '13:13'
router_id: 192.168.255.12
router_id: 11.11.11.11
updates:
wait_install: true
neighbors:
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -1047,7 +1047,6 @@ router_bgp:
- address_family: evpn
route_targets:
- '12:12'
router_id: 192.168.255.13
updates:
wait_install: true
neighbors:
Expand All @@ -1068,7 +1067,7 @@ router_bgp:
- address_family: evpn
route_targets:
- '13:13'
router_id: 192.168.255.13
router_id: 11.11.11.11
updates:
wait_install: true
neighbors:
Expand Down
Loading
Loading