Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Feat(eos_designs): Restrict PTP on certain uplinks #4645

Closed
Closed
Show file tree
Hide file tree
Changes from all commits
Commits
File filter

Filter by extension

Filter by extension

Conversations
Failed to load comments.
Loading
Jump to
Jump to file
Failed to load files.
Loading
Diff view
Diff view
Original file line number Diff line number Diff line change
Expand Up @@ -26,7 +26,7 @@ management api http-commands
no shutdown
!
interface Port-Channel1
description L2_ptp-test-leaf_Port-Channel11
description L2_ptp-tests-leaf1_Port-Channel11
no shutdown
switchport trunk allowed vlan 11
switchport mode trunk
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -39,7 +39,7 @@ management api http-commands
no shutdown
!
interface Port-Channel1
description L2_ptp-test-leaf_Port-Channel14
description L2_ptp-tests-leaf1_Port-Channel14
no shutdown
switchport trunk allowed vlan 11
switchport mode trunk
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -39,7 +39,7 @@ management api http-commands
no shutdown
!
interface Port-Channel1
description L2_ptp-test-leaf_Port-Channel12
description L2_ptp-tests-leaf1_Port-Channel12
no shutdown
switchport trunk allowed vlan 11
switchport mode trunk
Expand Down
Copy link
Contributor

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Why are these configs changing?

Original file line number Diff line number Diff line change
Expand Up @@ -24,24 +24,11 @@ ptp monitor threshold missing-message delay-resp 3 sequence-ids
ptp monitor threshold missing-message announce 3 sequence-ids
!
spanning-tree mode mstp
no spanning-tree vlan-id 4093-4094
spanning-tree mst 0 priority 4096
!
vlan 11
name VLAN11
!
vlan 3000
name MLAG_L3_VRF_VRF1
trunk group MLAG
!
vlan 4093
name MLAG_L3
trunk group MLAG
!
vlan 4094
name MLAG
trunk group MLAG
!
vrf instance MGMT
!
vrf instance VRF1
Expand All @@ -59,44 +46,27 @@ interface Port-Channel6
switchport access vlan 11
switchport mode access
switchport
mlag 6
ptp enable
ptp mpass
ptp announce interval 0
ptp announce timeout 3
ptp delay-req interval -3
ptp role master
ptp sync-message interval -3
ptp transport ipv4
!
interface Port-Channel9
description MLAG_ptp-tests-leaf2_Port-Channel9
no shutdown
switchport mode trunk
switchport trunk group MLAG
switchport
ptp enable
ptp announce interval 0
ptp announce timeout 3
ptp delay-req interval -3
ptp sync-message interval -3
ptp transport ipv4
!
interface Port-Channel11
description L2_ptp-tests-l2leaf1-ptp-disabled_Port-Channel1
no shutdown
switchport trunk allowed vlan 11
switchport mode trunk
switchport
mlag 11
!
interface Port-Channel12
description L2_ptp-tests-l2leaf2-ptp-enabled_Port-Channel1
no shutdown
switchport trunk allowed vlan 11
switchport mode trunk
switchport
mlag 12
ptp enable
ptp announce interval 0
ptp announce timeout 3
Expand All @@ -110,7 +80,6 @@ interface Port-Channel14
switchport trunk allowed vlan 11
switchport mode trunk
switchport
mlag 14
!
interface Ethernet1
description P2P_ptp-tests-spine1_Ethernet1
Expand Down Expand Up @@ -172,16 +141,6 @@ interface Ethernet6
no shutdown
channel-group 6 mode active
!
interface Ethernet9
description MLAG_ptp-tests-leaf2_Ethernet9
no shutdown
channel-group 9 mode active
!
interface Ethernet10
description MLAG_ptp-tests-leaf2_Ethernet10
no shutdown
channel-group 9 mode active
!
interface Ethernet11
description L2_ptp-tests-l2leaf1-ptp-disabled_Ethernet1
no shutdown
Expand Down Expand Up @@ -232,30 +191,9 @@ interface Vlan11
vrf VRF1
ip address 172.16.11.1/24
!
interface Vlan3000
description MLAG_L3_VRF_VRF1
no shutdown
mtu 9214
vrf VRF1
ip address 10.254.1.96/31
!
interface Vlan4093
description MLAG_L3
no shutdown
mtu 9214
ip address 10.254.1.96/31
!
interface Vlan4094
description MLAG
no shutdown
mtu 9214
no autostate
ip address 10.254.1.64/31
!
interface Vxlan1
description ptp-tests-leaf1_VTEP
vxlan source-interface Loopback1
vxlan virtual-router encapsulation mac-address mlag-system-id
vxlan udp-port 4789
vxlan vlan 11 vni 10011
vxlan vrf VRF1 vni 1
Expand All @@ -268,31 +206,11 @@ ip prefix-list PL-LOOPBACKS-EVPN-OVERLAY
seq 10 permit 10.254.1.0/27 eq 32
seq 20 permit 10.254.11.0/27 eq 32
!
ip prefix-list PL-MLAG-PEER-VRFS
seq 10 permit 10.254.1.96/31
!
mlag configuration
domain-id ptp-test-leaf
local-interface Vlan4094
peer-address 10.254.1.65
peer-link Port-Channel9
reload-delay mlag 300
reload-delay non-mlag 330
!
ip route vrf MGMT 0.0.0.0/0 192.168.0.1
!
route-map RM-CONN-2-BGP permit 10
match ip address prefix-list PL-LOOPBACKS-EVPN-OVERLAY
!
route-map RM-CONN-2-BGP-VRFS deny 10
match ip address prefix-list PL-MLAG-PEER-VRFS
!
route-map RM-CONN-2-BGP-VRFS permit 20
!
route-map RM-MLAG-PEER-IN permit 10
description Make routes learned over MLAG Peer-link less preferred on spines to ensure optimal routing
set origin incomplete
!
router bfd
multihop interval 300 min-rx 300 multiplier 3
!
Expand All @@ -309,15 +227,6 @@ router bgp 65101
neighbor IPv4-UNDERLAY-PEERS peer group
neighbor IPv4-UNDERLAY-PEERS send-community
neighbor IPv4-UNDERLAY-PEERS maximum-routes 12000
neighbor MLAG-IPv4-UNDERLAY-PEER peer group
neighbor MLAG-IPv4-UNDERLAY-PEER remote-as 65101
neighbor MLAG-IPv4-UNDERLAY-PEER next-hop-self
neighbor MLAG-IPv4-UNDERLAY-PEER description ptp-tests-leaf2
neighbor MLAG-IPv4-UNDERLAY-PEER route-map RM-MLAG-PEER-IN in
neighbor MLAG-IPv4-UNDERLAY-PEER send-community
neighbor MLAG-IPv4-UNDERLAY-PEER maximum-routes 12000
neighbor 10.254.1.97 peer group MLAG-IPv4-UNDERLAY-PEER
neighbor 10.254.1.97 description ptp-tests-leaf2_Vlan4093
neighbor 10.254.2.0 peer group IPv4-UNDERLAY-PEERS
neighbor 10.254.2.0 remote-as 65200
neighbor 10.254.2.0 description ptp-tests-spine1_Ethernet1
Expand All @@ -340,15 +249,12 @@ router bgp 65101
address-family ipv4
no neighbor EVPN-OVERLAY-PEERS activate
neighbor IPv4-UNDERLAY-PEERS activate
neighbor MLAG-IPv4-UNDERLAY-PEER activate
!
vrf VRF1
rd 10.254.1.1:1
route-target import evpn 1:1
route-target export evpn 1:1
router-id 10.254.1.1
neighbor 10.254.1.97 peer group MLAG-IPv4-UNDERLAY-PEER
neighbor 10.254.1.97 description ptp-tests-leaf2_Vlan3000
redistribute connected route-map RM-CONN-2-BGP-VRFS
redistribute connected
!
end
Loading
Loading