-
Notifications
You must be signed in to change notification settings - Fork 6
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
net-analyzer/nagios-plugin-check_smart: add 6.14.3
Signed-off-by: Anders Larsson <[email protected]>
- Loading branch information
1 parent
66b646d
commit d805ad5
Showing
2 changed files
with
29 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
27 changes: 27 additions & 0 deletions
27
net-analyzer/nagios-plugin-check_smart/nagios-plugin-check_smart-6.14.3.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,27 @@ | ||
# Copyright 1999-2024 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit perl-module vcs-snapshot | ||
|
||
MY_PN="${PN/nagios-plugin-/}" | ||
|
||
DESCRIPTION="Nagios plugin to monitor SMART health values for disks" | ||
HOMEPAGE="https://github.com/Napsty/check_smart" | ||
SRC_URI="https://github.com/Napsty/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-3+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
|
||
RDEPEND=" | ||
virtual/perl-Getopt-Long | ||
sys-apps/smartmontools | ||
" | ||
|
||
src_install() { | ||
local plugindir="/usr/$(get_libdir)/nagios/plugins" | ||
exeinto "${plugindir}" | ||
newexe check_smart.pl check_smart | ||
} |