Skip to content

Commit

Permalink
Merge pull request qualcomm-linux#327 from alimon/dunfell_5.13
Browse files Browse the repository at this point in the history
Kernel recipe structure changes and Linux 5.13 for dunfell
  • Loading branch information
ndechesne authored Jul 29, 2021
2 parents 5844f1c + 787917a commit 327291e
Show file tree
Hide file tree
Showing 7 changed files with 28 additions and 59 deletions.
32 changes: 18 additions & 14 deletions recipes-kernel/linux/linux-linaro-qcom.inc
Original file line number Diff line number Diff line change
@@ -1,27 +1,33 @@
# Copyright (C) 2014 Linaro
# Copyright (C) 2014-2021 Linaro
# Copyright (C) 2012, 2013 O.S. Systems Software LTDA.
# Released under the MIT license (see COPYING.MIT for the terms)

DESCRIPTION = "Linux kernel for MSM platforms"
DESCRIPTION ??= "Linaro Qualcomm Landing team ${PV} Kernel"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"

inherit kernel

# Put a local version until we have a true SRCREV to point to
LOCALVERSION ?= "+linaro"
SCMVERSION ?= "y"

SRCBRANCH = "release/qcomlt-${PV}"

COMPATIBLE_MACHINE = "(qcom)"

LINUX_LINARO_QCOM_GIT ?= "git://git.linaro.org/landing-teams/working/qualcomm/kernel.git;protocol=https"
SRC_URI = "${LINUX_LINARO_QCOM_GIT};branch=${SRCBRANCH}"

S = "${WORKDIR}/git"

KERNEL_DEFCONFIG_aarch64 ?= "${S}/arch/arm64/configs/defconfig"
KERNEL_DEFCONFIG_apq8064 ?= "${S}/arch/arm/configs/qcom_defconfig"
KERNEL_DEFCONFIG_arm ?= "${S}/arch/arm/configs/qcom_defconfig"
KERNEL_CONFIG_FRAGMENTS += "${S}/kernel/configs/distro.config"

require recipes-kernel/linux/linux-qcom-bootimg.inc

kernel_conf_variable() {
CONF_SED_SCRIPT="$CONF_SED_SCRIPT /CONFIG_$1[ =]/d;"
sed -e "/CONFIG_$1[ =]/d;" -i ${B}/.config
if test "$2" = "n"
then
echo "# CONFIG_$1 is not set" >> ${B}/.config
Expand All @@ -31,18 +37,15 @@ kernel_conf_variable() {
}

do_configure_prepend() {
echo "" > ${B}/.config
CONF_SED_SCRIPT=""

kernel_conf_variable LOCALVERSION "\"${LOCALVERSION}\""
kernel_conf_variable LOCALVERSION_AUTO y

if [ -f '${WORKDIR}/defconfig' ]; then
sed -e "${CONF_SED_SCRIPT}" < '${WORKDIR}/defconfig' >> '${B}/.config'
cp '${WORKDIR}/defconfig' '${B}/.config'
else
sed -e "${CONF_SED_SCRIPT}" < '${KERNEL_DEFCONFIG}' >> '${B}/.config'
cp '${KERNEL_DEFCONFIG}' '${B}/.config'
fi

kernel_conf_variable LOCALVERSION "\"${LOCALVERSION}\""
kernel_conf_variable LOCALVERSION_AUTO y

if [ "${SCMVERSION}" = "y" ]; then
# Add GIT revision to the local version
head=`git --git-dir=${S}/.git rev-parse --verify --short HEAD 2> /dev/null`
Expand Down Expand Up @@ -76,7 +79,8 @@ do_configure_prepend() {
# Now that all the fragments are located merge them.
( cd ${WORKDIR} && ${S}/scripts/kconfig/merge_config.sh -m -r -O ${B} ${B}/.config ${KERNEL_CONFIG_FRAGMENTS} 1>&2 )
fi
}

yes '' | oe_runmake -C ${S} O=${B} oldconfig
do_configure_append() {
oe_runmake -C ${S} O=${B} savedefconfig && cp ${B}/defconfig ${WORKDIR}/defconfig.saved
}
10 changes: 2 additions & 8 deletions recipes-kernel/linux/linux-linaro-qcomlt-dev.bb
Original file line number Diff line number Diff line change
Expand Up @@ -5,13 +5,10 @@
# To enable it add the following line to conf/local.conf:
# PREFERRED_PROVIDER_virtual/kernel = "linux-linaro-qcomlt-dev"

DESCRIPTION = "Linaro Qualcomm Landing team Integration Kernel ${PV}"
LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"

require recipes-kernel/linux/linux-linaro-qcom.inc
require recipes-kernel/linux/linux-qcom-bootimg.inc

SRCBRANCH ?= "integration-linux-qcomlt"
DESCRIPTION = "Linaro Qualcomm Landing team Integration Kernel ${PV}"
SRCBRANCH = "integration-linux-qcomlt"

# Set default SRCREV. it is statically set to the korg v3.7 tag, and
# hence prevent network access during parsing. If linux-linaro-qcomlt-dev
Expand All @@ -21,6 +18,3 @@ SRCREV ?= '${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "linux-l

LINUX_VERSION = "5.11+"
PV = "${LINUX_VERSION}+git${SRCPV}"

# Wifi firmware has a recognizable arch :(
ERROR_QA_remove = "arch"
11 changes: 1 addition & 10 deletions recipes-kernel/linux/linux-linaro-qcomlt_5.10.bb
Original file line number Diff line number Diff line change
@@ -1,15 +1,6 @@
# Copyright (C) 2014-2020 Linaro
# Released under the MIT license (see COPYING.MIT for the terms)

DESCRIPTION = "Linaro Qualcomm Landing team 5.10 Kernel"
LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"

require recipes-kernel/linux/linux-linaro-qcom.inc
require recipes-kernel/linux/linux-qcom-bootimg.inc

LOCALVERSION ?= "-linaro-lt-qcom"

SRCBRANCH = "release/qcomlt-5.10"
SRCREV = "6afb1155f01df9871e14e4189d83d31000b308ee"

COMPATIBLE_MACHINE = "(qcom)"
SRCREV = "9ab492e76768cd1bd9f2da52004ed537c8b329f3"
6 changes: 0 additions & 6 deletions recipes-kernel/linux/linux-linaro-qcomlt_5.12.bb
Original file line number Diff line number Diff line change
@@ -1,13 +1,7 @@
# Copyright (C) 2014-2021 Linaro
# Released under the MIT license (see COPYING.MIT for the terms)

DESCRIPTION = "Linaro Qualcomm Landing team 5.12 Kernel"
LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"

require recipes-kernel/linux/linux-linaro-qcom.inc
require recipes-kernel/linux/linux-qcom-bootimg.inc

LOCALVERSION ?= "-linaro-lt-qcom"

SRCBRANCH = "release/rb5/qcomlt-5.12"
SRCREV = "deeb40c41728645cd6971b1d7bd08281238caba0"
Expand Down
6 changes: 6 additions & 0 deletions recipes-kernel/linux/linux-linaro-qcomlt_5.13.bb
Original file line number Diff line number Diff line change
@@ -0,0 +1,6 @@
# Copyright (C) 2014-2020 Linaro
# Released under the MIT license (see COPYING.MIT for the terms)

require recipes-kernel/linux/linux-linaro-qcom.inc

SRCREV = "108d71930dc8a8c10036ed0acd70e9ed3d7d1675"
13 changes: 1 addition & 12 deletions recipes-kernel/linux/linux-linaro-qcomlt_5.7.bb
Original file line number Diff line number Diff line change
@@ -1,14 +1,10 @@
# Copyright (C) 2014-2019 Linaro
# Released under the MIT license (see COPYING.MIT for the terms)

DESCRIPTION = "Linaro Qualcomm Landing team 5.7 Kernel"
LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
require recipes-kernel/linux/linux-linaro-qcom.inc

inherit python3native

require recipes-kernel/linux/linux-linaro-qcom.inc
require recipes-kernel/linux/linux-qcom-bootimg.inc

SRC_URI_append_qrb5165-rb5 = " \
file://qrb5165-rb5.dts;subdir=git/arch/arm64/boot/dts/qcom \
file://qrb5165-rb5-enable.patch \
Expand All @@ -19,11 +15,4 @@ SRC_URI_append_qrb5165-rb5 = " \
file://0001-arm64-dts-qcom-sm8250-Add-support-for-SDC2.patch \
"

LOCALVERSION ?= "-linaro-lt-qcom"
SRCBRANCH ?= "release/qcomlt-5.7"
SRCREV ?= "4af49ea41ecf17e5e6243f3ac81dfc2f84d8a3a1"

COMPATIBLE_MACHINE = "(qcom)"

# Wifi firmware has a recognizable arch :(
ERROR_QA_remove = "arch"
9 changes: 0 additions & 9 deletions recipes-kernel/linux/linux-linaro-qcomlt_5.9.bb
Original file line number Diff line number Diff line change
@@ -1,18 +1,9 @@
# Copyright (C) 2014-2019 Linaro
# Released under the MIT license (see COPYING.MIT for the terms)

DESCRIPTION = "Linaro Qualcomm Landing team 5.9 Kernel"
LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"

require recipes-kernel/linux/linux-linaro-qcom.inc
require recipes-kernel/linux/linux-qcom-bootimg.inc

LOCALVERSION ?= "-linaro-lt-qcom"

SRCBRANCH ?= "release/qcomlt-5.9"
SRCREV ?= "b5ff44498a19a685aa10a07ec67e3d12bc95a33a"

SRCBRANCH_sm8250 = "release/rb5/qcomlt-5.9"
SRCREV_sm8250 = "6d5a9a5da79684f69e4c66a7cf9108ab4e77025f"

COMPATIBLE_MACHINE = "(qcom)"

0 comments on commit 327291e

Please sign in to comment.