Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

"Fix" for dkms #18

Closed
wants to merge 2 commits into from
Closed
Show file tree
Hide file tree
Changes from all commits
Commits
File filter

Filter by extension

Filter by extension

Conversations
Failed to load comments.
Loading
Jump to
Jump to file
Failed to load files.
Loading
Diff view
Diff view
5 changes: 3 additions & 2 deletions linux-mister/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -8,7 +8,7 @@ pkgbase=linux-mister
_kernelname=${pkgbase#linux}
_desc="MiSTer"
pkgver=5.15
pkgrel=6
pkgrel=7
Copy link
Member

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

This is fine.

arch=('armv7h')
url="https://github.com/MiSTer-devel/Linux-Kernel_MiSTer"
license=('GPL2')
Expand All @@ -21,7 +21,7 @@ source=("https://github.com/MiSTer-devel/Linux-Kernel_MiSTer/archive/${_commit}.
'config')
sha256sums=('19137b739278157eebb1e55501177e0616833c2fa3720a2dad4411f52009b686'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'166e62fa69d6837da16064d18754de1f251a665ebb4d97dc05ab66a7d1328195')
'ce5e368cde88a98d2d3a8151c58b67998878c0d43898f72e78848fe574e6448c')

prepare() {
cd "${srcdir}/${_srcname}"
Expand Down Expand Up @@ -78,6 +78,7 @@ _package() {
cd "${srcdir}/${_srcname}"

KARCH=arm
ARCH=arm
Copy link
Member

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Are you sure this does anything? You only declared a local variable in this function, and you're not using it anywhere. None of the subprocesses (like make) can see it.

Copy link
Contributor Author

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

It is not, sorry. The only change should in pkgrel.


# get kernel version
_kernver="$(make kernelrelease)"
Expand Down
15 changes: 9 additions & 6 deletions linux-mister/config
Original file line number Diff line number Diff line change
@@ -1,19 +1,20 @@
#
# Automatically generated file; DO NOT EDIT.
# Linux/arm 5.15.1-6 Kernel Configuration
# Linux/arm 5.15.1-7 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (crosstool-NG 1.23.0.418-d590) 10.2.0"
CONFIG_CC_VERSION_TEXT="gcc (GCC) 11.2.0"
CONFIG_CC_IS_GCC=y
CONFIG_GCC_VERSION=100200
CONFIG_GCC_VERSION=110200
CONFIG_CLANG_VERSION=0
CONFIG_AS_IS_GNU=y
CONFIG_AS_VERSION=23500
CONFIG_AS_VERSION=23800
CONFIG_LD_IS_BFD=y
CONFIG_LD_VERSION=23500
CONFIG_LD_VERSION=23800
CONFIG_LLD_VERSION=0
CONFIG_CC_CAN_LINK=y
CONFIG_CC_CAN_LINK_STATIC=y
CONFIG_CC_HAS_ASM_GOTO=y
CONFIG_CC_HAS_ASM_GOTO_OUTPUT=y
CONFIG_CC_HAS_ASM_INLINE=y
CONFIG_CC_HAS_NO_PROFILE_FN_ATTR=y
CONFIG_IRQ_WORK=y
Expand Down Expand Up @@ -3719,6 +3720,8 @@ CONFIG_INIT_STACK_NONE=y
# CONFIG_GCC_PLUGIN_STRUCTLEAK_BYREF_ALL is not set
# CONFIG_INIT_ON_ALLOC_DEFAULT_ON is not set
# CONFIG_INIT_ON_FREE_DEFAULT_ON is not set
CONFIG_CC_HAS_ZERO_CALL_USED_REGS=y
Copy link
Member

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

I would prefer if this file didn't change. I think the oldconfig differences here might be an artifact to you changing the compiler and that's it.

Copy link
Contributor Author

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

But then I cannot do unattended builds. Suggestion?

# CONFIG_ZERO_CALL_USED_REGS is not set
# end of Memory initialization
# end of Kernel hardening options
# end of Security options
Expand Down Expand Up @@ -4028,7 +4031,6 @@ CONFIG_DEBUG_INFO_DWARF_TOOLCHAIN_DEFAULT=y
# CONFIG_DEBUG_INFO_DWARF4 is not set
# CONFIG_DEBUG_INFO_DWARF5 is not set
# CONFIG_DEBUG_INFO_BTF is not set
CONFIG_PAHOLE_HAS_SPLIT_BTF=y
# CONFIG_GDB_SCRIPTS is not set
CONFIG_FRAME_WARN=1024
# CONFIG_STRIP_ASM_SYMS is not set
Expand Down Expand Up @@ -4057,6 +4059,7 @@ CONFIG_DEBUG_FS_ALLOW_ALL=y
CONFIG_HAVE_ARCH_KGDB=y
# CONFIG_KGDB is not set
# CONFIG_UBSAN is not set
CONFIG_HAVE_KCSAN_COMPILER=y
# end of Generic Kernel Debugging Instruments

CONFIG_DEBUG_KERNEL=y
Expand Down