You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
Changed all applications in order to have preprocessing definitions on top of the files and added relevant comments
Applications LED control is no more done into the timer callback functions but instead on the main while loop.
Added TimerStop function calls to each timer event callback.
Corrected timings comments. Timing values are most of the time us based.
Changed types names for stdint.h names. Helps on code portability
Renamed rand and srand to rand1 and srand1. Helps on code portability
Added some missing variables casts. Helps on code portability
Removed NULL definition from board.h
Added const variable attribute when necessary to functions prototypes
Moved ID1, ID2 and ID3 definition from board.h to board.c, usb-cdc-board.c and usb-dfu-board.c
Removed the definition of RAND_SEED. It has been replaced by a function named BoardGetRandomSeed
Renamed BoardMeasureBatterieLevel to BoardGetBatteryLevel
Added SetMaxPayloadLength API function to SX1272 and SX1276 radio drivers
Changed the name of Radio API Status function to GetStatus
AES/CMAC Changed types names for stdint.h names. Helps on code portability (Issue #20)
Moved __ffs function from utilities.h to spi-board.c. This function is only used there.
Utilities.c removed fputc function redefinition.
Replaced the usage of __IO attribute by volatile.
LoRaWAN
Added support for the US915 band (Normal mode and hybrid mode. Hybrid mode is a temporary configuration up until servers support it automatically) (Issue #16)
Corrected and simplified the downlink sequence counter management.
Removed the usage of PACKED attribute for data structures.
Renamed LoRaMacEvent_t into LoRaMacCallbacks_t and added a function pointer for getting battery level status
Renamed LoRaMacSetDutyCycleOn into LoRaMacSetTestDutyCycleOn
Renamed LoRaMacSetMicTest into LoRaMacTestSetMic
Increased the PHY buffer size to 250
Removed IsChannelFree check on LoRaMacSetNextChannel function. LoRaWAN is an ALHOA protocol. (Pull request #8)
LoRaMacEventInfo.TxDatarate now returns LoRaWAN datarate (DR0 -> DR7) instead of (SF12 -> DF7)
Corrected channel mask management for EU868 band.
Corrected LoRaMacPrepareFrame behavior function when no applicative payload is present.
LoRaMac-board.h now implements the settings for the PHY layers specified by LoRaWAN 1.0 specification. ( EU433, CN780, EU868, US915 ) (Issue #19)
Added LORAMAC_MIN_RX1_DR_OFFSET and LORAMAC_MAX_RX1_DR_OFFSET definitions to LoRaMac-board.h. Can be different upon used PHY layer
Added the limitation of output power according to the number of enabled channels for US915 band.
Added the limitation of the applicative payload length according to the datarate. Does not yet take in account the MAC commands buffer. (Issue #15)