Skip to content

Commit

Permalink
mcore-demos: Upgrade to 6.6.52_2.2.0
Browse files Browse the repository at this point in the history
imx95: 2.16.001 -> 24.12.00

Signed-off-by: Zelan Zou <[email protected]>
  • Loading branch information
zelan-nxp committed Jan 15, 2025
1 parent 1829088 commit 540f161
Show file tree
Hide file tree
Showing 4 changed files with 15 additions and 27 deletions.
2 changes: 1 addition & 1 deletion recipes-fsl/mcore-demos/README
Original file line number Diff line number Diff line change
Expand Up @@ -5,7 +5,7 @@ The M4 demo app version of each SoCs are followed:

The M7 demo app version of each SoCs are followed:
* 2.16.000 -- i.MX 8MP , 8MNULite, 8MN
* 2.16.001 -- i.MX95
* 24.12.00 -- i.MX95

The M33 demo app version of each SoCs are followed:
* 2.16.000 -- i.MX 8ULP, i.MX 93
26 changes: 7 additions & 19 deletions recipes-fsl/mcore-demos/imx-m4-demos_1.0.1.bb
Original file line number Diff line number Diff line change
@@ -1,27 +1,15 @@
SUMMARY = "i.MX M4 core Demo images"
SECTION = "app"
LICENSE = "Proprietary"
LIC_FILES_CHKSUM:mx7d-nxp-bsp = "file://COPYING;md5=8cf95184c220e247b9917e7244124c5a"
# Copyright 2017-2021 NXP
# Released under the MIT license (see COPYING.MIT for the terms)

inherit deploy fsl-eula-unpack
require imx-mcore-demos.inc

M4_SOC ?= "INVALID"
M4_SOC:mx7d-nxp-bsp = "imx7d-sabresd"
LIC_FILES_CHKSUM:mx7d-nxp-bsp = "file://COPYING;md5=8cf95184c220e247b9917e7244124c5a"

SRC_URI = "${FSL_MIRROR}/${M4_SOC}-m4-freertos-${PV}.bin;fsl-eula=true"
S = "${WORKDIR}/${M4_SOC}-m4-freertos-${PV}"
SRC_URI = "${FSL_MIRROR}/${SOC}-m4-freertos-${PV}.bin;fsl-eula=true"
S = "${WORKDIR}/${SOC}-m4-freertos-${PV}.bin"

SRC_URI[sha256sum] = "cc00d3b936d49b2794a2a99e10129437e70caba3fd26b8379b8c50dd22f73254"

do_deploy () {
# Install the demo binaries
install -d ${DEPLOYDIR}
cp ${S}/*.bin ${DEPLOYDIR}/
ls ${DEPLOYDIR}/
}
do_install[noexec] = "1"

addtask deploy before do_build after do_compile

PACKAGE_ARCH = "${MACHINE_SOCARCH}"
COMPATIBLE_MACHINE = "(mx7d-nxp-bsp)"

Original file line number Diff line number Diff line change
Expand Up @@ -5,6 +5,6 @@ require imx-mcore-demos.inc

LIC_FILES_CHKSUM:mx95-nxp-bsp = "file://COPYING;md5=ca53281cc0caa7e320d4945a896fb837"

SRC_URI[imx95.sha256sum] = "0569f128e2068c509dcd4afe6689a62cdb5a4ac9f8eb1b522b2bfaac0e7d09fd"
SRC_URI[imx95.sha256sum] = "01603b53fd01181631b71f5139a4a3e215f7e03cc531638ef4fa805a678ede3d"

COMPATIBLE_MACHINE = "(mx95-nxp-bsp)"
12 changes: 6 additions & 6 deletions recipes-fsl/mcore-demos/imx-mcore-demos.inc
Original file line number Diff line number Diff line change
Expand Up @@ -9,6 +9,7 @@ inherit deploy fsl-eula-unpack

SOC ?= "INVALID"
SOC:mx7ulp-nxp-bsp = "imx7ulp"
SOC:mx7d-nxp-bsp = "imx7d-sabresd"
SOC:mx8dxl-nxp-bsp = "imx8dxl"
SOC:mx8mm-nxp-bsp = "imx8mm"
SOC:mx8mn-nxp-bsp = "imx8mn"
Expand All @@ -32,16 +33,14 @@ MCORE_TYPE:mx8ulp-nxp-bsp = "m33"
MCORE_TYPE:mx93-nxp-bsp = "m33"
MCORE_TYPE:mx95-nxp-bsp = "m7"

SRC_URI = "${FSL_MIRROR}${SOC}-${MCORE_TYPE}-demo-${PV}.bin;name=${SOC};fsl-eula=true"
SRC_URI = "${FSL_MIRROR}/${SOC}-${MCORE_TYPE}-demo-${PV}.bin;name=${SOC};fsl-eula=true"

S = "${WORKDIR}/${SOC}-${MCORE_TYPE}-demo-${PV}"

#SRC_URI="https://www.nxp.com/lgfiles/NMG/MAD/YOCTO//imx93-m33-demo-2.14.0.bin;fsl-eula=true;name=imx93"


SCR = "SCR-${SOC}-${MCORE_TYPE}-demo.txt"

do_install () {
# install elf format binary to /lib/firmware
install -d ${D}${nonarch_base_libdir}/firmware
install -m 0644 ${S}/*.elf ${D}${nonarch_base_libdir}/firmware
}
Expand All @@ -50,8 +49,9 @@ DEPLOY_FILE_EXT ?= "bin"
DEPLOY_FILE_EXT:mx7ulp-nxp-bsp = "img"

do_deploy () {
# Install the demo binaries
install -m 0644 ${S}/*.${DEPLOY_FILE_EXT} ${DEPLOYDIR}/
# Install the demo binaries
install -d ${DEPLOYDIR}/mcore-demos
install -m 0644 ${S}/*.${DEPLOY_FILE_EXT} ${DEPLOYDIR}/mcore-demos/
}

addtask deploy after do_install
Expand Down

0 comments on commit 540f161

Please sign in to comment.