Skip to content

Commit 85bf0d1

Browse files
committed
build,travis: do not modify .travis.yml
restarting a build doesn't update .travis.yml but does update .travis_do.sh ... Signed-off-by: Etienne Champetier <[email protected]>
1 parent cd682e9 commit 85bf0d1

File tree

2 files changed

+11
-6
lines changed

2 files changed

+11
-6
lines changed

Diff for: .travis.yml

-1
Original file line numberDiff line numberDiff line change
@@ -11,5 +11,4 @@ before_script:
1111
- ./.travis_do.sh download_sdk
1212

1313
script:
14-
- ./.travis_do.sh test_commits
1514
- ./.travis_do.sh test_packages

Diff for: .travis_do.sh

+11-5
Original file line numberDiff line numberDiff line change
@@ -55,9 +55,8 @@ download_sdk() {
5555
}
5656

5757
# test_package will run on the `script` step.
58-
# test_package call make download check for very new/modified package in it's
59-
# own clean sdk directory
60-
test_packages() {
58+
# test_package call make download check for very new/modified package
59+
test_packages2() {
6160
# search for new or modified packages. PKGS will hold a list of package like 'admin/muninlite admin/monit ...'
6261
PKGS=$(git diff --name-only "$TRAVIS_COMMIT_RANGE" | grep 'Makefile$' | grep -v '/files/' | awk -F'/Makefile' '{ print $1 }')
6362

@@ -101,7 +100,7 @@ EOF
101100
echo_blue "=== $pkg_name Finished package"
102101
done
103102

104-
exit $RET
103+
return $RET
105104
}
106105

107106
test_commits() {
@@ -139,7 +138,14 @@ test_commits() {
139138
fi
140139
done
141140

142-
exit $RET
141+
return $RET
142+
}
143+
144+
test_packages() {
145+
GRET=0
146+
test_commits || GRET=1
147+
test_packages2 || GRET=1
148+
return $GRET
143149
}
144150

145151
echo_blue "=== Travis ENV"

0 commit comments

Comments
 (0)