File tree 2 files changed +11
-6
lines changed
2 files changed +11
-6
lines changed Original file line number Diff line number Diff line change @@ -11,5 +11,4 @@ before_script:
11
11
- ./.travis_do.sh download_sdk
12
12
13
13
script :
14
- - ./.travis_do.sh test_commits
15
14
- ./.travis_do.sh test_packages
Original file line number Diff line number Diff line change @@ -55,9 +55,8 @@ download_sdk() {
55
55
}
56
56
57
57
# test_package will run on the `script` step.
58
- # test_package call make download check for very new/modified package in it's
59
- # own clean sdk directory
60
- test_packages () {
58
+ # test_package call make download check for very new/modified package
59
+ test_packages2 () {
61
60
# search for new or modified packages. PKGS will hold a list of package like 'admin/muninlite admin/monit ...'
62
61
PKGS=$( git diff --name-only " $TRAVIS_COMMIT_RANGE " | grep ' Makefile$' | grep -v ' /files/' | awk -F' /Makefile' ' { print $1 }' )
63
62
101
100
echo_blue " === $pkg_name Finished package"
102
101
done
103
102
104
- exit $RET
103
+ return $RET
105
104
}
106
105
107
106
test_commits () {
@@ -139,7 +138,14 @@ test_commits() {
139
138
fi
140
139
done
141
140
142
- exit $RET
141
+ return $RET
142
+ }
143
+
144
+ test_packages () {
145
+ GRET=0
146
+ test_commits || GRET=1
147
+ test_packages2 || GRET=1
148
+ return $GRET
143
149
}
144
150
145
151
echo_blue " === Travis ENV"
You can’t perform that action at this time.
0 commit comments