Skip to content

Commit

Permalink
Use symbolic link
Browse files Browse the repository at this point in the history
This appears to work, although I'm not yet sure whether it's a good
approach.
  • Loading branch information
chiphogg committed Jul 14, 2024
1 parent 0fe7747 commit cf9b8a7
Show file tree
Hide file tree
Showing 5 changed files with 6 additions and 3 deletions.
2 changes: 1 addition & 1 deletion CMakeLists.txt
Original file line number Diff line number Diff line change
Expand Up @@ -55,7 +55,7 @@ set(gtest_force_shared_crt ON CACHE BOOL "" FORCE)
FetchContent_MakeAvailable(googletest)
include(GoogleTest)

add_subdirectory(au)
add_subdirectory(include)

# Configure how Au will be installed.
#
Expand Down
2 changes: 1 addition & 1 deletion au/CMakeLists.txt
Original file line number Diff line number Diff line change
Expand Up @@ -12,7 +12,7 @@
# See the License for the specific language governing permissions and
# limitations under the License.

include(../cmake/HeaderOnlyLibrary.cmake)
include("${PROJECT_SOURCE_DIR}/cmake/HeaderOnlyLibrary.cmake")

#
# Publicly exported targets
Expand Down
3 changes: 2 additions & 1 deletion cmake/HeaderOnlyLibrary.cmake
Original file line number Diff line number Diff line change
Expand Up @@ -45,7 +45,7 @@ function(header_only_library)
${ARG_NAME}
INTERFACE
FILE_SET HEADERS
BASE_DIRS ${CMAKE_SOURCE_DIR}
BASE_DIRS "${PROJECT_SOURCE_DIR}/include"
FILES ${ARG_HEADERS}
)
if (DEFINED ARG_DEPS)
Expand All @@ -71,6 +71,7 @@ function(header_only_library)
TARGETS ${ARG_NAME}
EXPORT ${AU_EXPORT_SET_NAME}
FILE_SET HEADERS
INCLUDES DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}"
)

# Add the test, if requested.
Expand Down
1 change: 1 addition & 0 deletions include/CMakeLists.txt
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
add_subdirectory(au)
1 change: 1 addition & 0 deletions include/au

0 comments on commit cf9b8a7

Please sign in to comment.