-
Notifications
You must be signed in to change notification settings - Fork 12
/
Copy pathRat in a Maze Problem.cpp
96 lines (89 loc) · 2.58 KB
/
Rat in a Maze Problem.cpp
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
/*
You are given a N*N maze with a rat placed at maze[0][0]. Find and print all paths that rat can follow to reach its destination i.e. maze[N-1][N-1]. Rat can move in any direction ( left, right, up and down).
Value of every cell in the maze can either be 0 or 1. Cells with value 0 are blocked means rat cannot enter into those cells and those with value 1 are open.
Input Format
The first line of input contains an integer 'N' representing
the dimension of the maze.
The next N lines of input contain N space-separated
integers representing the type of the cell.
Output Format :
For each test case, print the path from start position to destination position and only cells that are part of the solution path should be 1, rest all cells should be 0.
Output for every test case will be printed in a separate line.
Note:
You do not need to print anything, it has already been taken care of. Just implement the given function.
Constraints:
0 < N < 11 0 <= Maze[i][j] <=1
Time Limit: 1sec
Sample Input 1 :
3
1 0 1
1 0 1
1 1 1
Sample Output 1 :
1 0 0 1 0 0 1 1 1
Sample Output 1 Explanation :
Only 1 path is possible
1 0 0
1 0 0
1 1 1
Which is printed from left to right and then top to bottom in one line.
Sample Input 2 :
3
1 0 1
1 1 1
1 1 1
Sample Output 2 :
1 0 0 1 1 1 1 1 1
1 0 0 1 0 0 1 1 1
1 0 0 1 1 0 0 1 1
1 0 0 1 1 1 0 0 1
Sample Output 2 Explanation :
4 paths are possible which are printed in the required format.
*/
#include<iostream>
using namespace std;
void printsolution(int** solution, int n)
{
for(int i = 0; i < n; i++)
for(int j = 0; j < n; j++)
cout << solution[i][j] << " ";
cout << endl;
}
void mazeHelp(int maze[][20], int n, int** solution, int x, int y)
{
if(x == n-1 && y == n-1)
{
solution[x][y] = 1;
printsolution(solution,n);
return;
}
if(x >= n || y >= n || x < 0 || y < 0 || maze[x][y] == 0 || solution[x][y] == 1)
return;
solution[x][y] = 1;
mazeHelp(maze,n,solution,x-1,y);
mazeHelp(maze,n,solution,x+1,y);
mazeHelp(maze,n,solution,x,y+1);
mazeHelp(maze,n,solution,x,y-1);
solution[x][y] = 0;
}
void ratInAMaze(int maze[][20], int n){
/* Don't write main().
* Don't read input, it is passed as function argument.
* Print output as specified in the question
*/
int** solution = new int*[n];
for(int i = 0; i < n; i++)
solution[i] = new int[n];
mazeHelp(maze,n,solution,0,0);
}
int main(){
int n;
cin >> n ;
int maze[20][20];
for(int i = 0; i < n ;i++){
for(int j = 0; j < n; j++){
cin >> maze[i][j];
}
}
ratInAMaze(maze, n);
}