diff --git a/README.md b/README.md
index 90efcf3..d40dacf 100644
--- a/README.md
+++ b/README.md
@@ -14,6 +14,8 @@ The directory containing `PKGBUILD` and `.SRCINFO` files can be specified in `pk
 
 ## Inputs
 
+> ALL of these are optional
+
 ### `target`
 
 **Default: pkgbuild** Validation target. Can be one of: `pkgbuild`, `srcinfo`, `run`.
@@ -22,7 +24,12 @@ The directory containing `PKGBUILD` and `.SRCINFO` files can be specified in `pk
 
 **Default: '.'** Path to DIRECTORY where the PKGBUILD file is.
 
-The `pkgname` is automatically extracted from the PKGBUILD
+### `pkgname`
+
+Totally optional, will work for most cases even if you leave it
+**If needed, you can explicitly state it**
+
+**Default: ** The `pkgname` is automatically extracted from the PKGBUILD
 
 > TODO: Add this as input to explicitly tell the pkgname
 
@@ -46,7 +53,7 @@ jobs:
     runs-on: ubuntu-latest
     steps:
     - uses: actions/checkout@v2
-    - uses: adig-pkgs/arch-pkgbuild-builder@v2.0
+    - uses: adig-pkgs/arch-pkgbuild-builder@v2.1
 ```
 
 > This currently doesn't work for split-packages (ie. if your PKGBUILD contains `pkgname=('a-aef' 'b-aef' 'c-aef') # my package`)
diff --git a/action.yml b/action.yml
index d2e8dbc..3ed356b 100644
--- a/action.yml
+++ b/action.yml
@@ -11,6 +11,11 @@ inputs:
       Path to Directory containing the PKGBUILD file
     required: false
     default: '.'
+  pkgname:
+    description: >-
+      Explicitly state the pkgname, if you are facing any difficulties
+    required: false
+    default: ''
   target:
     description: >-
       Validation target.
@@ -34,3 +39,4 @@ runs:
     - ${{ inputs.target }}
     - ${{ inputs.command }}
     - ${{ inputs.debug }}
+    - ${{ inputs.pkgname }}
diff --git a/entrypoint.sh b/entrypoint.sh
index 5ec74c4..cc52047 100755
--- a/entrypoint.sh
+++ b/entrypoint.sh
@@ -14,7 +14,10 @@ pkgbuild_dir=$1
 pkgbuild_dir=$(realpath ${pkgbuild_dir})
 
 # Remove comments
-pkgname=$(awk '/pkgname=/ {print}' "${pkgbuild_dir}/PKGBUILD" | head -n1 | cut -d'#' -f1 | cut -d'=' -f2 | sed -e 's/^ *//g' | sed -e 's/ *$//g')
+pkgname=$5
+if [ "$pkgname" == "" ]; then
+	pkgname=$(awk '/pkgname=/ {print}' "${pkgbuild_dir}/PKGBUILD" | head -n1 | cut -d'#' -f1 | cut -d'=' -f2 | sed -e 's/^ *//g' | sed -e 's/ *$//g')
+fi
 command=$3
 
 # assumes that package files are in a subdirectory