Skip to content

Commit e76ac9f

Browse files
committed
rustc: Update to 1.44.0
Version 1.44.0 (2020-06-04) ========================== Language -------- - [You can now use `async/.await` with `#[no_std]` enabled.][69033] - [Added the `unused_braces` lint.][70081] **Syntax-only changes** - [Expansion-driven outline module parsing][69838] ```rust #[cfg(FALSE)] mod foo { mod bar { mod baz; // `foo/bar/baz.rs` doesn't exist, but no error! } } ``` These are still rejected semantically, so you will likely receive an error but these changes can be seen and parsed by macros and conditional compilation. Compiler -------- - [Rustc now respects the `-C codegen-units` flag in incremental mode.][70156] Additionally when in incremental mode rustc defaults to 256 codegen units. - [Refactored `catch_unwind` to have zero-cost, unless unwinding is enabled and a panic is thrown.][67502] - [Added tier 3\* support for the `aarch64-unknown-none` and `aarch64-unknown-none-softfloat` targets.][68334] - [Added tier 3 support for `arm64-apple-tvos` and `x86_64-apple-tvos` targets.][68191] Libraries --------- - [Special cased `vec![]` to map directly to `Vec::new()`.][70632] This allows `vec![]` to be able to be used in `const` contexts. - [`convert::Infallible` now implements `Hash`.][70281] - [`OsString` now implements `DerefMut` and `IndexMut` returning a `&mut OsStr`.][70048] - [Unicode 13 is now supported.][69929] - [`String` now implements `From<&mut str>`.][69661] - [`IoSlice` now implements `Copy`.][69403] - [`Vec<T>` now implements `From<[T; N]>`.][68692] Where `N` is at most 32. - [`proc_macro::LexError` now implements `fmt::Display` and `Error`.][68899] - [`from_le_bytes`, `to_le_bytes`, `from_be_bytes`, `to_be_bytes`, `from_ne_bytes`, and `to_ne_bytes` methods are now `const` for all integer types.][69373] Stabilized APIs --------------- - [`PathBuf::with_capacity`] - [`PathBuf::capacity`] - [`PathBuf::clear`] - [`PathBuf::reserve`] - [`PathBuf::reserve_exact`] - [`PathBuf::shrink_to_fit`] - [`f32::to_int_unchecked`] - [`f64::to_int_unchecked`] - [`Layout::align_to`] - [`Layout::pad_to_align`] - [`Layout::array`] - [`Layout::extend`] Cargo ----- - [Added the `cargo tree` command which will print a tree graph of your dependencies.][cargo/8062] E.g. ``` mdbook v0.3.2 (/Users/src/rust/mdbook) ├── ammonia v3.0.0 │ ├── html5ever v0.24.0 │ │ ├── log v0.4.8 │ │ │ └── cfg-if v0.1.9 │ │ ├── mac v0.1.1 │ │ └── markup5ever v0.9.0 │ │ ├── log v0.4.8 (*) │ │ ├── phf v0.7.24 │ │ │ └── phf_shared v0.7.24 │ │ │ ├── siphasher v0.2.3 │ │ │ └── unicase v1.4.2 │ │ │ [build-dependencies] │ │ │ └── version_check v0.1.5 ... ``` You can also display dependencies on multiple versions of the same crate with `cargo tree -d` (short for `cargo tree --duplicates`). Misc ---- - [Rustdoc now allows you to specify `--crate-version` to have rustdoc include the version in the sidebar.][69494] Compatibility Notes ------------------- - [Rustc now correctly generates static libraries on Windows GNU targets with the `.a` extension, rather than the previous `.lib`.][70937] - [Removed the `-C no_integrated_as` flag from rustc.][70345] - [The `file_name` property in JSON output of macro errors now points the actual source file rather than the previous format of `<NAME macros>`.][70969] **Note:** this may not point to a file that actually exists on the user's system. - [The minimum required external LLVM version has been bumped to LLVM 8.][71147] - [`mem::{zeroed, uninitialised}` will now panic when used with types that do not allow zero initialization such as `NonZeroU8`.][66059] This was previously a warning. - [In 1.45.0 (the next release) converting a `f64` to `u32` using the `as` operator has been defined as a saturating operation.][71269] This was previously undefined behaviour, but you can use the `{f64, f32}::to_int_unchecked` methods to continue using the current behaviour, which may be desirable in rare performance sensitive situations. Internal Only ------------- These changes provide no direct user facing benefits, but represent significant improvements to the internals and overall performance of rustc and related tools. - [dep_graph Avoid allocating a set on when the number reads are small.][69778] - [Replace big JS dict with JSON parsing.][71250] [69373]: rust-lang/rust#69373 [66059]: rust-lang/rust#66059 [68191]: rust-lang/rust#68191 [68899]: rust-lang/rust#68899 [71147]: rust-lang/rust#71147 [71250]: rust-lang/rust#71250 [70937]: rust-lang/rust#70937 [70969]: rust-lang/rust#70969 [70632]: rust-lang/rust#70632 [70281]: rust-lang/rust#70281 [70345]: rust-lang/rust#70345 [70048]: rust-lang/rust#70048 [70081]: rust-lang/rust#70081 [70156]: rust-lang/rust#70156 [71269]: rust-lang/rust#71269 [69838]: rust-lang/rust#69838 [69929]: rust-lang/rust#69929 [69661]: rust-lang/rust#69661 [69778]: rust-lang/rust#69778 [69494]: rust-lang/rust#69494 [69403]: rust-lang/rust#69403 [69033]: rust-lang/rust#69033 [68692]: rust-lang/rust#68692 [68334]: rust-lang/rust#68334 [67502]: rust-lang/rust#67502 [cargo/8062]: rust-lang/cargo#8062 [`PathBuf::with_capacity`]: https://doc.rust-lang.org/std/path/struct.PathBuf.html#method.with_capacity [`PathBuf::capacity`]: https://doc.rust-lang.org/std/path/struct.PathBuf.html#method.capacity [`PathBuf::clear`]: https://doc.rust-lang.org/std/path/struct.PathBuf.html#method.clear [`PathBuf::reserve`]: https://doc.rust-lang.org/std/path/struct.PathBuf.html#method.reserve [`PathBuf::reserve_exact`]: https://doc.rust-lang.org/std/path/struct.PathBuf.html#method.reserve_exact [`PathBuf::shrink_to_fit`]: https://doc.rust-lang.org/std/path/struct.PathBuf.html#method.shrink_to_fit [`f32::to_int_unchecked`]: https://doc.rust-lang.org/std/primitive.f32.html#method.to_int_unchecked [`f64::to_int_unchecked`]: https://doc.rust-lang.org/std/primitive.f64.html#method.to_int_unchecked [`Layout::align_to`]: https://doc.rust-lang.org/std/alloc/struct.Layout.html#method.align_to [`Layout::pad_to_align`]: https://doc.rust-lang.org/std/alloc/struct.Layout.html#method.pad_to_align [`Layout::array`]: https://doc.rust-lang.org/std/alloc/struct.Layout.html#method.array [`Layout::extend`]: https://doc.rust-lang.org/std/alloc/struct.Layout.html#method.extend
1 parent 14705f2 commit e76ac9f

File tree

2 files changed

+62
-59
lines changed

2 files changed

+62
-59
lines changed

lang/rust-bin/Makefile

+29-22
Original file line numberDiff line numberDiff line change
@@ -1,9 +1,8 @@
1-
# $NetBSD: Makefile,v 1.7 2020/06/03 10:45:04 nia Exp $
1+
# $NetBSD: Makefile,v 1.8 2020/06/09 15:58:05 nia Exp $
22

3-
DISTNAME= rust-1.42.0
3+
DISTNAME= rust-1.44.0
44
CATEGORIES= lang
55
MASTER_SITES= https://static.rust-lang.org/dist/
6-
PKGREVISION= 1
76

87
MAINTAINER= [email protected]
98
HOMEPAGE= https://rust-lang.org/
@@ -98,21 +97,25 @@ do-install:
9897
post-install: fix-darwin-install-name
9998
fix-darwin-install-name:
10099
. for bin in cargo-miri clippy-driver miri rls rustc rustdoc
101-
otool -XL ${DESTDIR}${PREFIX}/bin/${bin} \
102-
| ${GREP} '@rpath' | while read rpath rest; do \
103-
install_name_tool -change $$rpath \
104-
`${ECHO} $$rpath | ${SED} -e 's,@rpath,${PREFIX}/lib,g'` \
105-
${DESTDIR}${PREFIX}/bin/${bin}; \
106-
done
100+
if [ -f ${DESTDIR}${PREFIX}/bin/${bin} ]; then \
101+
otool -XL ${DESTDIR}${PREFIX}/bin/${bin} \
102+
| ${GREP} '@rpath' | while read rpath rest; do \
103+
install_name_tool -change $$rpath \
104+
`${ECHO} $$rpath | ${SED} -e 's,@rpath,${PREFIX}/lib,g'` \
105+
${DESTDIR}${PREFIX}/bin/${bin}; \
106+
done \
107+
; fi
107108
. endfor
108109
. for bin in lldb lldb-mi llvm-nm llvm-objcopy llvm-objdump \
109110
llvm-profdata llvm-readobj llvm-size llvm-strip
110-
otool -XL ${DESTDIR}${PREFIX}/lib/rustlib/${RUST_ARCH}/bin/${bin} \
111-
| ${GREP} '@rpath' | while read rpath rest; do \
112-
install_name_tool -change $$rpath \
113-
`${ECHO} $$rpath | ${SED} -e 's,@rpath,${PREFIX}/lib/rustlib/${RUST_ARCH}/lib,g'` \
114-
${DESTDIR}${PREFIX}/lib/rustlib/${RUST_ARCH}/bin/${bin}; \
115-
done
111+
if [ -f ${DESTDIR}${PREFIX}/bin/${bin} ]; then \
112+
otool -XL ${DESTDIR}${PREFIX}/lib/rustlib/${RUST_ARCH}/bin/${bin} \
113+
| ${GREP} '@rpath' | while read rpath rest; do \
114+
install_name_tool -change $$rpath \
115+
`${ECHO} $$rpath | ${SED} -e 's,@rpath,${PREFIX}/lib/rustlib/${RUST_ARCH}/lib,g'` \
116+
${DESTDIR}${PREFIX}/lib/rustlib/${RUST_ARCH}/bin/${bin}; \
117+
done \
118+
; fi
116119
. endfor
117120
. for lib in lib lib/rustlib/${RUST_ARCH}/lib lib/rustlib/${RUST_ARCH}/codegen-backends
118121
for f in ${DESTDIR}${PREFIX}/${lib}/lib*.dylib; do \
@@ -130,27 +133,31 @@ fix-darwin-install-name:
130133
.else
131134
TOOL_DEPENDS+= patchelf-[0-9]*:../../devel/patchelf
132135

133-
# ld.elf_so in NetBSD 8.x only obeys RPATH, not RUNPATH, so force RPATH there.
134-
FORCE_RPATH=
135136
# The llvm utilities need a specific libstdc++ version from compat80
136137
. if ${OPSYS} == "NetBSD" && empty(OS_VERSION:M[0-8].*)
137138
RUST_LLVM_RPATH= ${PREFIX}/emul/netbsd/usr/lib:${PREFIX}/lib
139+
FORCE_RPATH=
138140
. else
141+
# ld.elf_so in NetBSD 8.x only obeys RPATH, not RUNPATH, so force RPATH there.
139142
RUST_LLVM_RPATH= ${PREFIX}/lib
140-
FORCE_RPATH= --force-rpath
143+
FORCE_RPATH= --force-rpath
141144
. endif
142145

143146
.PHONY: fix-relative-rpath
144147
post-install: fix-relative-rpath
145148
fix-relative-rpath:
146149
. for bin in cargo-miri clippy-driver miri rls rustc rustdoc
147-
${PREFIX}/bin/patchelf ${FORCE_RPATH} --set-rpath \
148-
${PREFIX}/lib ${DESTDIR}${PREFIX}/bin/${bin}
150+
if [ -f ${DESTDIR}${PREFIX}/bin/${bin} ]; then \
151+
${PREFIX}/bin/patchelf ${FORCE_RPATH} --set-rpath \
152+
${PREFIX}/lib ${DESTDIR}${PREFIX}/bin/${bin} \
153+
; fi
149154
. endfor
150155
. for bin in llvm-ar llvm-nm llvm-objcopy llvm-objdump llvm-profdata \
151156
llvm-readobj llvm-size llvm-strip
152-
${PREFIX}/bin/patchelf ${FORCE_RPATH} --set-rpath ${RUST_LLVM_RPATH} \
153-
${DESTDIR}${PREFIX}/lib/rustlib/${RUST_ARCH}/bin/${bin}
157+
if [ -f ${DESTDIR}${PREFIX}/bin/${bin} ]; then \
158+
${PREFIX}/bin/patchelf ${FORCE_RPATH} --set-rpath ${RUST_LLVM_RPATH} \
159+
${DESTDIR}${PREFIX}/lib/rustlib/${RUST_ARCH}/bin/${bin} \
160+
; fi
154161
. endfor
155162
. for lib in lib lib/rustlib/${RUST_ARCH}/lib \
156163
lib/rustlib/${RUST_ARCH}/codegen-backends

lang/rust-bin/distinfo

+33-37
Original file line numberDiff line numberDiff line change
@@ -1,39 +1,35 @@
1-
$NetBSD: distinfo,v 1.1 2020/05/18 16:17:21 nia Exp $
1+
$NetBSD: distinfo,v 1.2 2020/06/09 15:58:05 nia Exp $
22

3-
SHA1 (rust-1.42.0-aarch64-unknown-linux-gnu.tar.gz) = f5b32a30b6b744834be4ceed1c4eac5873dc9a4f
4-
RMD160 (rust-1.42.0-aarch64-unknown-linux-gnu.tar.gz) = 5c313e75fe27707240772e316cf8b2b61eea5165
5-
SHA512 (rust-1.42.0-aarch64-unknown-linux-gnu.tar.gz) = ac4c9c21103b12e122f3f277424e74ee2572daf62da3476ed6710910fa4ecf843cb6464b05338ae50aa35e9844ad04a8c09746af8f03602c643da3673dc60d06
6-
Size (rust-1.42.0-aarch64-unknown-linux-gnu.tar.gz) = 153531604 bytes
7-
SHA1 (rust-1.42.0-i686-unknown-freebsd.tar.gz) = 47c98dcff8988d8466ede45ffe4299cd293fb2b3
8-
RMD160 (rust-1.42.0-i686-unknown-freebsd.tar.gz) = 175cfd391535b332d658a2bdfb81895f7bfac8e5
9-
SHA512 (rust-1.42.0-i686-unknown-freebsd.tar.gz) = 096dee142161d669f88498b68f00e881c56fbf8ec8295e1924b70ab69f9db28e6f0faf763b9b5532333aca4ef1fd0d84c1ef0e4914c4b781fc80be299fcc9fda
10-
Size (rust-1.42.0-i686-unknown-freebsd.tar.gz) = 120349647 bytes
11-
SHA1 (rust-1.42.0-i686-unknown-linux-gnu.tar.gz) = e477282ac75019e0012ae062f58459affbdccae4
12-
RMD160 (rust-1.42.0-i686-unknown-linux-gnu.tar.gz) = 655fde440160d3a2db730148d5453b2d46f12d36
13-
SHA512 (rust-1.42.0-i686-unknown-linux-gnu.tar.gz) = 55ba536b2c75a48320899a79a4487db40f5a0ab54543c1eb4b19cf7600e2d6b4343ce1bcb3b77094f8885441bd1056c28afe7dd05ea751eced2071b8f07804ca
14-
Size (rust-1.42.0-i686-unknown-linux-gnu.tar.gz) = 201205399 bytes
15-
SHA1 (rust-1.42.0-powerpc64le-unknown-linux-gnu.tar.gz) = 479f31aa1dac6a274b9f77b927a2695e930d7edb
16-
RMD160 (rust-1.42.0-powerpc64le-unknown-linux-gnu.tar.gz) = 152414c88625b8a2dbd622dde03e3a7695aa6612
17-
SHA512 (rust-1.42.0-powerpc64le-unknown-linux-gnu.tar.gz) = b9028b8aaec11c48a3d4af6a2a726ba64fcdf0e953299293a139a809db598bb9ef564febeb14b3cdb20b64bf73c14be373b6d5aacc52ae140f812ce62b4cb64f
18-
Size (rust-1.42.0-powerpc64le-unknown-linux-gnu.tar.gz) = 171741051 bytes
19-
SHA1 (rust-1.42.0-x86_64-apple-darwin.tar.gz) = 232c1d8d14cebef81cc6e8507ed9b5a337041237
20-
RMD160 (rust-1.42.0-x86_64-apple-darwin.tar.gz) = 19e4313c4cd862acb521e73b5269a25683091042
21-
SHA512 (rust-1.42.0-x86_64-apple-darwin.tar.gz) = 373940c7a2d2d921ca3d21c7a649c3014b1de8e04822f56c8de313ba6f610a70a559f106f7aa049bf5eaf333dde46089b2cf8e71961801788cd8eb515342cb84
22-
Size (rust-1.42.0-x86_64-apple-darwin.tar.gz) = 170080422 bytes
23-
SHA1 (rust-1.42.0-x86_64-unknown-freebsd.tar.gz) = 97ce4299110d7a1c2b326980435d4b7de8cded2b
24-
RMD160 (rust-1.42.0-x86_64-unknown-freebsd.tar.gz) = 340f704051498f718a57b70e90a06cd259bfffc0
25-
SHA512 (rust-1.42.0-x86_64-unknown-freebsd.tar.gz) = f9dda7103adc60c8b7c096474be7615605fa9ddf15ae035702ee8d6628b359da45f448b872bfe64c4aa2a576ca61f149f8e526b5cb608fc41120263f1b4e138c
26-
Size (rust-1.42.0-x86_64-unknown-freebsd.tar.gz) = 120581969 bytes
27-
SHA1 (rust-1.42.0-x86_64-unknown-linux-gnu.tar.gz) = 9f8c44701393d8c536d35d1aed5b6c72d75c7865
28-
RMD160 (rust-1.42.0-x86_64-unknown-linux-gnu.tar.gz) = 099d892ec9013f3492c4c3056fe53ddec6a28638
29-
SHA512 (rust-1.42.0-x86_64-unknown-linux-gnu.tar.gz) = 924e6a814a04ecfd566427779429eb0b27beabe854569f2df6d3e768b8b88808e41ccb7dc26484b9dde3bccfe8dbbc2018b414008bd3bdc9e5f6dd51963757af
30-
Size (rust-1.42.0-x86_64-unknown-linux-gnu.tar.gz) = 185229723 bytes
31-
SHA1 (rust-1.42.0-x86_64-unknown-linux-musl.tar.gz) = ca2c0ab49fd4d3b6891efa33292643293dccaa3c
32-
RMD160 (rust-1.42.0-x86_64-unknown-linux-musl.tar.gz) = 7e1ff0b7562f4bd3a994cd22173d906389db4d10
33-
SHA512 (rust-1.42.0-x86_64-unknown-linux-musl.tar.gz) = 30ecf6915e22c49ec67e5c613c07c445995a81eacd4399424ecbc28bcb010cd078ee85fb46aaa29c6707e94d1b8512db4a6cbeb9124fae9df56fc47a43d6710e
34-
Size (rust-1.42.0-x86_64-unknown-linux-musl.tar.gz) = 144668656 bytes
35-
SHA1 (rust-1.42.0-x86_64-unknown-netbsd.tar.gz) = da70b4b20d20baa675b3400ab18751cfcd5337a9
36-
RMD160 (rust-1.42.0-x86_64-unknown-netbsd.tar.gz) = 5856fbf266a33e16d1446d06a1729bcbd9027e35
37-
SHA512 (rust-1.42.0-x86_64-unknown-netbsd.tar.gz) = 849054ed8db2181e291652ecd3a927dbc42884d5c6796a0a4d72387b5e48f371d82426c418f6e5e09dfb4dc0fc185cbe5b9c39fe3d7e133ee8739b9f5327f325
38-
Size (rust-1.42.0-x86_64-unknown-netbsd.tar.gz) = 125750204 bytes
3+
SHA1 (rust-1.44.0-aarch64-unknown-linux-gnu.tar.gz) = 24970dd3121201dd3ce366ff4d49517c4bcf6dad
4+
RMD160 (rust-1.44.0-aarch64-unknown-linux-gnu.tar.gz) = 9d91cf483c224b19567e4e89441720dee65aa6a7
5+
SHA512 (rust-1.44.0-aarch64-unknown-linux-gnu.tar.gz) = 574dfd875a1506f4a4b4f896684d59ab7ff5325244939b242dcbe3aed0449e5f507966e5d879da7eede081f4d9c230a708bf502ff525d3c5a318bd34eed519a4
6+
Size (rust-1.44.0-aarch64-unknown-linux-gnu.tar.gz) = 156675554 bytes
7+
SHA1 (rust-1.44.0-i686-unknown-freebsd.tar.gz) = bbd0ea17117df54a6eececbd9ba8d0da2fdfd9e6
8+
RMD160 (rust-1.44.0-i686-unknown-freebsd.tar.gz) = e6ef30200074cbd9a531ad68156648fb5e9eccc4
9+
SHA512 (rust-1.44.0-i686-unknown-freebsd.tar.gz) = 74ff9075b28ce5b9eca77c0542e8b9446cc88a5db6e77886051b22ac3117c2e537fd4be1f8371e0d057f2e42456c04c51134aff81ab33efcc48516c4970da719
10+
Size (rust-1.44.0-i686-unknown-freebsd.tar.gz) = 123140342 bytes
11+
SHA1 (rust-1.44.0-i686-unknown-linux-gnu.tar.gz) = 67c4ad3ce015a69e28c4676c2628de3f15e90afa
12+
RMD160 (rust-1.44.0-i686-unknown-linux-gnu.tar.gz) = b79d29672882a477f653a24a5ff9c31517adf1b5
13+
SHA512 (rust-1.44.0-i686-unknown-linux-gnu.tar.gz) = b07d61f6b4c124e94d011c8eb3742309c864fedbf69df37233a7a69918487c34ce5d48eaf4d812c9f041d42bbcde0149be6310bf46bd75eed25ce52b62ecc105
14+
Size (rust-1.44.0-i686-unknown-linux-gnu.tar.gz) = 204511062 bytes
15+
SHA1 (rust-1.44.0-x86_64-apple-darwin.tar.gz) = d3cf8e0088ed4ef81a6c67d75c68a53a9897e410
16+
RMD160 (rust-1.44.0-x86_64-apple-darwin.tar.gz) = 057cd552cabafc6addfaf827f20ac369d829009c
17+
SHA512 (rust-1.44.0-x86_64-apple-darwin.tar.gz) = 21f7c528ef38a8dc3275749b11923439313237d01cb83c725a93e5c5746f0fc52356786bc4451cf1915594c0e151a3458b43ae80d2c82ad674255aae28c89022
18+
Size (rust-1.44.0-x86_64-apple-darwin.tar.gz) = 173815253 bytes
19+
SHA1 (rust-1.44.0-x86_64-unknown-freebsd.tar.gz) = f3a2b6ec86c7e30b13d9f8a8d148657aa3137730
20+
RMD160 (rust-1.44.0-x86_64-unknown-freebsd.tar.gz) = 508415f47221bc6642bb5b8d9267804cd6106725
21+
SHA512 (rust-1.44.0-x86_64-unknown-freebsd.tar.gz) = d76db9273f1702419b5d3a6a0c8faf575d716292ee85db851441648fa8f46f382b2555953dbd25db3733e25bf5d6e3e979f081fd5b4e668f53225754c5a5bacc
22+
Size (rust-1.44.0-x86_64-unknown-freebsd.tar.gz) = 123464670 bytes
23+
SHA1 (rust-1.44.0-x86_64-unknown-linux-gnu.tar.gz) = dd577355e6bcf8ef67f19f77836910e90a7ab5ee
24+
RMD160 (rust-1.44.0-x86_64-unknown-linux-gnu.tar.gz) = 465f0c4d9ec7f66868bd6c8cecbef7f12a532a6e
25+
SHA512 (rust-1.44.0-x86_64-unknown-linux-gnu.tar.gz) = 5f13a2f069756daf03965bf183401e670b93e1264eb7c8639c4297573b2d1cbcae07d437154e6296270bfdfd155c23ded66d7c4e0a539c60ddf023a9057255c0
26+
Size (rust-1.44.0-x86_64-unknown-linux-gnu.tar.gz) = 188776305 bytes
27+
SHA1 (rust-1.44.0-x86_64-unknown-linux-musl.tar.gz) = f3321e0d34fdf55800754a0300bc3da8f2c712f1
28+
RMD160 (rust-1.44.0-x86_64-unknown-linux-musl.tar.gz) = f2f513fdd9db61992aa433c9a61b0d05e9e5d7e9
29+
SHA512 (rust-1.44.0-x86_64-unknown-linux-musl.tar.gz) = 54f4dd616e7eaae906ca585aa5834cf194833caa052c04f3e296dae224da79934c7cadfa8a9ff3d89d036c2f2001690acd09514f11025f59d1a3dda62e71a7b0
30+
Size (rust-1.44.0-x86_64-unknown-linux-musl.tar.gz) = 171923245 bytes
31+
SHA1 (rust-1.44.0-x86_64-unknown-netbsd.tar.gz) = 12a20c742baf3f1bed6f2b47c60476a2134e3d78
32+
RMD160 (rust-1.44.0-x86_64-unknown-netbsd.tar.gz) = 595fc6df2b9e16196ce491cb4f215efcf9a5909c
33+
SHA512 (rust-1.44.0-x86_64-unknown-netbsd.tar.gz) = da3760f1f0d4901f7c5f1cf8eac1f809cc8fab78f13ca6ca3f1d5a1e57837ff6ace46f0e752a5caee165630aed0f32302550cc3fdac58be4d4e6308002d946c4
34+
Size (rust-1.44.0-x86_64-unknown-netbsd.tar.gz) = 128799057 bytes
3935
SHA1 (patch-install.sh) = 4dc4edcbda3c9d2b60ea51b5f83cadd5992ba786

0 commit comments

Comments
 (0)