Skip to content

Commit 45ec697

Browse files
committed
rust: upgrade to version 1.70.0.
Pkgsrc changes: * Adjust patches and cargo checksums to new versions. * Adjust to not cross-build to 8.0, due to LLVM using c++17, so adjust USE_LANGUAGES. Upstream changes: Version 1.70.0 (2023-06-01) ========================== Language -------- - [Relax ordering rules for `asm!` operands] (rust-lang/rust#105798) - [Properly allow macro expanded `format_args` invocations to uses captures] (rust-lang/rust#106505) - [Lint ambiguous glob re-exports] (rust-lang/rust#107880) - [Perform const and unsafe checking for expressions in `let _ = expr` position.] (rust-lang/rust#102256) Compiler -------- - [Extend -Cdebuginfo with new options and named aliases] (rust-lang/rust#109808) This provides a smaller version of debuginfo for cases that only need line number information (`-Cdebuginfo=line-tables-only`), which may eventually become the default for `-Cdebuginfo=1`. - [Make `unused_allocation` lint against `Box::new` too] (rust-lang/rust#104363) - [Detect uninhabited types early in const eval] (rust-lang/rust#109435) - [Switch to LLD as default linker for {arm,thumb}v4t-none-eabi] (rust-lang/rust#109721) - [Add tier 3 target `loongarch64-unknown-linux-gnu`] (rust-lang/rust#96971) - [Add tier 3 target for `i586-pc-nto-qnx700` (QNX Neutrino RTOS, version 7.0)] (rust-lang/rust#109173), - [Insert alignment checks for pointer dereferences as debug assertions] (rust-lang/rust#98112) This catches undefined behavior at runtime, and may cause existing code to fail. Refer to Rust's [platform support page][platform-support-doc] for more information on Rust's tiered platform support. Libraries --------- - [Document NonZeroXxx layout guarantees] (rust-lang/rust#94786) - [Windows: make `Command` prefer non-verbatim paths] (rust-lang/rust#96391) - [Implement Default for some alloc/core iterators] (rust-lang/rust#99929) - [Fix handling of trailing bare CR in str::lines] (rust-lang/rust#100311) - [allow negative numeric literals in `concat!`] (rust-lang/rust#106844) - [Add documentation about the memory layout of `Cell`] (rust-lang/rust#106921) - [Use `partial_cmp` to implement tuple `lt`/`le`/`ge`/`gt`] (rust-lang/rust#108157) - [Stabilize `atomic_as_ptr`] (rust-lang/rust#108419) - [Stabilize `nonnull_slice_from_raw_parts`] (rust-lang/rust#97506) - [Partial stabilization of `once_cell`] (rust-lang/rust#105587) - [Stabilize `nonzero_min_max`] (rust-lang/rust#106633) - [Flatten/inline format_args!() and (string and int) literal arguments into format_args!()] (rust-lang/rust#106824) - [Stabilize movbe target feature] (rust-lang/rust#107711) - [don't splice from files into pipes in io::copy] (rust-lang/rust#108283) - [Add a builtin unstable `FnPtr` trait that is implemented for all function pointers] (rust-lang/rust#108080) This extends `Debug`, `Pointer`, `Hash`, `PartialEq`, `Eq`, `PartialOrd`, and `Ord` implementations for function pointers with all ABIs. Stabilized APIs --------------- - [`NonZero*::MIN/MAX`] (https://doc.rust-lang.org/stable/std/num/struct.NonZeroI8.html#associatedconstant.MIN) - [`BinaryHeap::retain`] (https://doc.rust-lang.org/stable/std/collections/struct.BinaryHeap.html#method.retain) - [`Default for std::collections::binary_heap::IntoIter`] (https://doc.rust-lang.org/stable/std/collections/binary_heap/struct.IntoIter.html) - [`Default for std::collections::btree_map::{IntoIter, Iter, IterMut}`] (https://doc.rust-lang.org/stable/std/collections/btree_map/struct.IntoIter.html) - [`Default for std::collections::btree_map::{IntoKeys, Keys}`] (https://doc.rust-lang.org/stable/std/collections/btree_map/struct.IntoKeys.html) - [`Default for std::collections::btree_map::{IntoValues, Values}`] (https://doc.rust-lang.org/stable/std/collections/btree_map/struct.IntoKeys.html) - [`Default for std::collections::btree_map::Range`] (https://doc.rust-lang.org/stable/std/collections/btree_map/struct.Range.html) - [`Default for std::collections::btree_set::{IntoIter, Iter}`] (https://doc.rust-lang.org/stable/std/collections/btree_set/struct.IntoIter.html) - [`Default for std::collections::btree_set::Range`] (https://doc.rust-lang.org/stable/std/collections/btree_set/struct.Range.html) - [`Default for std::collections::linked_list::{IntoIter, Iter, IterMut}`] (https://doc.rust-lang.org/stable/alloc/collections/linked_list/struct.IntoIter.html) - [`Default for std::vec::IntoIter`] (https://doc.rust-lang.org/stable/alloc/vec/struct.IntoIter.html#impl-Default-for-IntoIter%3CT,+A%3E) - [`Default for std::iter::Chain`] (https://doc.rust-lang.org/stable/std/iter/struct.Chain.html) - [`Default for std::iter::Cloned`] (https://doc.rust-lang.org/stable/std/iter/struct.Cloned.html) - [`Default for std::iter::Copied`] (https://doc.rust-lang.org/stable/std/iter/struct.Copied.html) - [`Default for std::iter::Enumerate`] (https://doc.rust-lang.org/stable/std/iter/struct.Enumerate.html) - [`Default for std::iter::Flatten`] (https://doc.rust-lang.org/stable/std/iter/struct.Flatten.html) - [`Default for std::iter::Fuse`] (https://doc.rust-lang.org/stable/std/iter/struct.Fuse.html) - [`Default for std::iter::Rev`] (https://doc.rust-lang.org/stable/std/iter/struct.Rev.html) - [`Default for std::slice::Iter`] (https://doc.rust-lang.org/stable/std/slice/struct.Iter.html) - [`Default for std::slice::IterMut`] (https://doc.rust-lang.org/stable/std/slice/struct.IterMut.html) - [`Rc::into_inner`] (https://doc.rust-lang.org/stable/alloc/rc/struct.Rc.html#method.into_inner) - [`Arc::into_inner`] (https://doc.rust-lang.org/stable/alloc/sync/struct.Arc.html#method.into_inner) - [`std::cell::OnceCell`] (https://doc.rust-lang.org/stable/std/cell/struct.OnceCell.html) - [`Option::is_some_and`] (https://doc.rust-lang.org/stable/std/option/enum.Option.html#method.is_some_and) - [`NonNull::slice_from_raw_parts`] (https://doc.rust-lang.org/stable/std/ptr/struct.NonNull.html#method.slice_from_raw_parts) - [`Result::is_ok_and`] (https://doc.rust-lang.org/stable/std/result/enum.Result.html#method.is_ok_and) - [`Result::is_err_and`] (https://doc.rust-lang.org/stable/std/result/enum.Result.html#method.is_err_and) - [`std::sync::atomic::Atomic*::as_ptr`] (https://doc.rust-lang.org/stable/std/sync/atomic/struct.AtomicU8.html#method.as_ptr) - [`std::io::IsTerminal`] (https://doc.rust-lang.org/stable/std/io/trait.IsTerminal.html) - [`std::os::linux::net::SocketAddrExt`] (https://doc.rust-lang.org/stable/std/os/linux/net/trait.SocketAddrExt.html) - [`std::os::unix::net::UnixDatagram::bind_addr`] (https://doc.rust-lang.org/stable/std/os/unix/net/struct.UnixDatagram.html#method.bind_addr) - [`std::os::unix::net::UnixDatagram::connect_addr`] (https://doc.rust-lang.org/stable/std/os/unix/net/struct.UnixDatagram.html#method.connect_addr) - [`std::os::unix::net::UnixDatagram::send_to_addr`] (https://doc.rust-lang.org/stable/std/os/unix/net/struct.UnixDatagram.html#method.send_to_addr) - [`std::os::unix::net::UnixListener::bind_addr`] (https://doc.rust-lang.org/stable/std/os/unix/net/struct.UnixListener.html#method.bind_addr) - [`std::path::Path::as_mut_os_str`] (https://doc.rust-lang.org/stable/std/path/struct.Path.html#method.as_mut_os_str) - [`std::sync::OnceLock`] (https://doc.rust-lang.org/stable/std/sync/struct.OnceLock.html) Cargo ----- - [Add `CARGO_PKG_README`] (rust-lang/cargo#11645) - [Make `sparse` the default protocol for crates.io] (rust-lang/cargo#11791) - [Accurately show status when downgrading dependencies] (rust-lang/cargo#11839) - [Use registry.default for login/logout] (rust-lang/cargo#11949) - [Stabilize `cargo logout`] (rust-lang/cargo#11950) Misc ---- - [Stabilize rustdoc `--test-run-directory`] (rust-lang/rust#103682) Compatibility Notes ------------------- - [Prevent stable `libtest` from supporting `-Zunstable-options`] (rust-lang/rust#109044) - [Perform const and unsafe checking for expressions in `let _ = expr` position.] (rust-lang/rust#102256) - [WebAssembly targets enable `sign-ext` and `mutable-globals` features in codegen] (rust-lang/rust#109807) This may cause incompatibility with older execution environments. - [Insert alignment checks for pointer dereferences as debug assertions] (rust-lang/rust#98112) This catches undefined behavior at runtime, and may cause existing code to fail. Internal Changes ---------------- These changes do not affect any public interfaces of Rust, but they represent significant improvements to the performance or internals of rustc and related tools. - [Upgrade to LLVM 16] (rust-lang/rust#109474) - [Use SipHash-1-3 instead of SipHash-2-4 for StableHasher] (rust-lang/rust#107925)
1 parent 84dda93 commit 45ec697

8 files changed

+163
-193
lines changed

rust/Makefile

+34-34
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
# $NetBSD: Makefile,v 1.197 2020/09/29 16:45:16 gdt Exp $
22

3-
DISTNAME= rustc-1.69.0-src
3+
DISTNAME= rustc-1.70.0-src
44
PKGNAME= ${DISTNAME:S/rustc/rust/:S/-src//}
55
CATEGORIES= lang
66
MASTER_SITES= https://static.rust-lang.org/dist/
@@ -12,11 +12,11 @@ LICENSE= mit OR apache-2.0
1212

1313
CONFLICTS+= rust-bin-[0-9]*
1414

15-
# LLVM uses gcc7, follow suit. Also, uses -std=c++14
15+
# LLVM requires gcc7, follow suit. Also, uses -std=c++17
1616
GCC_REQD+= 7
1717

1818
USE_GCC_RUNTIME= yes
19-
USE_LANGUAGES= c c++11
19+
USE_LANGUAGES= c c++17
2020
USE_LIBTOOL= yes
2121
USE_TOOLS+= bash grep gmake perl:build pkg-config
2222

@@ -210,49 +210,49 @@ BUILDLINK_TRANSFORM+= opt:x86_64:arm64
210210
DISTFILES:= ${DEFAULT_DISTFILES}
211211

212212
.if ${MACHINE_PLATFORM:MDarwin-*-aarch64} || make(distinfo) || make (makesum) || make(mdi)
213-
RUST_STAGE0_VER= 1.68.2
213+
RUST_STAGE0_VER= 1.69.0
214214
RUST_ARCH:= aarch64-apple-darwin
215215
RUST_STAGE0:= rust-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.gz
216216
RUST_STD_STAGE0:= rust-std-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.gz
217217
DISTFILES:= ${DISTFILES} ${RUST_STAGE0} ${RUST_STD_STAGE0}
218218
.endif
219219
.if ${MACHINE_PLATFORM:MDarwin-*-x86_64} || make(distinfo) || make (makesum) || make(mdi)
220-
RUST_STAGE0_VER= 1.68.2
220+
RUST_STAGE0_VER= 1.69.0
221221
RUST_ARCH:= x86_64-apple-darwin
222222
RUST_STAGE0:= rust-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.gz
223223
RUST_STD_STAGE0:= rust-std-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.gz
224224
DISTFILES:= ${DISTFILES} ${RUST_STAGE0} ${RUST_STD_STAGE0}
225225
.endif
226226
.if ${MACHINE_PLATFORM:MLinux-*-aarch64} || make(distinfo) || make (makesum) || make(mdi)
227-
RUST_STAGE0_VER= 1.68.2
227+
RUST_STAGE0_VER= 1.69.0
228228
RUST_ARCH:= aarch64-unknown-linux-gnu
229229
RUST_STAGE0:= rust-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.gz
230230
RUST_STD_STAGE0:= rust-std-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.gz
231231
DISTFILES:= ${DISTFILES} ${RUST_STAGE0} ${RUST_STD_STAGE0}
232232
.endif
233233
.if ${MACHINE_PLATFORM:MLinux-*-earmv6hf} || make(distinfo) || make (makesum) || make(mdi)
234-
RUST_STAGE0_VER= 1.68.2
234+
RUST_STAGE0_VER= 1.69.0
235235
RUST_ARCH:= arm-unknown-linux-gnueabihf
236236
RUST_STAGE0:= rust-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.gz
237237
RUST_STD_STAGE0:= rust-std-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.gz
238238
DISTFILES:= ${DISTFILES} ${RUST_STAGE0} ${RUST_STD_STAGE0}
239239
.endif
240240
.if ${MACHINE_PLATFORM:MLinux-*-earmv7hf} || make(distinfo) || make (makesum) || make(mdi)
241-
RUST_STAGE0_VER= 1.68.2
241+
RUST_STAGE0_VER= 1.69.0
242242
RUST_ARCH:= armv7-unknown-linux-gnueabihf
243243
RUST_STAGE0:= rust-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.gz
244244
RUST_STD_STAGE0:= rust-std-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.gz
245245
DISTFILES:= ${DISTFILES} ${RUST_STAGE0} ${RUST_STD_STAGE0}
246246
.endif
247247
.if ${MACHINE_PLATFORM:MLinux-*-i386} || make(distinfo) || make (makesum) || make(mdi)
248-
RUST_STAGE0_VER= 1.68.2
248+
RUST_STAGE0_VER= 1.69.0
249249
RUST_ARCH:= i686-unknown-linux-gnu
250250
RUST_STAGE0:= rust-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.gz
251251
RUST_STD_STAGE0:= rust-std-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.gz
252252
DISTFILES:= ${DISTFILES} ${RUST_STAGE0} ${RUST_STD_STAGE0}
253253
.endif
254254
.if ${MACHINE_PLATFORM:MLinux-*-x86_64} || make(distinfo) || make (makesum) || make(mdi)
255-
RUST_STAGE0_VER= 1.68.2
255+
RUST_STAGE0_VER= 1.69.0
256256
RUST_ARCH:= x86_64-unknown-linux-gnu
257257
RUST_STAGE0:= rust-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.gz
258258
RUST_STD_STAGE0:= rust-std-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.gz
@@ -264,7 +264,7 @@ DISTFILES:= ${DISTFILES} ${RUST_STAGE0} ${RUST_STD_STAGE0}
264264
# x86_64-sun-solaris bootstrap and comment out the overrides.
265265
#
266266
.if ${MACHINE_PLATFORM:MSunOS-*-x86_64} || make(distinfo) || make (makesum) || make(mdi)
267-
RUST_STAGE0_VER= 1.68.2
267+
RUST_STAGE0_VER= 1.69.0
268268
RUST_ARCH:= x86_64-unknown-illumos
269269
RUST_STAGE0:= rust-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.gz
270270
SITES.${RUST_STAGE0}= https://us-central.manta.mnx.io/pkgsrc/public/pkg-bootstraps/
@@ -277,14 +277,14 @@ CONFIGURE_ARGS+= --host=${RUST_ARCH}
277277
CONFIGURE_ARGS+= --target=${RUST_ARCH}
278278
.endif
279279
.if ${MACHINE_PLATFORM:MFreeBSD-*-x86_64} || make(distinfo) || make (makesum) || make(mdi)
280-
RUST_STAGE0_VER= 1.68.2
280+
RUST_STAGE0_VER= 1.69.0
281281
RUST_ARCH:= x86_64-unknown-freebsd
282282
RUST_STAGE0:= rust-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.gz
283283
RUST_STD_STAGE0:= rust-std-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.gz
284284
DISTFILES:= ${DISTFILES} ${RUST_STAGE0} ${RUST_STD_STAGE0}
285285
.endif
286286
.if ${MACHINE_PLATFORM:MNetBSD-*-i386} || make(distinfo) || make (makesum) || make(mdi)
287-
RUST_STAGE0_VER= 1.68.2
287+
RUST_STAGE0_VER= 1.69.0
288288
RUST_ARCH= i586-unknown-netbsd
289289
RUST_STAGE0:= rust-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.xz
290290
RUST_STD_STAGE0:= rust-std-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.xz
@@ -304,14 +304,14 @@ pre-build-fix-paxctl:
304304
${TOOLS_PLATFORM.paxctl} +am ${WRKDIR}/rust-bootstrap/bin/rustc
305305
.endif
306306
.if ${MACHINE_PLATFORM:MNetBSD-*-x86_64} || make(distinfo) || make (makesum) || make(mdi)
307-
RUST_STAGE0_VER= 1.68.2
307+
RUST_STAGE0_VER= 1.69.0
308308
RUST_ARCH= x86_64-unknown-netbsd
309309
RUST_STAGE0:= rust-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.xz
310310
RUST_STD_STAGE0:= rust-std-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.xz
311311
DISTFILES:= ${DISTFILES} ${RUST_STAGE0} ${RUST_STD_STAGE0}
312312
.endif
313313
.if ${MACHINE_PLATFORM:MNetBSD-*-powerpc} || make(distinfo) || make (makesum) || make(mdi)
314-
RUST_STAGE0_VER= 1.68.2
314+
RUST_STAGE0_VER= 1.69.0
315315
RUST_ARCH= powerpc-unknown-netbsd
316316

317317
# Cross-built against NetBSD 9.0
@@ -334,7 +334,7 @@ SITES.${RUST_STD_STAGE0}= ${MASTER_SITE_LOCAL:=rust/}
334334

335335
.endif
336336
.if ${MACHINE_PLATFORM:MNetBSD-*-aarch64} || make(distinfo) || make (makesum) || make(mdi)
337-
RUST_STAGE0_VER= 1.68.2
337+
RUST_STAGE0_VER= 1.69.0
338338
RUST_ARCH= aarch64-unknown-netbsd
339339
RUST_STAGE0:= rust-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.xz
340340
RUST_STD_STAGE0:= rust-std-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.xz
@@ -343,7 +343,7 @@ SITES.${RUST_STAGE0}= ${MASTER_SITE_LOCAL:=rust/}
343343
SITES.${RUST_STD_STAGE0}= ${MASTER_SITE_LOCAL:=rust/}
344344
.endif
345345
.if ${MACHINE_PLATFORM:MNetBSD-*-aarch64eb} || make(distinfo) || make (makesum) || make(mdi)
346-
RUST_STAGE0_VER= 1.68.2
346+
RUST_STAGE0_VER= 1.69.0
347347
RUST_ARCH= aarch64_be-unknown-netbsd
348348
RUST_STAGE0:= rust-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.xz
349349
RUST_STD_STAGE0:= rust-std-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.xz
@@ -352,7 +352,7 @@ SITES.${RUST_STAGE0}= ${MASTER_SITE_LOCAL:=rust/}
352352
SITES.${RUST_STD_STAGE0}= ${MASTER_SITE_LOCAL:=rust/}
353353
.endif
354354
.if ${MACHINE_PLATFORM:MNetBSD-*-sparc64} || make(distinfo) || make (makesum) || make(mdi)
355-
RUST_STAGE0_VER= 1.68.2
355+
RUST_STAGE0_VER= 1.69.0
356356
RUST_ARCH= sparc64-unknown-netbsd
357357
RUST_STAGE0:= rust-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.xz
358358
RUST_STD_STAGE0:= rust-std-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.xz
@@ -362,7 +362,7 @@ SITES.${RUST_STD_STAGE0}= ${MASTER_SITE_LOCAL:=rust/}
362362
.endif
363363
.if ${MACHINE_PLATFORM:MNetBSD-*-earmv7hf} || make(distinfo) || make (makesum) || make(mdi)
364364
RUST_ARCH= armv7-unknown-netbsd-eabihf
365-
RUST_STAGE0_VER= 1.68.2
365+
RUST_STAGE0_VER= 1.69.0
366366
RUST_STAGE0:= rust-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.xz
367367
RUST_STD_STAGE0:= rust-std-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.xz
368368
DISTFILES:= ${DISTFILES} ${RUST_STAGE0} ${RUST_STD_STAGE0}
@@ -371,7 +371,7 @@ SITES.${RUST_STD_STAGE0}= ${MASTER_SITE_LOCAL:=rust/}
371371
.endif
372372
.if ${MACHINE_PLATFORM:MNetBSD-*-earmv6hf} || make(distinfo) || make (makesum) || make(mdi)
373373
RUST_ARCH= armv6-unknown-netbsd-eabihf
374-
RUST_STAGE0_VER= 1.68.2
374+
RUST_STAGE0_VER= 1.69.0
375375
RUST_STAGE0:= rust-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.xz
376376
RUST_STD_STAGE0:= rust-std-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.xz
377377
DISTFILES:= ${DISTFILES} ${RUST_STAGE0} ${RUST_STD_STAGE0}
@@ -380,7 +380,7 @@ SITES.${RUST_STD_STAGE0}= ${MASTER_SITE_LOCAL:=rust/}
380380
.endif
381381
.if ${MACHINE_PLATFORM:MNetBSD-*-mipsel} || make(distinfo) || make (makesum) || make(mdi)
382382
RUST_ARCH= mipsel-unknown-netbsd
383-
RUST_STAGE0_VER= 1.68.2
383+
RUST_STAGE0_VER= 1.69.0
384384
RUST_STAGE0:= rust-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.xz
385385
RUST_STD_STAGE0:= rust-std-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.xz
386386
DISTFILES:= ${DISTFILES} ${RUST_STAGE0} ${RUST_STD_STAGE0}
@@ -424,14 +424,14 @@ SUBST_VARS.rpath= PREFIX
424424
#CKSUMS+= a8e8ff94141ffd6760f10e9359a206badc792ce068f3fed8a5b5e06ebe9a72a4
425425

426426
CKSUM_CRATES+= vendor/libc
427-
CKSUMS+= b1c0a1d347b30d45c85429b7236d234f5b2c86b9eec439e897c9371d856c187a
428-
CKSUMS+= 280468ba8d1efca96895eed707a72ec577aef65ac15b10caca0b3124504d9f11
429-
CKSUMS+= 107a4aa396b8383c66e0ace2f941450b4b69146558cdc4d9fbe33eeab51760f1
430-
CKSUMS+= 62169589a535636bee360c767d8014c63ba2042e4d7d3078b118987947b194b8
427+
CKSUMS+= 6442ed05eb390d44a03daa9800af1030f2ee3e61db98675262c227b28de51937
428+
CKSUMS+= ec554c837999c718786debfcfe2241984193751fcd52156323b418d96319aa95
429+
CKSUMS+= 4493317993af390d8aafc2cb7ace4c349dfc9d2451fd666844f04a4fa1f47442
430+
CKSUMS+= ed4f1abfa290a172a65b61f6d5f3b985828dff45c11e09576c7aad9dedfc6500
431431

432-
CKSUM_CRATES+= vendor/libc-0.2.137
433-
CKSUMS+= 77009c0e2e06abf8e81634bb65c22a0ccf9564a7cc64cee62d08b8ea716b8cac
434-
CKSUMS+= fe5911a550e975c2df8ccb96f1195e41f5286609afb53f4a3d28bf7c63b6031c
432+
CKSUM_CRATES+= vendor/libc-0.2.139
433+
CKSUMS+= 107a4aa396b8383c66e0ace2f941450b4b69146558cdc4d9fbe33eeab51760f1
434+
CKSUMS+= 129f7ffc0ebf799f2ed817c443d4de8eede26d35f629387e08951cbcd2914f4a
435435

436436
#CKSUM_CRATES+= vendor/libc-0.2.138
437437

@@ -455,14 +455,14 @@ CKSUMS+= f58085b9d0666ccf62e0ae17fb5dae937c0a86fcc55dc0ae04ad8659e696a49c
455455
CKSUMS+= ea445a2f85068957d0347fa384c8f9c7c2726a65e930f4352d1b10476cddd851
456456

457457
CKSUM_CRATES+= vendor/openssl-src
458-
CKSUMS+= 40cd1069246b552b04fcdfd13eb77b3a89194192f18c426b77377a78abbfd72f
459-
CKSUMS+= f358adc7b69c478ca89a96505f9a28f51cc6ad481bcdd304d5089e112c0904db
460-
CKSUMS+= b3c59089fa4151eb978a55f17e2adff6ceb752d579b64962336b49cefe41776b
461-
CKSUMS+= db49cdc41015692a4dd2076a33d694c3371a6720db176742cb6c509d533a1fcd
458+
CKSUMS+= 090744f85cf99a9b8412c23fca1eabb61eb45d830f0f9f0e7309be2572c1e827
459+
CKSUMS+= 4261f87c06e6505afd9f7bdafe5aebdd153a1c6f928203cec2dd125642d60fc1
460+
CKSUMS+= 9aeed598f844ca5b63cf222052b44fc643d6cb47a879c286b46c34bbbba618df
461+
CKSUMS+= dadfaa4a6a749a3d14a8cb76e25a72627973939f54ca4236182665e4a1fd9640
462462

463463
CKSUM_CRATES+= vendor/openssl-sys
464-
CKSUMS+= d397af804c0b786978867528635fa9148cd2ad0e6abd591ace21b5bd3719c38d
465-
CKSUMS+= 246d1f71852a08745fba8d00f126d2bd7816c9428d568a0d5e4907e69548ab9b
464+
CKSUMS+= d04538b63898180949bc7d9ced4806395011a3f6c5d374d4ebfdf2b30cd9cc33
465+
CKSUMS+= 5972bc8c1549820108b53df23ee1a9fb7c3d40c2c198a855a5afdf563cbafb26
466466

467467
CKSUM_CRATES+= vendor/nix
468468
CKSUMS+= c3e13a2edea54d190a4b051f62efc97953c00b5051a9fda0e39e3bc732a31939

rust/cross.mk

-1
Original file line numberDiff line numberDiff line change
@@ -16,7 +16,6 @@
1616
#CROSS_ROOT= /u/evbarm-armv6hf
1717
#CROSS_ROOT= /u/sparc64
1818
#CROSS_ROOT= /u/macppc
19-
#CROSS_ROOT= /u/9.0-macppc
2019
#CROSS_ROOT= /u/evbarm64
2120
#CROSS_ROOT= /u/evbarm64eb
2221
#CROSS_ROOT= /u/i386

0 commit comments

Comments
 (0)